summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-10-12 00:34:11 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-10-12 00:34:11 +0000
commit46449917d9de1a95a0f372ec3ac5bf10bc0e97ec (patch)
tree8885941c132456164f74085f19efa8f809c48fb1 /games-strategy/warzone2100
parentMarking libwpd-0.8.2 ~ppc64 per bug 108874 (diff)
downloadgentoo-2-46449917d9de1a95a0f372ec3ac5bf10bc0e97ec.tar.gz
gentoo-2-46449917d9de1a95a0f372ec3ac5bf10bc0e97ec.tar.bz2
gentoo-2-46449917d9de1a95a0f372ec3ac5bf10bc0e97ec.zip
Initial import. Original ebuild by <denisdupeyron@msn.com>. Patch submitted by Fabien Zouaoui <fabien@zouaoui.org>. Closing bug #96249.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'games-strategy/warzone2100')
-rw-r--r--games-strategy/warzone2100/ChangeLog11
-rw-r--r--games-strategy/warzone2100/Manifest3
-rw-r--r--games-strategy/warzone2100/files/0.2.2-clparse.c.patch16
-rw-r--r--games-strategy/warzone2100/files/digest-warzone2100-0.2.21
-rw-r--r--games-strategy/warzone2100/metadata.xml5
-rw-r--r--games-strategy/warzone2100/warzone2100-0.2.2.ebuild57
6 files changed, 93 insertions, 0 deletions
diff --git a/games-strategy/warzone2100/ChangeLog b/games-strategy/warzone2100/ChangeLog
new file mode 100644
index 000000000000..4e30d829f028
--- /dev/null
+++ b/games-strategy/warzone2100/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-strategy/warzone2100
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/ChangeLog,v 1.1 2005/10/12 00:34:11 wolf31o2 Exp $
+
+*warzone2100-0.2.2 (12 Oct 2005)
+
+ 12 Oct 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/0.2.2-clparse.c.patch, +metadata.xml, +warzone2100-0.2.2.ebuild:
+ Initial import. Original ebuild by <denisdupeyron@msn.com>. Patch submitted
+ by Fabien Zouaoui <fabien@zouaoui.org>. Closing bug #96249.
+
diff --git a/games-strategy/warzone2100/Manifest b/games-strategy/warzone2100/Manifest
new file mode 100644
index 000000000000..845e142a7636
--- /dev/null
+++ b/games-strategy/warzone2100/Manifest
@@ -0,0 +1,3 @@
+MD5 9e76c302897e454e4f4812dc1b3322e5 files/0.2.2-clparse.c.patch 413
+MD5 c2760647a592be7a727446029eff8d0c files/digest-warzone2100-0.2.2 72
+MD5 55a5d81dacdb1befb3a3293fd897db77 warzone2100-0.2.2.ebuild 1293
diff --git a/games-strategy/warzone2100/files/0.2.2-clparse.c.patch b/games-strategy/warzone2100/files/0.2.2-clparse.c.patch
new file mode 100644
index 000000000000..30056aee3827
--- /dev/null
+++ b/games-strategy/warzone2100/files/0.2.2-clparse.c.patch
@@ -0,0 +1,16 @@
+--- src/clparse.c.origin 2005-09-02 13:27:01.000000000 +0200
++++ src/clparse.c 2005-09-02 20:01:08.000000000 +0200
+@@ -56,6 +56,13 @@
+ pXor = xorString(cl);
+ sprintf(cl2,"%s%s","-",cl);
+
++ // paths Gentoo
++ resSetBaseDir("DATADIR");
++ if (_chdir("DATADIR") != 0)
++ {
++ DBERROR(("Path not found: DATADIR \n"));
++ }
++
+ /* loop through command line */
+ for( i = 1; i < argc; ++i) {
+ tokenType = argv[i];
diff --git a/games-strategy/warzone2100/files/digest-warzone2100-0.2.2 b/games-strategy/warzone2100/files/digest-warzone2100-0.2.2
new file mode 100644
index 000000000000..3dcd4f94d345
--- /dev/null
+++ b/games-strategy/warzone2100/files/digest-warzone2100-0.2.2
@@ -0,0 +1 @@
+MD5 b23fa1896856c3b9ee37b39029e4c532 warzone2100-0.2.2.tar.bz2 31076323
diff --git a/games-strategy/warzone2100/metadata.xml b/games-strategy/warzone2100/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/warzone2100/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-strategy/warzone2100/warzone2100-0.2.2.ebuild b/games-strategy/warzone2100/warzone2100-0.2.2.ebuild
new file mode 100644
index 000000000000..ff0ddca087ed
--- /dev/null
+++ b/games-strategy/warzone2100/warzone2100-0.2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/warzone2100/warzone2100-0.2.2.ebuild,v 1.1 2005/10/12 00:34:11 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="Warzone 2100, the 3D real-time strategy game"
+HOMEPAGE="http://warzone2100.sourceforge.net/"
+SRC_URI="mirror://sourceforge/warzone2100/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mp3 ogg opengl"
+
+DEPEND=">=media-libs/libsdl-1.2.8
+ >=media-libs/sdl-net-1.2.5
+ opengl? ( virtual/opengl )
+ >=media-libs/openal-20040817
+ ogg? ( >=media-libs/libvorbis-1.1.0 media-libs/libogg )
+ mp3? ( >=media-libs/libmad-0.15 )"
+
+src_unpack() {
+ unpack ${A}
+
+ sed s:DATADIR:"$GAMES_DATADIR"/${PN}/: \
+ "${FILESDIR}"/${PV}-clparse.c.patch > \
+ ${T}/${PV}-clparse.c.patch \
+ || die "sed failed"
+
+ sed -i 's: -m32::' ${S}/configure || die
+ sed -i 's:-m32::' ${S}/makerules/common.mk || die
+
+ cd ${S}
+ epatch ${T}/${PV}-clparse.c.patch || die "epatch failed"
+}
+
+src_compile() {
+ # $(use_with cda) ... cda disables ogg/mp3
+ egamesconf \
+ $(use_with opengl) \
+ $(use_with ogg) \
+ $(use_with mp3) \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="${CXXFLAGS}" \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/warzone || die "do executable failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "install data failed"
+ dodoc AUTHORS CHANGELOG README || "install doc failed"
+
+ prepgamesdirs
+}