summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-23 02:14:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-23 02:14:13 +0000
commitb21348c8150e23997aae6bc40ab44ea56c841016 (patch)
tree45f3843ba28b368a8075afef9e347fdaa66a8397 /games-strategy/wesnoth
parentamd64 stable, bug 245707 (diff)
downloadgentoo-2-b21348c8150e23997aae6bc40ab44ea56c841016.tar.gz
gentoo-2-b21348c8150e23997aae6bc40ab44ea56c841016.tar.bz2
gentoo-2-b21348c8150e23997aae6bc40ab44ea56c841016.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog7
-rw-r--r--games-strategy/wesnoth/wesnoth-1.6a.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index e68039f01055..c257d0dce0b2 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.139 2009/03/11 15:13:59 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.140 2009/03/23 02:14:13 mr_bones_ Exp $
+
+*wesnoth-1.6a (23 Mar 2009)
+
+ 23 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org> +wesnoth-1.6a.ebuild:
+ version bump
11 Mar 2009; Brent Baude <ranger@gentoo.org> wesnoth-1.4.7-r1.ebuild:
Marking wesnoth-1.4.7-r1 ppc and ppc64 for bug 255394
diff --git a/games-strategy/wesnoth/wesnoth-1.6a.ebuild b/games-strategy/wesnoth/wesnoth-1.6a.ebuild
new file mode 100644
index 000000000000..61dccd12a700
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.6a.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-1.6a.ebuild,v 1.1 2009/03/23 02:14:13 mr_bones_ Exp $
+
+EAPI=2
+inherit cmake-utils eutils toolchain-funcs flag-o-matic games
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dedicated nls server tinygui"
+
+RDEPEND=">=media-libs/libsdl-1.2.7[X]
+ media-libs/sdl-net
+ >=media-libs/sdl-ttf-2.0.8
+ >=media-libs/sdl-mixer-1.2[vorbis]
+ >=media-libs/sdl-image-1.2[jpeg,png]
+ dev-libs/boost
+ sys-libs/zlib
+ x11-libs/pango
+ media-libs/fontconfig
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ !dedicated? (
+ tinygui? ( media-gfx/imagemagick[jpeg,png] )
+ )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ if use dedicated || use server ; then
+ sed \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_STATEDIR:${GAMES_STATEDIR}:" \
+ -e "s/GAMES_USER_DED/${GAMES_USER_DED}/" \
+ -e "s/GAMES_GROUP/${GAMES_GROUP}/" "${FILESDIR}"/wesnothd.rc \
+ > "${T}"/wesnothd \
+ || die "sed failed"
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ append-flags -fno-stack-protector
+ fi
+ if use dedicated || use server ; then
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_CAMPAIGN_SERVER=TRUE
+ -DENABLE_SERVER=TRUE
+ -DSERVER_UID=${GAMES_USER_DED}
+ -DSERVER_GID=${GAMES_GROUP}
+ -DFIFO_DIR=${GAMES_STATEDIR}/run/wesnothd"
+ else
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_CAMPAIGN_SERVER=FALSE
+ -DENABLE_SERVER=FALSE"
+ fi
+ mycmakeargs="
+ ${mycmakeargs}
+ -DENABLE_GAME=$(use dedicated && echo FALSE || echo TRUE)
+ -DENABLE_NLS=$(use nls && echo TRUE || echo FALSE)
+ -DGUI=$(use tinygui && echo tiny || echo normal)
+ -DENABLE_FRIBIDI=FALSE
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
+ -DPREFERENCES_DIR=.wesnoth
+ -DDATAROOTDIR=${GAMES_DATADIR}
+ -DBINDIR=${GAMES_BINDIR}
+ -DMANDIR=/usr/share/man
+ -DDOCDIR=/usr/share/doc/${PF}"
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ DOCS="README changelog players_changelog" cmake-utils_src_install
+ if use dedicated || use server; then
+ keepdir "${GAMES_STATEDIR}/run/wesnothd"
+ doinitd "${T}"/wesnothd || die "doinitd failed"
+ fi
+ prepgamesdirs
+}