summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-03-03 19:38:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-03-03 19:38:25 +0000
commit0eb772dc94de89ab75555fb24ff8a40ebb8d6dd8 (patch)
tree4c50f592aa721e376f151d0848ae0a6e02bfcfa9 /games-strategy
parentstable (diff)
downloadgentoo-2-0eb772dc94de89ab75555fb24ff8a40ebb8d6dd8.tar.gz
gentoo-2-0eb772dc94de89ab75555fb24ff8a40ebb8d6dd8.tar.bz2
gentoo-2-0eb772dc94de89ab75555fb24ff8a40ebb8d6dd8.zip
version bump
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/crimson/ChangeLog10
-rw-r--r--games-strategy/crimson/crimson-0.5.3.ebuild60
2 files changed, 68 insertions, 2 deletions
diff --git a/games-strategy/crimson/ChangeLog b/games-strategy/crimson/ChangeLog
index 9c952d079802..3dacf9f6c4ee 100644
--- a/games-strategy/crimson/ChangeLog
+++ b/games-strategy/crimson/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/crimson
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/ChangeLog,v 1.27 2007/12/27 18:29:51 mr_bones_ Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/ChangeLog,v 1.28 2009/03/03 19:38:25 mr_bones_ Exp $
+
+*crimson-0.5.3 (03 Mar 2009)
+
+ 03 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +crimson-0.5.3.ebuild:
+ version bump
*crimson-0.5.2 (27 Dec 2007)
diff --git a/games-strategy/crimson/crimson-0.5.3.ebuild b/games-strategy/crimson/crimson-0.5.3.ebuild
new file mode 100644
index 000000000000..ea1f2d4000ce
--- /dev/null
+++ b/games-strategy/crimson/crimson-0.5.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/crimson/crimson-0.5.3.ebuild,v 1.1 2009/03/03 19:38:25 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Tactical war game in the tradition of Battle Isle"
+HOMEPAGE="http://crimson.seul.org/"
+SRC_URI="http://crimson.seul.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test zlib"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/sdl-net
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ test? (
+ =app-text/docbook-xml-dtd-4.2*
+ dev-libs/libxml2
+ )"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-sound \
+ --enable-network \
+ $(use_with zlib) \
+ --enable-cfed \
+ --enable-bi2cf \
+ --enable-comet \
+ --enable-cf2bmp
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ pixmapsdir="/usr/share/pixmaps" \
+ install || die "emake install failed"
+ dodoc NEWS README* THANKS TODO
+ rm -rf "${D}/${GAMES_DATADIR}/applications"
+ make_desktop_entry crimson "Crimson Fields"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ ewarn "Crimson Fields ${PV} is not necessarily save-game compatible with previous versions."
+ echo
+ elog "If you have older save files and you wish to continue those games,"
+ elog "you'll need to remerge the version with which you started"
+ elog "those save-games."
+}