summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-04 20:23:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-04 20:23:59 +0000
commit2ae9fefdb5ffe1e7b331ed12cd0482fe7ebb315a (patch)
tree7024ba649e1f29c061861ed5a16f57262724a9f3 /games-strategy
parentRemove old (diff)
downloadgentoo-2-2ae9fefdb5ffe1e7b331ed12cd0482fe7ebb315a.tar.gz
gentoo-2-2ae9fefdb5ffe1e7b331ed12cd0482fe7ebb315a.tar.bz2
gentoo-2-2ae9fefdb5ffe1e7b331ed12cd0482fe7ebb315a.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog8
-rw-r--r--games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch12
-rw-r--r--games-strategy/glob2/glob2-0.9.4.4.ebuild53
3 files changed, 72 insertions, 1 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index caacc3e3a5ff..c08926b7de6a 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/glob2
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.48 2009/07/13 10:46:02 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.49 2009/09/04 20:23:59 mr_bones_ Exp $
+
+*glob2-0.9.4.4 (04 Sep 2009)
+
+ 04 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +glob2-0.9.4.4.ebuild, +files/glob2-0.9.4.4-gcc44.patch:
+ version bump
13 Jul 2009; Tupone Alfredo <tupone@gentoo.org>
+files/glob2-0.9.4.1-gcc44.patch, glob2-0.9.4.1.ebuild:
diff --git a/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
new file mode 100644
index 000000000000..67aa1a0789c4
--- /dev/null
+++ b/games-strategy/glob2/files/glob2-0.9.4.4-gcc44.patch
@@ -0,0 +1,12 @@
+--- libgag/include/StreamBackend.h.old 2009-07-13 10:52:36.000000000 +0200
++++ libgag/include/StreamBackend.h 2009-07-13 10:52:57.000000000 +0200
+@@ -28,6 +28,9 @@
+ #ifdef putc
+ #undef putc
+ #endif
++#ifdef getc
++#undef getc
++#endif
+
+ namespace GAGCore
+ {
diff --git a/games-strategy/glob2/glob2-0.9.4.4.ebuild b/games-strategy/glob2/glob2-0.9.4.4.ebuild
new file mode 100644
index 000000000000..5ffa6ed07f86
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.9.4.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.4.ebuild,v 1.1 2009/09/04 20:23:59 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="http://dl.sv.nongnu.org/releases/glob2/0.9.4/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ >=dev-libs/boost-1.34
+ media-libs/libsdl[opengl]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libvorbis
+ dev-libs/fribidi
+ media-libs/speex"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc44.patch )
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[:space:]*[0-9]\+\).*/\1/; p }")
+
+ scons \
+ ${sconsopts} \
+ CXXFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ INSTALLDIR="${GAMES_DATADIR}"/${PN} \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ || die "scons failed again"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns data maps scripts || die "doins failed"
+ find "${D}/${GAMES_DATADIR}"/${PN} -name SConscript -exec rm -f {} +
+ newicon data/icons/glob2-icon-48x48.png ${PN}.png
+ make_desktop_entry glob2 "Globulation 2"
+ dodoc README*
+ prepgamesdirs
+}