summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-09-11 21:19:38 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-09-11 21:19:38 +0000
commit3fe27a57240dc2975f33a912fa28c336cdfc274d (patch)
tree9f5e3d387b900e5832c011099bfbe7b94c531432 /games-strategy
parentStable on alpha. (diff)
downloadgentoo-2-3fe27a57240dc2975f33a912fa28c336cdfc274d.tar.gz
gentoo-2-3fe27a57240dc2975f33a912fa28c336cdfc274d.tar.bz2
gentoo-2-3fe27a57240dc2975f33a912fa28c336cdfc274d.zip
Version bump to 0.10.1. Bug #135667
(Portage version: 2.1.1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/attal/ChangeLog8
-rw-r--r--games-strategy/attal/attal-0.10.1.ebuild51
-rw-r--r--games-strategy/attal/files/attal-0.10.1-gcc41.patch33
-rw-r--r--games-strategy/attal/files/attal-0.10.1-gentoo.patch33
-rw-r--r--games-strategy/attal/files/digest-attal-0.10.16
5 files changed, 130 insertions, 1 deletions
diff --git a/games-strategy/attal/ChangeLog b/games-strategy/attal/ChangeLog
index 2a63beb10baf..f96559f07bed 100644
--- a/games-strategy/attal/ChangeLog
+++ b/games-strategy/attal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/attal
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/ChangeLog,v 1.18 2006/06/29 13:39:04 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/ChangeLog,v 1.19 2006/09/11 21:19:38 tupone Exp $
+
+*attal-0.10.1 (11 Sep 2006)
+
+ 11 Sep 2006; <tupone@gentoo.org> +files/attal-0.10.1-gcc41.patch,
+ +files/attal-0.10.1-gentoo.patch, +attal-0.10.1.ebuild:
+ Version bump to 0.10.1. Bug #135667 by Andrei Slavoiu
29 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org> attal-0.9.3.ebuild,
attal-0.9.4.ebuild:
diff --git a/games-strategy/attal/attal-0.10.1.ebuild b/games-strategy/attal/attal-0.10.1.ebuild
new file mode 100644
index 000000000000..2d6ed2da3911
--- /dev/null
+++ b/games-strategy/attal/attal-0.10.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/attal-0.10.1.ebuild,v 1.1 2006/09/11 21:19:38 tupone Exp $
+
+inherit qt4 eutils games
+
+MY_P="${PN}-src-${PV}"
+DESCRIPTION="turn-based strategy game project"
+HOMEPAGE="http://www.attal-thegame.org/"
+SRC_URI="mirror://sourceforge/attal/${MY_P}.tar.bz2
+ mirror://sourceforge/attal/themes-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="$(qt4_min_version 4)
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ mv ../themes .
+ find . -name .cvsignore -print0 | xargs -0 rm -f
+ epatch "${FILESDIR}"/${P}-{gcc41,gentoo}.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ libCommon/displayHelp.cpp \
+ libCommon/attalCommon.cpp \
+ server/duel.cpp \
+ || die "sed failed"
+
+ qmake -o Makefile Makefile.pro || die "qmake failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed" #disable parallel builds
+}
+
+src_install() {
+ dogamesbin attal-* || die "dogamesbin failed"
+ dogameslib.so lib*.so* || die "dogameslib.so failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins HOWTOPLAY.html
+ doins -r themes || die "doins themes failed"
+ dodoc AUTHORS NEWS README TODO
+ prepgamesdirs
+}
diff --git a/games-strategy/attal/files/attal-0.10.1-gcc41.patch b/games-strategy/attal/files/attal-0.10.1-gcc41.patch
new file mode 100644
index 000000000000..161aa3251d2e
--- /dev/null
+++ b/games-strategy/attal/files/attal-0.10.1-gcc41.patch
@@ -0,0 +1,33 @@
+--- libClient/ressourceWin.h.old 2006-09-11 20:57:10.000000000 +0200
++++ libClient/ressourceWin.h 2006-09-11 20:57:24.000000000 +0200
+@@ -54,7 +54,7 @@
+
+ public:
+ /** Construtcor */
+- RessourceWin( QWidget * parent = 0, const char * name = 0, WinResType type );
++ RessourceWin( QWidget * parent, const char * name, WinResType type );
+
+ /** Initialize player */
+ void setPlayer( GenericPlayer * );
+--- libCommon/creature.h.old 2006-05-25 00:50:11.000000000 -0400
++++ libCommon/creature.h 2006-05-25 00:51:51.000000000 -0400
+@@ -38,6 +38,7 @@
+
+ class CreatureHandler;
+ class GenericFightUnit;
++int computeSequence( GenericFightUnit * unit );
+
+ /** Manage a creature */
+ enum CreatureAnimationType {
+
+--- server/serverInterface.h.old 2006-09-11 21:33:00.000000000 +0200
++++ server/serverInterface.h 2006-09-11 21:33:16.000000000 +0200
+@@ -135,7 +135,7 @@
+ void initStatusBar();
+
+ /** Add new action */
+- QAction * ServerInterface::addAction( const QString & label, MENU_ACTIONS id, QSignalMapper * sigmap );
++ QAction *addAction( const QString & label, MENU_ACTIONS id, QSignalMapper * sigmap );
+
+ void addAI(bool hide);
+
diff --git a/games-strategy/attal/files/attal-0.10.1-gentoo.patch b/games-strategy/attal/files/attal-0.10.1-gentoo.patch
new file mode 100644
index 000000000000..ab8d0c605105
--- /dev/null
+++ b/games-strategy/attal/files/attal-0.10.1-gentoo.patch
@@ -0,0 +1,33 @@
+--- libCommon/displayHelp.cpp.old 2006-09-11 22:41:38.000000000 +0200
++++ libCommon/displayHelp.cpp 2006-09-11 22:42:20.000000000 +0200
+@@ -44,7 +44,7 @@
+ _text->mimeSourceFactory()->setFilePath( QString(".") );
+ _text->mimeSourceFactory()->setExtensionType( "html", "text/html;charset=iso8859-1" );
+ _text->setTextFormat( Qt::RichText );
+- _text->setSource( "./HOWTOPLAY.html" );
++ _text->setSource( "@GENTOO_DATADIR@/HOWTOPLAY.html" );
+
+ QPushButton * pbOk = new QPushButton( this );
+ pbOk->setText( QObject::tr( "Ok" ) );
+--- libCommon/attalCommon.cpp.old 2006-09-11 22:45:23.000000000 +0200
++++ libCommon/attalCommon.cpp 2006-09-11 22:47:28.000000000 +0200
+@@ -52,7 +52,7 @@
+ {
+ QDir folder;
+
+- folder.setPath( "./themes/" + THEME );
++ folder.setPath( "@GENTOO_DATADIR@/themes/" + THEME );
+
+ #ifndef WIN32
+ if( ! folder.exists() ) {
+--- server/duel.cpp.old 2006-09-11 22:48:30.000000000 +0200
++++ server/duel.cpp 2006-09-11 22:48:57.000000000 +0200
+@@ -44,7 +44,7 @@
+ {
+ QDir folder;
+
+- folder.setPath( "./themes/" + THEME );
++ folder.setPath( "@GENTOO_DATADIR@/themes/" + THEME );
+ if( ! folder.exists() ) {
+ folder.setPath( "/usr/local/share/games/attal/themes/" + THEME );
+ if( ! folder.exists() ) {
diff --git a/games-strategy/attal/files/digest-attal-0.10.1 b/games-strategy/attal/files/digest-attal-0.10.1
new file mode 100644
index 000000000000..19d75c0a9876
--- /dev/null
+++ b/games-strategy/attal/files/digest-attal-0.10.1
@@ -0,0 +1,6 @@
+MD5 d2e01aaf57a630a6681d372c7f0b8bbb attal-src-0.10.1.tar.bz2 283704
+RMD160 86c92158aacd20f6dc9af22bbd31c7543ae1d953 attal-src-0.10.1.tar.bz2 283704
+SHA256 9dd692daa99dbf3ec14c178b5b3334a6a4085f790749aa58cf45ddf8c5e8649b attal-src-0.10.1.tar.bz2 283704
+MD5 757b6d3e7795ff17a63446ed7dd1efd1 themes-0.10.1.tar.bz2 30744206
+RMD160 7ac400bb73580efdbd8082268b3e1bd7b745f37b themes-0.10.1.tar.bz2 30744206
+SHA256 1f0e9c8b70ac8fd50cf7af492177b88383b230fe400f6ffa4b5641badac5a002 themes-0.10.1.tar.bz2 30744206