summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-09-25 12:12:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-09-25 12:12:28 +0000
commit8f7268aff74b03c978b4ac63631dc5ee9637f0ca (patch)
tree44ccd2166505c426bf2a45abd0f3b308105d3ff8 /games-strategy
parentFix building with make >= 3.82 by not using "dnl" for commenting lines out fr... (diff)
downloadgentoo-2-8f7268aff74b03c978b4ac63631dc5ee9637f0ca.tar.gz
gentoo-2-8f7268aff74b03c978b4ac63631dc5ee9637f0ca.tar.bz2
gentoo-2-8f7268aff74b03c978b4ac63631dc5ee9637f0ca.zip
Fix building with make >= 3.82 wrt #336200 by Diego E. Pettenò.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/xconq/ChangeLog8
-rw-r--r--games-strategy/xconq/files/xconq-make-382.patch46
-rw-r--r--games-strategy/xconq/xconq-7.4.1.ebuild7
3 files changed, 56 insertions, 5 deletions
diff --git a/games-strategy/xconq/ChangeLog b/games-strategy/xconq/ChangeLog
index 960f6502cd5d..44076dff0fbe 100644
--- a/games-strategy/xconq/ChangeLog
+++ b/games-strategy/xconq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/xconq
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.14 2008/12/21 04:31:45 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.15 2010/09/25 12:12:28 ssuominen Exp $
+
+ 25 Sep 2010; Samuli Suominen <ssuominen@gentoo.org> xconq-7.4.1.ebuild,
+ +files/xconq-make-382.patch:
+ Fix building with make >= 3.82 wrt #336200 by Diego E. Pettenò.
21 Dec 2008; Jeremy Olexa <darkside@gentoo.org> xconq-7.4.1.ebuild:
amd64 stable, bug 234953
diff --git a/games-strategy/xconq/files/xconq-make-382.patch b/games-strategy/xconq/files/xconq-make-382.patch
new file mode 100644
index 000000000000..292a3ff35b76
--- /dev/null
+++ b/games-strategy/xconq/files/xconq-make-382.patch
@@ -0,0 +1,46 @@
+http://bugs.gentoo.org/336200
+
+--- kernel/Makefile.in
++++ kernel/Makefile.in
+@@ -176,8 +176,8 @@
+ realclean: distclean
+
+ Makefile: Makefile.in $(host_makefile_frag) $(target_makefile_frag)
+- cd .. \
+- && CONFIG_FILES=kernel/$@ CONFIG_HEADERS= $(SHELL) ./config.status
++ cd .. \
++ && CONFIG_FILES=kernel/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ # All the .h dependencies.
+
+--- tcltk/Makefile.in
++++ tcltk/Makefile.in
+@@ -140,8 +140,8 @@
+ realclean: distclean
+
+ Makefile: $(srcdir)/Makefile.in
+- cd .. \
+- && CONFIG_FILES=tcltk/$@ CONFIG_HEADERS= $(SHELL) ./config.status
++ cd .. \
++ && CONFIG_FILES=tcltk/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ # All the .h dependencies.
+
+--- x11/Makefile.in
++++ x11/Makefile.in
+@@ -240,11 +240,11 @@
+ realclean: distclean
+
+ Makefile: Makefile.in $(host_makefile_frag) $(target_makefile_frag)
+- cd .. \
+- && CONFIG_FILES=x11/$@ CONFIG_HEADERS= $(SHELL) ./config.status
++ cd .. \
++ && CONFIG_FILES=x11/$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ # Dependencies.
+
+ xconq.o: $(ALL_H) $(krnsrcdir)/cmdline.h $(srcdir)/../tcltk/tkconq.h
+
+-ximfapp.o: $(LOW_H) $(krnsrcdir)/imf.h
+\ No newline at end of file
++ximfapp.o: $(LOW_H) $(krnsrcdir)/imf.h
diff --git a/games-strategy/xconq/xconq-7.4.1.ebuild b/games-strategy/xconq/xconq-7.4.1.ebuild
index 2bd9490b95f7..3dfd1b23925f 100644
--- a/games-strategy/xconq/xconq-7.4.1.ebuild
+++ b/games-strategy/xconq/xconq-7.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.13 2008/12/21 04:31:45 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.14 2010/09/25 12:12:28 ssuominen Exp $
inherit eutils games
@@ -24,7 +24,8 @@ src_unpack() {
cd "${S}"
epatch \
"${FILESDIR}"/${PN}-gcc-3.4.patch \
- "${FILESDIR}"/${PN}-tkconq.patch
+ "${FILESDIR}"/${PN}-tkconq.patch \
+ "${FILESDIR}"/${PN}-make-382.patch
}
src_compile() {