summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-06 20:36:47 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-06 20:36:47 +0000
commit91127a10a68c47d15f517f6d225b6396536cee7f (patch)
tree4f7c2ece1f1a10e85b2ac2856d01ed4acfe23524 /games-strategy
parentStealing this for games, since we are the only packages that depend on it. M... (diff)
downloadgentoo-2-91127a10a68c47d15f517f6d225b6396536cee7f.tar.gz
gentoo-2-91127a10a68c47d15f517f6d225b6396536cee7f.tar.bz2
gentoo-2-91127a10a68c47d15f517f6d225b6396536cee7f.zip
Updated gcc41 patch, added freelordsrc patch, and marking stable on ppc/x86. This is for bug #140707 and bug #133538.
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freelords/ChangeLog8
-rw-r--r--games-strategy/freelords/files/freelords-0.3.7-freelordsrc.patch12
-rw-r--r--games-strategy/freelords/files/freelords-0.3.7-gcc41.patch32
-rw-r--r--games-strategy/freelords/freelords-0.3.7.ebuild9
4 files changed, 48 insertions, 13 deletions
diff --git a/games-strategy/freelords/ChangeLog b/games-strategy/freelords/ChangeLog
index af791b741eb0..444f774596a7 100644
--- a/games-strategy/freelords/ChangeLog
+++ b/games-strategy/freelords/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/freelords
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.22 2006/05/28 00:36:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/ChangeLog,v 1.23 2006/09/06 20:36:47 wolf31o2 Exp $
+
+ 06 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +files/freelords-0.3.7-freelordsrc.patch,
+ files/freelords-0.3.7-gcc41.patch, freelords-0.3.7.ebuild:
+ Updated gcc41 patch, added freelordsrc patch, and marking stable on ppc/x86.
+ This is for bug #140707 and bug #133538.
28 May 2006; <Tupone@gentoo.org> +files/freelords-0.3.7-gcc41.patch,
freelords-0.3.7.ebuild:
diff --git a/games-strategy/freelords/files/freelords-0.3.7-freelordsrc.patch b/games-strategy/freelords/files/freelords-0.3.7-freelordsrc.patch
new file mode 100644
index 000000000000..b03e88ffee6c
--- /dev/null
+++ b/games-strategy/freelords/files/freelords-0.3.7-freelordsrc.patch
@@ -0,0 +1,12 @@
+diff -N -u -r freelords-0.3.7-old/freelordsrc.in freelords-0.3.7/freelordsrc.in
+--- freelords-0.3.7-old/freelordsrc.in 2006-05-16 23:21:48.709485176 +0200
++++ freelords-0.3.7/freelordsrc.in 2006-05-16 23:22:10.712637169 +0200
+@@ -1,7 +1,7 @@
+ <?xml version="1.0"?>
+ <freelordsrc version="@VERSION@">
+ <d_datapath>@FREELORDS_DATADIR@</d_datapath>
+- <d_savepath>@HOME@/.freelords</d_savepath>
++
+ <d_lang>C</d_lang>
+ <d_resolution>@SCREEN_RESOLUTION@</d_resolution>
+ <d_fullscreen>@USE_FULLSCREEN@</d_fullscreen>
diff --git a/games-strategy/freelords/files/freelords-0.3.7-gcc41.patch b/games-strategy/freelords/files/freelords-0.3.7-gcc41.patch
index bc1f915974a6..4c58255efd1a 100644
--- a/games-strategy/freelords/files/freelords-0.3.7-gcc41.patch
+++ b/games-strategy/freelords/files/freelords-0.3.7-gcc41.patch
@@ -1,5 +1,6 @@
---- src/ai_smart.h.old 2006-05-28 01:45:00.000000000 +0200
-+++ src/ai_smart.h 2006-05-28 01:45:14.000000000 +0200
+diff -N -u -r freelords-0.3.7-old/src/ai_smart.h freelords-0.3.7/src/ai_smart.h
+--- freelords-0.3.7-old/src/ai_smart.h 2006-05-16 22:38:32.461522747 +0200
++++ freelords-0.3.7/src/ai_smart.h 2006-05-16 22:42:53.180077999 +0200
@@ -106,7 +106,7 @@
Threat *getBiggestDangerTo(City *city, Threatlist *threats);
@@ -9,8 +10,21 @@
};
#endif // AI_SMART_H
---- src/path.h.old 2006-05-28 01:41:44.000000000 +0200
-+++ src/path.h 2006-05-28 01:42:02.000000000 +0200
+diff -N -u -r freelords-0.3.7-old/src/OptionsDialog.cpp freelords-0.3.7/src/OptionsDialog.cpp
+--- freelords-0.3.7-old/src/OptionsDialog.cpp 2006-05-16 22:38:32.921421416 +0200
++++ freelords-0.3.7/src/OptionsDialog.cpp 2006-05-16 22:46:17.083151544 +0200
+@@ -245,7 +245,7 @@
+ d_smooth_scrolling->Hide();
+ d_show_next_player->Hide();
+
+- unsigned int mode = (unsigned int)item->GetUserData();
++ unsigned long mode = (unsigned long)item->GetUserData();
+
+ switch(mode)
+ {
+diff -N -u -r freelords-0.3.7-old/src/path.h freelords-0.3.7/src/path.h
+--- freelords-0.3.7-old/src/path.h 2006-05-16 22:38:32.465521866 +0200
++++ freelords-0.3.7/src/path.h 2006-05-16 22:40:28.655921355 +0200
@@ -60,7 +60,7 @@
/* This function is used to verify if the stack can move on the Tile
* of the given destination point
@@ -20,8 +34,9 @@
/** Validates an existing path.
*
---- src/scroller.h.old 2006-05-28 01:51:44.000000000 +0200
-+++ src/scroller.h 2006-05-28 01:51:56.000000000 +0200
+diff -N -u -r freelords-0.3.7-old/src/scroller.h freelords-0.3.7/src/scroller.h
+--- freelords-0.3.7-old/src/scroller.h 2006-05-16 22:38:32.937417892 +0200
++++ freelords-0.3.7/src/scroller.h 2006-05-16 22:44:24.244013663 +0200
@@ -39,7 +39,7 @@
void eventMouseLeave();
@@ -31,8 +46,9 @@
Uint32 d_timer;
SmallMap * d_smap;
---- src/tooltip.h.old 2006-05-28 01:52:04.000000000 +0200
-+++ src/tooltip.h 2006-05-28 01:52:15.000000000 +0200
+diff -N -u -r freelords-0.3.7-old/src/tooltip.h freelords-0.3.7/src/tooltip.h
+--- freelords-0.3.7-old/src/tooltip.h 2006-05-16 22:38:32.505513055 +0200
++++ freelords-0.3.7/src/tooltip.h 2006-05-16 22:44:49.426465153 +0200
@@ -55,7 +55,7 @@
bool eventMouseMotion(const SDL_MouseMotionEvent* event);
bool eventMouseButtonDown(const SDL_MouseButtonEvent* event);
diff --git a/games-strategy/freelords/freelords-0.3.7.ebuild b/games-strategy/freelords/freelords-0.3.7.ebuild
index 6b30053410e9..8560b671131f 100644
--- a/games-strategy/freelords/freelords-0.3.7.ebuild
+++ b/games-strategy/freelords/freelords-0.3.7.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.7.ebuild,v 1.5 2006/05/28 00:36:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freelords/freelords-0.3.7.ebuild,v 1.6 2006/09/06 20:36:47 wolf31o2 Exp $
inherit eutils games
DESCRIPTION="Free Warlords clone"
-HOMEPAGE="http://freelords.sourceforge.net/"
+HOMEPAGE="http://www.freelords.org/"
SRC_URI="mirror://sourceforge/freelords/${P}.tar.bz2"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ppc x86"
LICENSE="GPL-2"
SLOT="0"
IUSE="editor nls"
@@ -35,7 +35,6 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}"-gcc41.patch
sed -i \
-e "s:\"freelordsrc\":\"${GAMES_SYSCONFDIR}/freelordsrc\":" \
src/main.cpp \
@@ -44,6 +43,8 @@ src_unpack() {
-e '/^localedir/ s:$(datadir):/usr/share:' \
-e 's:$(prefix)/share/locale:/usr/share/locale:' src/Makefile.in \
|| die "sed src/Makefile.in failed"
+ epatch ${FILESDIR}/${P}-gcc41.patch
+ epatch ${FILESDIR}/${P}-freelordsrc.patch
}
src_compile() {