summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-12-10 03:17:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-12-10 03:17:17 +0000
commitb886cf191e77e1724868f53a79c56122ee90f678 (patch)
tree505d3838d8fb25de6af7ebf7670668fafa4b8bd2 /games-strategy
parentstable on amd64. see bug #73936 (Manifest recommit) (diff)
downloadgentoo-2-b886cf191e77e1724868f53a79c56122ee90f678.tar.gz
gentoo-2-b886cf191e77e1724868f53a79c56122ee90f678.tar.bz2
gentoo-2-b886cf191e77e1724868f53a79c56122ee90f678.zip
fix deps and wrapper per bug #68134
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/triplea/ChangeLog5
-rw-r--r--games-strategy/triplea/triplea-0.4.8.ebuild9
2 files changed, 8 insertions, 6 deletions
diff --git a/games-strategy/triplea/ChangeLog b/games-strategy/triplea/ChangeLog
index 9a80aeb81f63..63fe286576f6 100644
--- a/games-strategy/triplea/ChangeLog
+++ b/games-strategy/triplea/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/triplea
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.12 2004/07/24 10:34:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/ChangeLog,v 1.13 2004/12/10 03:17:17 mr_bones_ Exp $
+
+ 09 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org> triplea-0.4.8.ebuild:
+ fix deps and wrapper per bug #68134
24 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> triplea-0.4.8.ebuild:
save games in HomeDir patch from Will McQueen via bug #57062
diff --git a/games-strategy/triplea/triplea-0.4.8.ebuild b/games-strategy/triplea/triplea-0.4.8.ebuild
index 729cc9b84a9c..448c79673964 100644
--- a/games-strategy/triplea/triplea-0.4.8.ebuild
+++ b/games-strategy/triplea/triplea-0.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.4.8.ebuild,v 1.2 2004/07/24 10:34:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/triplea/triplea-0.4.8.ebuild,v 1.3 2004/12/10 03:17:17 mr_bones_ Exp $
inherit games
@@ -19,9 +19,8 @@ RDEPEND="|| (
>=virtual/jdk-1.4
>=virtual/jre-1.4 )"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
app-arch/unzip
- >=dev-java/ant-1.4.1
+ >=dev-java/ant-core-1.4.1
dev-java/junit
jikes? ( >=dev-java/jikes-1.17 )"
@@ -29,7 +28,7 @@ S="${WORKDIR}/${PN}_${MY_PV}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# The sourcecode currently assumes the game is being run from a directory
# one level below the installation root.
@@ -37,7 +36,7 @@ src_unpack() {
#!/bin/sh
cd "${GAMES_DATADIR}/${PN}/lib"
- java -mx96M -cp \\
+ java -cp \\
../data:../lib/plastic-1.2.0.jar:../lib/${P}.jar \\
games.strategy.engine.framework.GameRunner
EOF