summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-11 21:34:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-11 21:34:29 +0000
commitd682868e52667e3eb971da247fbb6b15f335f2f5 (patch)
treed40bf269264d932ccdf6914937a56873eb8a6f42 /games-strategy
parentbackported permission-change code to stable ebuild (diff)
downloadgentoo-2-d682868e52667e3eb971da247fbb6b15f335f2f5.tar.gz
gentoo-2-d682868e52667e3eb971da247fbb6b15f335f2f5.tar.bz2
gentoo-2-d682868e52667e3eb971da247fbb6b15f335f2f5.zip
die backticks
(Portage version: 2.0.53)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/attal/attal-0.9.3.ebuild4
-rw-r--r--games-strategy/attal/attal-0.9.4.ebuild4
-rw-r--r--games-strategy/freecnc/freecnc-0.2.0.ebuild4
-rw-r--r--games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild4
-rw-r--r--games-strategy/spacehulk/spacehulk-1.4.5.ebuild4
-rw-r--r--games-strategy/spacehulk/spacehulk-1.4.99.ebuild4
-rw-r--r--games-strategy/xarchon/xarchon-0.50.ebuild4
-rw-r--r--games-strategy/xscorch/xscorch-0.1.16_rc2.ebuild6
8 files changed, 17 insertions, 17 deletions
diff --git a/games-strategy/attal/attal-0.9.3.ebuild b/games-strategy/attal/attal-0.9.3.ebuild
index 2aa668d28faa..b94fc5b3efe1 100644
--- a/games-strategy/attal/attal-0.9.3.ebuild
+++ b/games-strategy/attal/attal-0.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/attal-0.9.3.ebuild,v 1.4 2005/07/07 04:38:09 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/attal-0.9.3.ebuild,v 1.5 2006/01/11 21:34:29 mr_bones_ Exp $
inherit eutils flag-o-matic games
@@ -34,7 +34,7 @@ src_unpack() {
${QTDIR}/bin/qmake -o Makefile Makefile.pro || die "qmake failed"
sed -i \
"s:\./themes/:${GAMES_DATADIR}/${PN}/themes/:" \
- `grep -Rl '\./themes/' *` \
+ $(grep -Rl '\./themes/' *) \
|| die "fixing theme loc"
find "${WORKDIR}"/themes-${PV} -name .cvsignore -print0 | xargs -0 rm -f
}
diff --git a/games-strategy/attal/attal-0.9.4.ebuild b/games-strategy/attal/attal-0.9.4.ebuild
index aa281523ea21..35f8dd5fb3e2 100644
--- a/games-strategy/attal/attal-0.9.4.ebuild
+++ b/games-strategy/attal/attal-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/attal-0.9.4.ebuild,v 1.1 2005/10/10 07:01:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/attal/attal-0.9.4.ebuild,v 1.2 2006/01/11 21:34:29 mr_bones_ Exp $
inherit eutils flag-o-matic games
@@ -34,7 +34,7 @@ src_unpack() {
"${QTDIR}"/bin/qmake -o Makefile Makefile.pro || die "qmake failed"
sed -i \
"s:\./themes/:${GAMES_DATADIR}/${PN}/themes/:" \
- `grep -Rl '\./themes/' *` \
+ $(grep -Rl '\./themes/' *) \
|| die "fixing theme loc"
find "${WORKDIR}"/themes -name .cvsignore -print0 | xargs -0 rm -f
}
diff --git a/games-strategy/freecnc/freecnc-0.2.0.ebuild b/games-strategy/freecnc/freecnc-0.2.0.ebuild
index 7aa40e6b2531..761d2a168bdd 100644
--- a/games-strategy/freecnc/freecnc-0.2.0.ebuild
+++ b/games-strategy/freecnc/freecnc-0.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.0.ebuild,v 1.6 2005/09/16 02:25:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.0.ebuild,v 1.7 2006/01/11 21:34:29 mr_bones_ Exp $
inherit games flag-o-matic eutils
@@ -29,7 +29,7 @@ src_unpack() {
mkdir data ; cd data
unpack cc1demo1.zip cc1demo2.zip
for f in * ; do
- mv ${f} `echo ${f} | awk '{print tolower($1)}'` || die "moving $f"
+ mv ${f} $(echo ${f} | awk '{print tolower($1)}') || die "moving $f"
done
fi
cd "${S}"
diff --git a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
index 9a26a558e948..a54bd0ca237b 100644
--- a/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
+++ b/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.6 2005/09/16 02:25:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecnc/freecnc-0.2.1.31072003.ebuild,v 1.7 2006/01/11 21:34:29 mr_bones_ Exp $
inherit flag-o-matic eutils games
@@ -30,7 +30,7 @@ src_unpack() {
mkdir data ; cd data
unpack cc1demo1.zip cc1demo2.zip
for f in * ; do
- mv ${f} `echo ${f} | awk '{print tolower($1)}'` || die "moving $f"
+ mv ${f} $(echo ${f} | awk '{print tolower($1)}') || die "moving $f"
done
fi
cd "${S}"
diff --git a/games-strategy/spacehulk/spacehulk-1.4.5.ebuild b/games-strategy/spacehulk/spacehulk-1.4.5.ebuild
index 11006cf22ea5..344735e1ded1 100644
--- a/games-strategy/spacehulk/spacehulk-1.4.5.ebuild
+++ b/games-strategy/spacehulk/spacehulk-1.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.5.ebuild,v 1.5 2005/07/07 04:38:44 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.5.ebuild,v 1.6 2006/01/11 21:34:29 mr_bones_ Exp $
inherit games
@@ -20,7 +20,7 @@ DEPEND="=x11-libs/qt-3*
media-libs/nas"
src_compile() {
- egamesconf `use_with xinerama` || die
+ egamesconf $(use_with xinerama) || die
emake || die "emake failed"
}
diff --git a/games-strategy/spacehulk/spacehulk-1.4.99.ebuild b/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
index ff43c324eaea..6692dded13b6 100644
--- a/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
+++ b/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.99.ebuild,v 1.6 2005/07/07 04:38:44 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.99.ebuild,v 1.7 2006/01/11 21:34:29 mr_bones_ Exp $
inherit games kde-functions
@@ -23,7 +23,7 @@ DEPEND="=x11-libs/qt-3*
src_compile() {
set-qtdir 3
egamesconf \
- `use_with xinerama` \
+ $(use_with xinerama) \
|| die
emake || die "emake failed"
}
diff --git a/games-strategy/xarchon/xarchon-0.50.ebuild b/games-strategy/xarchon/xarchon-0.50.ebuild
index b19b7942160b..37738af9b702 100644
--- a/games-strategy/xarchon/xarchon-0.50.ebuild
+++ b/games-strategy/xarchon/xarchon-0.50.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xarchon/xarchon-0.50.ebuild,v 1.5 2004/06/24 23:30:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xarchon/xarchon-0.50.ebuild,v 1.6 2006/01/11 21:34:29 mr_bones_ Exp $
inherit games
@@ -25,7 +25,7 @@ src_compile() {
|| mysndconf="--disable-sound"
egamesconf \
--enable-network \
- `use_enable joystick` \
+ $(use_enable joystick) \
${mysndconf} \
|| die
emake || die
diff --git a/games-strategy/xscorch/xscorch-0.1.16_rc2.ebuild b/games-strategy/xscorch/xscorch-0.1.16_rc2.ebuild
index 210359722382..4f2d05529768 100644
--- a/games-strategy/xscorch/xscorch-0.1.16_rc2.ebuild
+++ b/games-strategy/xscorch/xscorch-0.1.16_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.1.16_rc2.ebuild,v 1.5 2004/06/24 23:30:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xscorch/xscorch-0.1.16_rc2.ebuild,v 1.6 2006/01/11 21:34:29 mr_bones_ Exp $
inherit eutils games
@@ -47,8 +47,8 @@ src_compile() {
egamesconf \
--enable-network \
--with-readline=maybe \
- `use_with gtk` \
- `use_with gnome` \
+ $(use_with gtk) \
+ $(use_with gnome) \
${myconf} \
|| die
emake || die "emake failed"