summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-06-07 04:02:33 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-06-07 04:02:33 +0000
commitff21fe9d11a8a2bcffe94ca70b6956fe080cb60f (patch)
treed349bead0986a32871dfca52740f2854dcec4d57 /games-strategy
parentVersion bump. (diff)
downloadgentoo-2-ff21fe9d11a8a2bcffe94ca70b6956fe080cb60f.tar.gz
gentoo-2-ff21fe9d11a8a2bcffe94ca70b6956fe080cb60f.tar.bz2
gentoo-2-ff21fe9d11a8a2bcffe94ca70b6956fe080cb60f.zip
EAPI=5; build with --as-needed (bug #510458)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/naev/ChangeLog5
-rw-r--r--games-strategy/naev/naev-0.5.3.ebuild15
2 files changed, 11 insertions, 9 deletions
diff --git a/games-strategy/naev/ChangeLog b/games-strategy/naev/ChangeLog
index e19e188adf15..330993293f1c 100644
--- a/games-strategy/naev/ChangeLog
+++ b/games-strategy/naev/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/naev
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.20 2014/05/15 17:06:17 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/ChangeLog,v 1.21 2014/06/07 04:02:33 mr_bones_ Exp $
+
+ 07 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org> naev-0.5.3.ebuild:
+ EAPI=5; build with --as-needed (bug #510458)
15 May 2014; Ulrich Müller <ulm@gentoo.org> naev-0.5.3.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-strategy/naev/naev-0.5.3.ebuild b/games-strategy/naev/naev-0.5.3.ebuild
index e532a549d3f4..712670d97daa 100644
--- a/games-strategy/naev/naev-0.5.3.ebuild
+++ b/games-strategy/naev/naev-0.5.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.3.ebuild,v 1.8 2014/05/15 17:06:17 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.3.ebuild,v 1.9 2014/06/07 04:02:33 mr_bones_ Exp $
-EAPI=2
-inherit gnome2-utils games
+EAPI=5
+inherit flag-o-matic gnome2-utils games
DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
HOMEPAGE="http://code.google.com/p/naev/"
@@ -33,9 +33,9 @@ src_unpack() {
}
src_configure() {
+ append-libs -lm -lvorbis
egamesconf \
--docdir=/usr/share/doc/${PF} \
- --disable-dependency-tracking \
$(use_enable debug) \
$(use_with openal) \
$(use_with mixer sdlmixer)
@@ -50,18 +50,17 @@ src_install() {
DESTDIR="${D}" \
appicondir=/usr/share/pixmaps \
Graphicsdir=/usr/share/applications \
- install || die
+ install
insinto "${GAMES_DATADIR}"/${PN}
- newins "${DISTDIR}"/ndata-${PV} ndata || die
+ newins "${DISTDIR}"/ndata-${PV} ndata
local res
for res in 16 32 64 128; do
- newicon -s ${res} extras/logos/logo${res}.png naev.png || die
+ newicon -s ${res} extras/logos/logo${res}.png naev.png
done
rm -f "${D}"/usr/share/doc/${PF}/LICENSE
- prepalldocs
prepgamesdirs
}