summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-23 03:18:02 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-23 03:18:02 +0000
commitebccba150c8d7fda13f438148ce37ac255cb76bb (patch)
tree4d7b0a2f78be9b36eb280e7dc3ccde32694b33ac /games-util/joystick
parentstable on ia64 (diff)
downloadgentoo-2-ebccba150c8d7fda13f438148ce37ac255cb76bb.tar.gz
gentoo-2-ebccba150c8d7fda13f438148ce37ac255cb76bb.tar.bz2
gentoo-2-ebccba150c8d7fda13f438148ce37ac255cb76bb.zip
Make sure we build even with older linux-headers #103270 by David Mulford.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-util/joystick')
-rw-r--r--games-util/joystick/ChangeLog6
-rw-r--r--games-util/joystick/files/joystick-MCS-defines.patch27
-rw-r--r--games-util/joystick/joystick-20050720.ebuild10
3 files changed, 41 insertions, 2 deletions
diff --git a/games-util/joystick/ChangeLog b/games-util/joystick/ChangeLog
index 4fa22789b5f3..37682c9c6133 100644
--- a/games-util/joystick/ChangeLog
+++ b/games-util/joystick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-util/joystick
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.2 2005/07/21 07:53:07 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/ChangeLog,v 1.3 2005/08/23 03:18:02 vapier Exp $
+
+ 23 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/joystick-MCS-defines.patch, joystick-20050720.ebuild:
+ Make sure we build even with older linux-headers #103270 by David Mulford.
21 Jul 2005; David Holm <dholm@gentoo.org> joystick-20050720.ebuild:
Added to ~ppc.
diff --git a/games-util/joystick/files/joystick-MCS-defines.patch b/games-util/joystick/files/joystick-MCS-defines.patch
new file mode 100644
index 000000000000..9fa8aad16880
--- /dev/null
+++ b/games-util/joystick/files/joystick-MCS-defines.patch
@@ -0,0 +1,27 @@
+http://bugs.gentoo.org/103270
+
+--- evtest.c
++++ evtest.c
+@@ -254,6 +254,22 @@
+ [ABS_VOLUME] = "Volume", [ABS_MISC] = "Misc",
+ };
+
++/* many of these MSC defines are only in newer linux headers */
++#ifndef MSC_SERIAL
++# define MSC_SERIAL
++#endif 0x00
++#ifndef MSC_PULSELED
++# define MSC_PULSELED 0x01
++#endif
++#ifndef MSC_GESTURE
++# define MSC_GESTURE 0x02
++#endif
++#ifndef MSC_RAW
++# define MSC_RAW 0x03
++#endif
++#ifndef MSC_SCAN
++# define MSC_SCAN 0x04
++#endif
+ char *misc[MSC_MAX + 1] = {
+ [ 0 ... MSC_MAX] = NULL,
+ [MSC_SERIAL] = "Serial", [MSC_PULSELED] = "Pulseled",
diff --git a/games-util/joystick/joystick-20050720.ebuild b/games-util/joystick/joystick-20050720.ebuild
index 583dc329d8cb..7c4dfeb02754 100644
--- a/games-util/joystick/joystick-20050720.ebuild
+++ b/games-util/joystick/joystick-20050720.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20050720.ebuild,v 1.2 2005/07/21 07:53:07 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/joystick/joystick-20050720.ebuild,v 1.3 2005/08/23 03:18:02 vapier Exp $
+
+inherit eutils
DESCRIPTION="joystick testing utilities"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
@@ -15,6 +17,12 @@ DEPEND="sdl? ( media-libs/libsdl )"
S=${WORKDIR}/utils
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/joystick-MCS-defines.patch
+}
+
src_compile() {
local SDL
use sdl && SDL=1 || SDL=0