summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 18:53:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 18:53:23 +0000
commitf832b6aa8af70160dd49b2f91631e66e941b9dbe (patch)
treee28495f9d6e402f2d221775fbef168a3e40e3457 /games-util/qstat/qstat-25b-r1.ebuild
parentAdd local dv USE flag for mjpegtools. (diff)
downloadgentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.tar.gz
gentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.tar.bz2
gentoo-2-f832b6aa8af70160dd49b2f91631e66e941b9dbe.zip
welcome to games-util
Diffstat (limited to 'games-util/qstat/qstat-25b-r1.ebuild')
-rw-r--r--games-util/qstat/qstat-25b-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-util/qstat/qstat-25b-r1.ebuild b/games-util/qstat/qstat-25b-r1.ebuild
new file mode 100644
index 000000000000..25c9e2d9b622
--- /dev/null
+++ b/games-util/qstat/qstat-25b-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/qstat/qstat-25b-r1.ebuild,v 1.1 2003/09/10 18:53:23 vapier Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="Server statics collector supporting many FPS games"
+SRC_URI="http://www.qstat.org/${PN}${PV}.tar.gz"
+HOMEPAGE="http://www.qstat.org"
+
+KEYWORDS="x86"
+LICENSE="Artistic"
+SLOT="0"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${PN}${PV}.tar.gz
+ cd ${S}
+ patch -p1 < ${FILESDIR}/qstat-25b.gcc3-fix
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install () {
+ dobin qstat
+
+ dosym /usr/bin/qstat /usr/bin/quakestat
+
+ dodoc CHANGES.txt COMPILE.txt
+ dohtml template/*
+ dohtml qstatdoc.html
+}