summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-05-04 16:55:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-05-04 16:55:22 +0000
commit0e65540f82e37c3dbc990b60d345c628dbae6074 (patch)
treeeb8c8593247113ba3718e1cca262ce44d750f958 /games-util
parentUse doins instead of dodoc (bug #365809). (diff)
downloadgentoo-2-0e65540f82e37c3dbc990b60d345c628dbae6074.tar.gz
gentoo-2-0e65540f82e37c3dbc990b60d345c628dbae6074.tar.bz2
gentoo-2-0e65540f82e37c3dbc990b60d345c628dbae6074.zip
version bump (bug #365957) submitted by Locke Shinseiko
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/grfcodec/ChangeLog10
-rw-r--r--games-util/grfcodec/grfcodec-5.1.1.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/games-util/grfcodec/ChangeLog b/games-util/grfcodec/ChangeLog
index 03f747001140..70c6ccdd5e53 100644
--- a/games-util/grfcodec/ChangeLog
+++ b/games-util/grfcodec/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/grfcodec
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/ChangeLog,v 1.5 2010/10/15 13:49:56 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/ChangeLog,v 1.6 2011/05/04 16:55:22 mr_bones_ Exp $
+
+*grfcodec-5.1.1 (04 May 2011)
+
+ 04 May 2011; Michael Sterrett <mr_bones_@gentoo.org>
+ +grfcodec-5.1.1.ebuild:
+ version bump (bug #365957) submitted by Locke Shinseiko
15 Oct 2010; Markus Meier <maekke@gentoo.org> grfcodec-0_pre2306.ebuild:
add ~arm, bug #316003
diff --git a/games-util/grfcodec/grfcodec-5.1.1.ebuild b/games-util/grfcodec/grfcodec-5.1.1.ebuild
new file mode 100644
index 000000000000..69650e9d794e
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-5.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/grfcodec-5.1.1.ebuild,v 1.1 2011/05/04 16:55:22 mr_bones_ Exp $
+
+EAPI=3
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+MY_PV=${PV/_rc/-RC}
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/grfcodec"
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://binaries.openttd.org/extra/${PN}/${MY_PV}/${PN}-${MY_PV}-source.tar.gz"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ S=${WORKDIR}/${PN}
+else
+ S=${WORKDIR}/${PN}-${MY_PV}-source
+fi
+
+DEPEND="!games-util/nforenum
+ dev-lang/perl
+ dev-libs/boost
+ media-libs/libpng"
+RDEPEND=""
+
+src_prepare() {
+# Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
+cat > Makefile.local <<-__EOF__
+ CXX = $(tc-getCXX)
+ CXXFLAGS = ${CXXFLAGS}
+ LDOPT = ${LDFLAGS}
+ UPX =
+ V = 1
+ __EOF__
+}
+
+src_install() {
+ dobin ${PN} grf{diff,id,merge} nforenum || die
+ doman docs/*.1 || die
+ dodoc changelog.txt docs/*.txt || die
+}