summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-24 19:08:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-24 19:08:23 +0000
commit3d768a046e25792d1b256ee54696fb1156d96afc (patch)
treef27165ee6f21aca33c88600f9171bf30bea75b82 /games-util
parentadd more use-based deps (bug #260164) (diff)
downloadgentoo-2-3d768a046e25792d1b256ee54696fb1156d96afc.tar.gz
gentoo-2-3d768a046e25792d1b256ee54696fb1156d96afc.tar.bz2
gentoo-2-3d768a046e25792d1b256ee54696fb1156d96afc.zip
EAPI=2; fix building with newer glibc (patch submitted by Michał Górny via bug #260111)
(Portage version: 2.1.6.7/cvs/Linux i686)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/etswitch/ChangeLog9
-rw-r--r--games-util/etswitch/etswitch-0.1.14.ebuild14
-rw-r--r--games-util/etswitch/files/etswitch-0.1.14-glibc.patch12
3 files changed, 24 insertions, 11 deletions
diff --git a/games-util/etswitch/ChangeLog b/games-util/etswitch/ChangeLog
index ba1824846615..9087b8d828fb 100644
--- a/games-util/etswitch/ChangeLog
+++ b/games-util/etswitch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/etswitch
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/etswitch/ChangeLog,v 1.3 2008/11/24 16:27:49 ssuominen Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/etswitch/ChangeLog,v 1.4 2009/02/24 19:08:21 mr_bones_ Exp $
+
+ 24 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/etswitch-0.1.14-glibc.patch, etswitch-0.1.14.ebuild:
+ EAPI=2; fix building with newer glibc (patch submitted by Michał Górny via
+ bug #260111)
24 Nov 2008; <ssuominen@gentoo.org> metadata.xml:
Re-assign to games herd.
diff --git a/games-util/etswitch/etswitch-0.1.14.ebuild b/games-util/etswitch/etswitch-0.1.14.ebuild
index 7f8ee297bef8..2ece4d74a067 100644
--- a/games-util/etswitch/etswitch-0.1.14.ebuild
+++ b/games-util/etswitch/etswitch-0.1.14.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/etswitch/etswitch-0.1.14.ebuild,v 1.5 2008/06/29 10:27:03 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/etswitch/etswitch-0.1.14.ebuild,v 1.6 2009/02/24 19:08:21 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="*nix minimizer for a few games"
@@ -23,15 +24,10 @@ DEPEND="${RDEPEND}
x11-proto/recordproto
x11-proto/xf86vidmodeproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-desktop-entry.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-desktop-entry.patch "${FILESDIR}"/${P}-glibc.patch )
-src_compile() {
+src_configure() {
egamesconf --datadir=/usr/share
- emake || die "emake failed."
}
src_install() {
diff --git a/games-util/etswitch/files/etswitch-0.1.14-glibc.patch b/games-util/etswitch/files/etswitch-0.1.14-glibc.patch
new file mode 100644
index 000000000000..a51862d6722d
--- /dev/null
+++ b/games-util/etswitch/files/etswitch-0.1.14-glibc.patch
@@ -0,0 +1,12 @@
+diff -dupr etswitch-old/src/etswitch.c etswitch-0.1.14/src/etswitch.c
+--- etswitch-old/src/etswitch.c 2009-02-24 11:20:29.594339029 +0100
++++ etswitch-0.1.14/src/etswitch.c 2009-02-24 11:28:12.100463404 +0100
+@@ -461,7 +461,7 @@ int main(int argc, char *argv[]){
+ /* setup lock, fixme */
+ /* use temp var */
+ lock_file = "/tmp/.etswitch.pid"; /* now this isnt failsafe but at least something */
+- lock_fd = open(lock_file, O_CREAT | O_RDWR);
++ lock_fd = open(lock_file, O_CREAT | O_RDWR, 0600);
+ if (lock_fd < 0) {
+ #ifdef DEBUG
+ fprintf(stdout, "'%s' allready exits, will try to open.\n",lock_file);