summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-06 10:47:27 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-06 10:47:27 +0000
commit66db3b3875ec3012f8b75ffb0f7775970bb2ef32 (patch)
tree21cc8723962fae77a7be56989b14e0138f03608c /gnome-base/gconf
parentforgot to add, thanks azarah (diff)
downloadgentoo-2-66db3b3875ec3012f8b75ffb0f7775970bb2ef32.tar.gz
gentoo-2-66db3b3875ec3012f8b75ffb0f7775970bb2ef32.tar.bz2
gentoo-2-66db3b3875ec3012f8b75ffb0f7775970bb2ef32.zip
added some ebuilds I forgot
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/gconf-1.0.4-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnome-base/gconf/gconf-1.0.4-r2.ebuild b/gnome-base/gconf/gconf-1.0.4-r2.ebuild
new file mode 100644
index 000000000000..086366c3fb10
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.0.4-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.4-r2.ebuild,v 1.1 2001/10/06 10:47:27 hallski Exp $
+
+P=GConf-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Gconf"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/GConf/${A}"
+
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=sys-libs/db-3.2.3h
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/gnome-libs-1.4.1.2-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/guile-1.4"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ mkdir intl
+ touch intl/libgettext.h
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}