summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2002-02-13 16:55:10 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2002-02-13 16:55:10 +0000
commit70944a373f89add50814c8076fc6f3a497e03124 (patch)
tree555315d8cd231fda459fb92987527d41af9f3d34 /gnome-base/gconf
parentRestoring to match what Gnome says is gnome-stable. (diff)
downloadgentoo-2-70944a373f89add50814c8076fc6f3a497e03124.tar.gz
gentoo-2-70944a373f89add50814c8076fc6f3a497e03124.tar.bz2
gentoo-2-70944a373f89add50814c8076fc6f3a497e03124.zip
New version. Removed gnome-libs dependency because it really shouldn't be there.
Diffstat (limited to 'gnome-base/gconf')
-rw-r--r--gnome-base/gconf/files/digest-gconf-1.0.81
-rw-r--r--gnome-base/gconf/gconf-1.0.8.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-base/gconf/files/digest-gconf-1.0.8 b/gnome-base/gconf/files/digest-gconf-1.0.8
new file mode 100644
index 000000000000..94b9f10e773b
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-1.0.8
@@ -0,0 +1 @@
+MD5 b0d662f3fa1dbab01796efe695577c74 GConf-1.0.8.tar.gz 1240140
diff --git a/gnome-base/gconf/gconf-1.0.8.ebuild b/gnome-base/gconf/gconf-1.0.8.ebuild
new file mode 100644
index 000000000000..348fc53fe27a
--- /dev/null
+++ b/gnome-base/gconf/gconf-1.0.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-1.0.8.ebuild,v 1.1 2002/02/13 16:55:10 g2boojum Exp $
+
+P=GConf-${PV}
+S=${WORKDIR}/${P}
+DESCRIPTION="Gconf"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/GConf/${P}.tar.gz"
+
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=sys-libs/db-3.2.3h
+ >=gnome-base/oaf-0.6.6-r1"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/guile-1.4"
+
+
+#src_unpack() {
+# unpack ${A}
+# patch -p0 < ${FILESDIR}/gconf-${PV}-gentoo.diff
+#}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ mkdir intl
+ touch intl/libgettext.h
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # Doesn't work with -j 4 (hallski)
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+}