summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2006-08-25 19:44:00 +0000
committerPatrick McLean <chutzpah@gentoo.org>2006-08-25 19:44:00 +0000
commit4162ccd5d5ebbcdb8d850f9f1e87fac95b920a24 (patch)
treefb2252caf0651cf4519f9fd7ebe7068908bea25d /gnome-base/gnome-mount/gnome-mount-0.4-r5.ebuild
parentStable on amd64/x86 wrt bug #144167. (diff)
downloadgentoo-2-4162ccd5d5ebbcdb8d850f9f1e87fac95b920a24.tar.gz
gentoo-2-4162ccd5d5ebbcdb8d850f9f1e87fac95b920a24.tar.bz2
gentoo-2-4162ccd5d5ebbcdb8d850f9f1e87fac95b920a24.zip
New revision, add patch to support mounting NTFS drives with ntfs-3g.
(Portage version: 2.1.1_pre5-r3)
Diffstat (limited to 'gnome-base/gnome-mount/gnome-mount-0.4-r5.ebuild')
-rw-r--r--gnome-base/gnome-mount/gnome-mount-0.4-r5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-base/gnome-mount/gnome-mount-0.4-r5.ebuild b/gnome-base/gnome-mount/gnome-mount-0.4-r5.ebuild
new file mode 100644
index 000000000000..fa4e9547cbaa
--- /dev/null
+++ b/gnome-base/gnome-mount/gnome-mount-0.4-r5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-mount/gnome-mount-0.4-r5.ebuild,v 1.1 2006/08/25 19:44:00 chutzpah Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Wrapper for (un)mounting and ejecting disks"
+HOMEPAGE="http://freedesktop.org/~david/"
+SRC_URI="http://freedesktop.org/~david/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=gnome-base/libgnomeui-2.13
+ >=sys-apps/dbus-0.60
+ >=sys-apps/hal-0.5.7-r1
+ >=x11-libs/gtk+-2.8
+ gnome-base/gnome-keyring
+ >=gnome-base/libglade-2
+ >=gnome-base/gconf-2"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29"
+
+DOCS="AUTHORS ChangeLog COPYING HACKING INSTALL NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fixes for bug #133549, bug #133880, bug #137211
+ epatch ${FILESDIR}/${PN}-hal-no-media-fstab.patch
+
+ # add support for mounting with ntfs-3g
+ epatch ${FILESDIR}/${P}-ntfs3g.patch
+}