summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-09 19:27:42 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-09 19:27:42 +0000
commite73545cc9224cfdd1d6dc1d45a612b8e60057cbe (patch)
tree787ee51ad518f899d8b79abcc21ba2cd253055d6 /gnome-base/gnome-shell
parentRevert PIL virtual change; see bug 471566. (diff)
downloadgentoo-2-e73545cc9224cfdd1d6dc1d45a612b8e60057cbe.tar.gz
gentoo-2-e73545cc9224cfdd1d6dc1d45a612b8e60057cbe.tar.bz2
gentoo-2-e73545cc9224cfdd1d6dc1d45a612b8e60057cbe.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base/gnome-shell')
-rw-r--r--gnome-base/gnome-shell/ChangeLog8
-rw-r--r--gnome-base/gnome-shell/files/gnome-shell-3.8.3-networkmanager-flag.patch200
-rw-r--r--gnome-base/gnome-shell/gnome-shell-3.8.3.ebuild207
3 files changed, 414 insertions, 1 deletions
diff --git a/gnome-base/gnome-shell/ChangeLog b/gnome-base/gnome-shell/ChangeLog
index 31adce4cfb8c..407b12abe740 100644
--- a/gnome-base/gnome-shell/ChangeLog
+++ b/gnome-base/gnome-shell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-shell
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/ChangeLog,v 1.35 2013/06/02 00:03:11 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/ChangeLog,v 1.36 2013/06/09 19:27:42 pacho Exp $
+
+*gnome-shell-3.8.3 (09 Jun 2013)
+
+ 09 Jun 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-shell-3.8.3-networkmanager-flag.patch, +gnome-shell-3.8.3.ebuild:
+ Version bump
02 Jun 2013; Jonathan Callen <abcd@gentoo.org> gnome-shell-3.6.3.1.ebuild,
gnome-shell-3.8.2.ebuild:
diff --git a/gnome-base/gnome-shell/files/gnome-shell-3.8.3-networkmanager-flag.patch b/gnome-base/gnome-shell/files/gnome-shell-3.8.3-networkmanager-flag.patch
new file mode 100644
index 000000000000..54c6d9746533
--- /dev/null
+++ b/gnome-base/gnome-shell/files/gnome-shell-3.8.3-networkmanager-flag.patch
@@ -0,0 +1,200 @@
+ * use config.js (and AC_SUBST HAVE_NETWORKMANAGER appropriately);
+ * take care to not import ui.status.network if nm is disabled;
+ * do not try to reassign to const variables;
+ * no point really in fiddling with the list of installed js files;
+ * don't build shell-mobile-providers if nm is disabled;
+ * use "networkmanager" instead of "network_manager" because THE
+ BIKESHED SHOULD BE BLUE, also because the upstream package name is
+ NetworkManager, not Network_Manager.
+--- a/configure.ac 2013-03-27 17:28:24.000000000 +0100
++++ b/configure.ac 2013-04-02 18:47:05.569818375 +0200
+@@ -94,8 +94,6 @@
+ libcanberra libcanberra-gtk3
+ telepathy-glib >= $TELEPATHY_GLIB_MIN_VERSION
+ polkit-agent-1 >= $POLKIT_MIN_VERSION xfixes
+- libnm-glib libnm-util >= $NETWORKMANAGER_MIN_VERSION
+- libnm-gtk >= $NETWORKMANAGER_MIN_VERSION
+ libsecret-unstable gcr-base-3 >= $GCR_MIN_VERSION)
+
+ PKG_CHECK_MODULES(GNOME_SHELL_JS, gio-2.0 gjs-internals-1.0 >= $GJS_MIN_VERSION)
+@@ -154,6 +157,38 @@
+ [Define if _NL_TIME_FIRST_WEEKDAY is available])
+ fi
+
++AC_ARG_ENABLE(networkmanager,
++ AS_HELP_STRING([--disable-networkmanager],
++ [disable NetworkManager support @<:@default=auto@:>@]),,
++ [enable_networkmanager=auto])
++
++if test "x$enable_networkmanager" != "xno"; then
++ PKG_CHECK_MODULES(NETWORKMANAGER,
++ [libnm-glib
++ libnm-util >= $NETWORKMANAGER_MIN_VERSION
++ libnm-gtk >= $NETWORKMANAGER_MIN_VERSION
++ gnome-keyring-1],
++ [have_networkmanager=yes],
++ [have_networkmanager=no])
++
++ GNOME_SHELL_CFLAGS="$GNOME_SHELL_CFLAGS $NETWORKMANAGER_CFLAGS"
++ GNOME_SHELL_LIBS="$GNOME_SHELL_LIBS $NETWORKMANAGER_LIBS"
++else
++ have_networkmanager="no (disabled)"
++fi
++
++if test "x$have_networkmanager" = "xyes"; then
++ AC_DEFINE(HAVE_NETWORKMANAGER, [1], [Define if we have NetworkManager])
++ AC_SUBST([HAVE_NETWORKMANAGER], [1])
++else
++ if test "x$enable_networkmanager" = "xyes"; then
++ AC_MSG_ERROR([Couldn't find NetworkManager.])
++ fi
++ AC_SUBST([HAVE_NETWORKMANAGER], [0])
++fi
++
++AM_CONDITIONAL(HAVE_NETWORKMANAGER, test "$have_networkmanager" = "yes")
++
+ # Sets GLIB_GENMARSHAL and GLIB_MKENUMS
+ AM_PATH_GLIB_2_0()
+
+@@ -199,3 +234,15 @@
+ man/Makefile
+ ])
+ AC_OUTPUT
++
++echo "
++Build configuration:
++
++ Prefix: ${prefix}
++ Source code location: ${srcdir}
++ Compiler: ${CC}
++ Compiler Warnings: $enable_compile_warnings
++
++ Support for NetworkManager: $have_networkmanager
++ Support for GStreamer recording: $build_recorder
++"
+diff --git a/js/Makefile.am b/js/Makefile.am
+index 323cd1b..d17111a 100644
+--- a/js/Makefile.am
++++ b/js/Makefile.am
+@@ -8,6 +8,7 @@ misc/config.js: misc/config.js.in Makefile
+ sed -e "s|[@]PACKAGE_NAME@|$(PACKAGE_NAME)|g" \
+ -e "s|[@]PACKAGE_VERSION@|$(PACKAGE_VERSION)|g" \
+ -e "s|[@]HAVE_BLUETOOTH@|$(HAVE_BLUETOOTH)|g" \
++ -e "s|[@]HAVE_NETWORKMANAGER@|$(HAVE_NETWORKMANAGER)|g" \
+ -e "s|[@]GETTEXT_PACKAGE@|$(GETTEXT_PACKAGE)|g" \
+ -e "s|[@]datadir@|$(datadir)|g" \
+ -e "s|[@]libexecdir@|$(libexecdir)|g" \
+diff --git a/js/misc/config.js.in b/js/misc/config.js.in
+index 9769104..9c4795d 100644
+--- a/js/misc/config.js.in
++++ b/js/misc/config.js.in
+@@ -6,6 +6,8 @@ const PACKAGE_NAME = '@PACKAGE_NAME@';
+ const PACKAGE_VERSION = '@PACKAGE_VERSION@';
+ /* 1 if gnome-bluetooth is available, 0 otherwise */
+ const HAVE_BLUETOOTH = @HAVE_BLUETOOTH@;
++/* 1 if networkmanager is available, 0 otherwise */
++const HAVE_NETWORKMANAGER = @HAVE_NETWORKMANAGER@;
+ /* gettext package */
+ const GETTEXT_PACKAGE = '@GETTEXT_PACKAGE@';
+ /* locale dir */
+diff --git a/js/ui/panel.js b/js/ui/panel.js
+index cfeb351..3bb13b4 100644
+--- a/js/ui/panel.js
++++ b/js/ui/panel.js
+@@ -933,11 +933,13 @@ if (Config.HAVE_BLUETOOTH)
+ PANEL_ITEM_IMPLEMENTATIONS['bluetooth'] =
+ imports.ui.status.bluetooth.Indicator;
+
+-try {
+- PANEL_ITEM_IMPLEMENTATIONS['network'] =
+- imports.ui.status.network.NMApplet;
+-} catch(e) {
+- log('NMApplet is not supported. It is possible that your NetworkManager version is too old');
++if (Config.HAVE_NETWORKMANAGER) {
++ try {
++ PANEL_ITEM_IMPLEMENTATIONS['network'] =
++ imports.ui.status.network.NMApplet;
++ } catch(e) {
++ log('NMApplet is not supported. It is possible that your NetworkManager version is too old');
++ }
+ }
+
+ const Panel = new Lang.Class({
+diff --git a/js/ui/sessionMode.js b/js/ui/sessionMode.js
+index f802dbd..eec830b 100644
+--- a/js/ui/sessionMode.js
++++ b/js/ui/sessionMode.js
+@@ -10,6 +10,8 @@ const FileUtils = imports.misc.fileUtils;
+ const Main = imports.ui.main;
+ const Params = imports.misc.params;
+
++const Config = imports.misc.config;
++
+ const DEFAULT_MODE = 'restrictive';
+
+ const _modes = {
+@@ -100,7 +102,10 @@ const _modes = {
+ isLocked: false,
+ isPrimary: true,
+ unlockDialog: imports.ui.unlockDialog.UnlockDialog,
+- components: ['networkAgent', 'polkitAgent', 'telepathyClient',
++ components: Config.HAVE_NETWORKMANAGER ?
++ ['networkAgent', 'polkitAgent', 'telepathyClient',
++ 'keyring', 'recorder', 'autorunManager', 'automountManager'] :
++ ['polkitAgent', 'telepathyClient',
+ 'keyring', 'recorder', 'autorunManager', 'automountManager'],
+ panel: {
+ left: ['activities', 'appMenu'],
+
+--- a/src/Makefile.am.old 2013-03-27 10:35:51.763616888 +0100
++++ b/src/Makefile.am 2013-03-27 10:38:09.745425152 +0100
+@@ -116,7 +116,6 @@
+ shell-invert-lightness-effect.h \
+ shell-keybinding-modes.h \
+ shell-mount-operation.h \
+- shell-network-agent.h \
+ shell-perf-log.h \
+ shell-screenshot.h \
+ shell-slicer.h \
+@@ -129,6 +128,10 @@
+ shell-wm.h \
+ shell-xfixes-cursor.h
+
++if HAVE_NETWORKMANAGER
++shell_public_headers_h += shell-network-agent.h
++endif
++
+ shell_private_sources = \
+ gactionmuxer.h \
+ gactionmuxer.c \
+@@ -159,7 +162,6 @@
+ shell-keyring-prompt.h \
+ shell-keyring-prompt.c \
+ shell-mount-operation.c \
+- shell-network-agent.c \
+ shell-perf-log.c \
+ shell-polkit-authentication-agent.h \
+ shell-polkit-authentication-agent.c \
+@@ -177,6 +179,10 @@
+ shell-xfixes-cursor.c \
+ $(NULL)
+
++if HAVE_NETWORKMANAGER
++libgnome_shell_la_SOURCES += shell-network-agent.c
++endif
++
+ libgnome_shell_la_gir_sources = \
+ $(filter-out %-private.h $(shell_private_sources), $(shell_public_headers_h) $(libgnome_shell_la_SOURCES))
+
+@@ -287,7 +293,10 @@
+ libgnome_shell_la_CPPFLAGS = $(gnome_shell_cflags)
+
+ Shell-0.1.gir: libgnome-shell.la St-1.0.gir
+-Shell_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 Soup-2.4 GMenu-3.0 NetworkManager-1.0 NMClient-1.0
++Shell_0_1_gir_INCLUDES = Clutter-1.0 ClutterX11-1.0 Meta-3.0 TelepathyGLib-0.12 Soup-2.4 GMenu-3.0
++if HAVE_NETWORKMANAGER
++Shell_0_1_gir_INCLUDES += NetworkManager-1.0 NMClient-1.0
++endif
+ Shell_0_1_gir_CFLAGS = $(libgnome_shell_la_CPPFLAGS) -I $(srcdir)
+ Shell_0_1_gir_LIBS = libgnome-shell.la
+ Shell_0_1_gir_FILES = $(libgnome_shell_la_gir_sources)
diff --git a/gnome-base/gnome-shell/gnome-shell-3.8.3.ebuild b/gnome-base/gnome-shell/gnome-shell-3.8.3.ebuild
new file mode 100644
index 000000000000..89f37dc31937
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-3.8.3.ebuild
@@ -0,0 +1,207 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-shell/gnome-shell-3.8.3.ebuild,v 1.1 2013/06/09 19:27:42 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit autotools eutils gnome2 multilib pax-utils python-r1
+
+DESCRIPTION="Provides core UI functions for the GNOME 3 desktop"
+HOMEPAGE="http://live.gnome.org/GnomeShell"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="+bluetooth +i18n +networkmanager"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# libXfixes-5.0 needed for pointer barriers
+# TODO: gstreamer support is currently automagical:
+# gstreamer? ( >=media-libs/gstreamer-0.11.92 )
+#
+# gnome-shell/gnome-control-center/mutter/gnome-settings-daemon better to be in sync for 3.8.3
+# https://mail.gnome.org/archives/gnome-announce-list/2013-June/msg00005.html
+COMMON_DEPEND="
+ >=app-accessibility/at-spi2-atk-2.5.3
+ >=dev-libs/atk-2[introspection]
+ >=app-crypt/gcr-3.7.5[introspection]
+ >=dev-libs/glib-2.35:2
+ >=dev-libs/gjs-1.35.8
+ >=dev-libs/gobject-introspection-0.10.1
+ >=x11-libs/gtk+-3.7.9:3[introspection]
+ >=media-libs/clutter-1.13.4:1.0[introspection]
+ >=dev-libs/json-glib-0.13.2
+ >=dev-libs/libcroco-0.6.2:0.6
+ >=gnome-base/gnome-desktop-3.7.90:3=[introspection]
+ >=gnome-base/gsettings-desktop-schemas-3.7.4
+ >=gnome-base/gnome-keyring-3.3.90
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+ gnome-base/libgnome-keyring
+ >=gnome-extra/evolution-data-server-3.5.3:=
+ >=media-libs/gstreamer-0.11.92:1.0
+ >=net-im/telepathy-logger-0.2.4[introspection]
+ >=net-libs/telepathy-glib-0.19[introspection]
+ >=sys-auth/polkit-0.100[introspection]
+ >=x11-libs/libXfixes-5.0
+ >=x11-wm/mutter-3.8.3[introspection]
+ >=x11-libs/startup-notification-0.11
+
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+
+ dev-libs/dbus-glib
+ dev-libs/libxml2:2
+ gnome-base/librsvg
+ media-libs/libcanberra[gtk3]
+ media-libs/mesa
+ >=media-sound/pulseaudio-2
+ >=net-libs/libsoup-2.40:2.4[introspection]
+ x11-libs/libX11
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/pango[introspection]
+ x11-apps/mesa-progs
+
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.5[introspection] )
+ networkmanager? ( >=net-misc/networkmanager-0.9.6[introspection] )
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated using:
+# grep -roe "imports.gi.*" gnome-shell-* | cut -f2 -d: | sort | uniq
+# Each block:
+# 1. Pull in polkit-0.101 for pretty authorization dialogs
+# 2. Introspection stuff needed via imports.gi.*
+# 3. gnome-session is needed for gnome-session-quit
+# 4. Control shell settings
+# 5. xdg-utils needed for xdg-open, used by extension tool
+# 6. gnome-icon-theme-symbolic and dejavu font neeed for various icons & arrows
+# 7. IBus is needed for i18n integration
+# 8. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c
+RDEPEND="${COMMON_DEPEND}
+ >=sys-auth/polkit-0.101[introspection]
+
+ >=app-accessibility/caribou-0.4.8
+ >=gnome-base/gdm-3.5[introspection]
+ >=gnome-base/libgnomekbd-2.91.4[introspection]
+ media-libs/cogl[introspection]
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ sys-power/upower[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+ >=gnome-base/gnome-control-center-3.8.3[bluetooth(+)?]
+
+ x11-misc/xdg-utils
+
+ media-fonts/dejavu
+ x11-themes/gnome-icon-theme-symbolic
+
+ || ( sys-auth/consolekit >=sys-apps/systemd-31 )
+ i18n? ( >=app-i18n/ibus-1.4.99[dconf,gtk3,introspection] )
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.17
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ !!=dev-lang/spidermonkey-1.8.2*
+"
+# libmozjs.so is picked up from /usr/lib while compiling, so block at build-time
+# https://bugs.gentoo.org/show_bug.cgi?id=360413
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ # Fix automagic gnome-bluetooth dep, bug #398145
+ epatch "${FILESDIR}/${PN}-3.7.90-bluetooth-flag.patch"
+
+ # Make networkmanager optional, bug #398593
+ epatch "${FILESDIR}/${PN}-3.8.3-networkmanager-flag.patch"
+
+ # Revert suspend break, upstream bug #693162 (from Debian)
+ epatch "${FILESDIR}/${PN}-3.8.0-suspend.patch"
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # Do not error out on warnings
+ gnome2_src_configure \
+ --enable-man \
+ --disable-jhbuild-wrapper-script \
+ $(use_with bluetooth) \
+ $(use_enable networkmanager) \
+ BROWSER_PLUGIN_DIR="${EPREFIX}"/usr/$(get_libdir)/nsbrowser/plugins
+}
+
+src_install() {
+ gnome2_src_install
+ python_replicate_script "${ED}/usr/bin/gnome-shell-extension-tool"
+ python_replicate_script "${ED}/usr/bin/gnome-shell-perf-tool"
+
+ # Required for gnome-shell on hardened/PaX, bug #398941
+ # Future-proof for >=spidermonkey-1.8.7 following polkit's example
+ if has_version '<dev-lang/spidermonkey-1.8.7'; then
+ pax-mark mr "${ED}usr/bin/gnome-shell"
+ elif has_version '>=dev-lang/spidermonkey-1.8.7[jit]'; then
+ pax-mark m "${ED}usr/bin/gnome-shell"
+ fi
+ # Required for gnome-shell on hardened/PaX #457146 and #457194
+ # PaX EMUTRAMP need to be on
+ if has_version '>=dev-libs/libffi-3.0.13[pax_kernel]'; then
+ pax-mark E "${ED}usr/bin/gnome-shell"
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! has_version 'media-libs/gst-plugins-good:1.0' || \
+ ! has_version 'media-plugins/gst-plugins-vpx:1.0'; then
+ ewarn "To make use of GNOME Shell's built-in screen recording utility,"
+ ewarn "you need to either install media-libs/gst-plugins-good:1.0"
+ ewarn "and media-plugins/gst-plugins-vpx:1.0, or use dconf-editor to change"
+ ewarn "apps.gnome-shell.recorder/pipeline to what you want to use."
+ fi
+
+ if ! has_version ">=x11-base/xorg-server-1.11"; then
+ ewarn "If you use multiple screens, it is highly recommended that you"
+ ewarn "upgrade to >=x11-base/xorg-server-1.11 to be able to make use of"
+ ewarn "pointer barriers which will make it easier to use hot corners."
+ fi
+
+ if has_version "<x11-drivers/ati-drivers-12"; then
+ ewarn "GNOME Shell has been reported to show graphical corruption under"
+ ewarn "x11-drivers/ati-drivers-11.*; you may want to use GNOME in"
+ ewarn "fallback mode, or switch to open-source drivers."
+ fi
+
+ if has_version "media-libs/mesa[video_cards_radeon]" ||
+ has_version "media-libs/mesa[video_cards_r300]" ||
+ has_version "media-libs/mesa[video_cards_r600]"; then
+ elog "GNOME Shell is unstable under classic-mode r300/r600 mesa drivers."
+ elog "Make sure that gallium architecture for r300 and r600 drivers is"
+ elog "selected using 'eselect mesa'."
+ if ! has_version "media-libs/mesa[gallium]"; then
+ ewarn "You will need to emerge media-libs/mesa with USE=gallium."
+ fi
+ fi
+
+ if has_version "media-libs/mesa[video_cards_intel]" ||
+ has_version "media-libs/mesa[video_cards_i915]" ||
+ has_version "media-libs/mesa[video_cards_i965]"; then
+ elog "GNOME Shell is unstable under gallium-mode i915/i965 mesa drivers."
+ elog "Make sure that classic architecture for i915 and i965 drivers is"
+ elog "selected using 'eselect mesa'."
+ if ! has_version "media-libs/mesa[classic]"; then
+ ewarn "You will need to emerge media-libs/mesa with USE=classic."
+ fi
+ fi
+}