summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-02 11:55:03 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-02 11:55:03 +0000
commit378fcbf22d8f39645a6a38b8259fb04bb42fd4d5 (patch)
tree3a9aabd7836d175096f0c5b1cc0216fb944d3272 /gnome-base/gnome-vfs/files
parentVersion bump. (diff)
downloadgentoo-2-378fcbf22d8f39645a6a38b8259fb04bb42fd4d5.tar.gz
gentoo-2-378fcbf22d8f39645a6a38b8259fb04bb42fd4d5.tar.bz2
gentoo-2-378fcbf22d8f39645a6a38b8259fb04bb42fd4d5.zip
Version bump. Do not build tests if not needed, bug #226221. Disable broken test, bug #285706. Do not install *.la files for gnome-vfs modules.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/gnome-vfs/files')
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.24.0-uuid-mount.patch38
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-build-tests-asneeded.patch25
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-disable-test-async-cancel.patch24
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-home_dir_fakeroot.patch155
4 files changed, 233 insertions, 9 deletions
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.24.0-uuid-mount.patch b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.0-uuid-mount.patch
index 364834875fe9..e76a9837136a 100644
--- a/gnome-base/gnome-vfs/files/gnome-vfs-2.24.0-uuid-mount.patch
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.0-uuid-mount.patch
@@ -1,11 +1,28 @@
-# Prevent gnome-vfs to show duplicate volumes due to LABEL and UUID in /etc/fstab
-#
-# Upstream: http://bugzilla.gnome.org/show_bug.cgi?id=357156
-# Gentoo: https://bugs.gentoo.org/attachment.cgi?id=131308
-# Similar to http://patches.ubuntu.com/by-release/extracted/ubuntu/g/gnome-vfs/1:2.24.0-1ubuntu2/15_uuid_mount.patch
---- a/libgnomevfs/gnome-vfs-unix-mounts.c 2007-04-10 15:03:59.000000000 +0300
-+++ b/libgnomevfs/gnome-vfs-unix-mounts.c 2007-09-18 17:48:49.000000000 +0300
-@@ -290,6 +290,15 @@ _gnome_vfs_get_current_unix_mounts (GLis
+From 8427c2daf543353f42b932b5137b6ec590f6589b Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 2 Oct 2010 00:42:31 +0200
+Subject: [PATCH 7/9] Prevent duplicated volumes, bug #193083
+
+---
+ libgnomevfs/gnome-vfs-unix-mounts.c | 39 +++++++++++++++++++++++++++++++++-
+ 1 files changed, 37 insertions(+), 2 deletions(-)
+
+diff --git a/libgnomevfs/gnome-vfs-unix-mounts.c b/libgnomevfs/gnome-vfs-unix-mounts.c
+index 51a009b..3eee305 100644
+--- a/libgnomevfs/gnome-vfs-unix-mounts.c
++++ b/libgnomevfs/gnome-vfs-unix-mounts.c
+@@ -40,6 +40,10 @@
+ #ifdef HAVE_POLL_H
+ #include <poll.h>
+ #endif
++
++#include <limits.h>
++#include <stdlib.h>
++
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <sys/time.h>
+@@ -290,6 +294,15 @@ _gnome_vfs_get_current_unix_mounts (GList **return_list)
mount_entry->mount_path = g_strdup (mntent->mnt_dir);
mount_entry->device_path = g_strdup (mntent->mnt_fsname);
@@ -21,7 +38,7 @@
mount_entry->filesystem_type = g_strdup (mntent->mnt_type);
g_hash_table_insert (mounts_hash,
-@@ -571,9 +580,31 @@ _gnome_vfs_get_unix_mount_table (GList *
+@@ -571,9 +584,31 @@ _gnome_vfs_get_unix_mount_table (GList **return_list)
}
mount_entry = g_new0 (GnomeVFSUnixMountPoint, 1);
@@ -55,3 +72,6 @@
mount_entry->filesystem_type = g_strdup (mntent->mnt_type);
#ifdef HAVE_HASMNTOPT
+--
+1.7.3
+
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-build-tests-asneeded.patch b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-build-tests-asneeded.patch
new file mode 100644
index 000000000000..45ca015573f0
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-build-tests-asneeded.patch
@@ -0,0 +1,25 @@
+From b7dabab33e00bdbd8b566ca058a1bce7dec2b77d Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 2 Oct 2010 01:45:21 +0200
+Subject: [PATCH 8/9] Do not build tests unless required
+
+---
+ test/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/test/Makefile.am b/test/Makefile.am
+index 5b0992e..a1aefa0 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -14,7 +14,7 @@ else
+ platform_only_programs = test-dns-sd test-symlinks test-parse-ls-lga
+ endif
+
+-noinst_PROGRAMS = \
++check_PROGRAMS = \
+ test-acl \
+ test-address \
+ test-async \
+--
+1.7.3
+
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-disable-test-async-cancel.patch b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-disable-test-async-cancel.patch
new file mode 100644
index 000000000000..2684c92ec098
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-disable-test-async-cancel.patch
@@ -0,0 +1,24 @@
+From 390c1f6c06917f54cfacd5f85834d02c231cc2ea Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 2 Oct 2010 01:46:31 +0200
+Subject: [PATCH 9/9] Disable broken test, bug #285706, upstream #618089
+
+---
+ test/Makefile.am | 1 -
+ 1 files changed, 0 insertions(+), 1 deletions(-)
+
+diff --git a/test/Makefile.am b/test/Makefile.am
+index a1aefa0..c18f2e4 100644
+--- a/test/Makefile.am
++++ b/test/Makefile.am
+@@ -62,7 +62,6 @@ TESTS_ENVIRONMENT = GNOME_VFS_MODULE_PATH=$(top_builddir)/modules/.libs \
+ SRCDIR=$(srcdir)
+ TESTS = test-acl \
+ test-address \
+- test-async-cancel \
+ test-escape \
+ test-uri \
+ $(srcdir)/auto-test
+--
+1.7.3
+
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-home_dir_fakeroot.patch b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-home_dir_fakeroot.patch
new file mode 100644
index 000000000000..991286aa4de6
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.4-home_dir_fakeroot.patch
@@ -0,0 +1,155 @@
+From 01dba45f0d15b7e23f21d19776d64f69879cd27a Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Sat, 2 Oct 2010 00:41:01 +0200
+Subject: [PATCH 5/9] Fix to identify ${HOME} (#200897)
+
+Thanks to debian folks.
+---
+ libgnomevfs/gnome-vfs-application-registry.c | 2 +-
+ libgnomevfs/gnome-vfs-init.c | 3 +-
+ libgnomevfs/gnome-vfs-private-utils.c | 52 ++++++++++++++++++++++++++
+ libgnomevfs/gnome-vfs-private-utils.h | 2 +
+ modules/file-method.c | 6 +-
+ 5 files changed, 60 insertions(+), 5 deletions(-)
+
+diff --git a/libgnomevfs/gnome-vfs-application-registry.c b/libgnomevfs/gnome-vfs-application-registry.c
+index 0b11cc5..051ea44 100644
+--- a/libgnomevfs/gnome-vfs-application-registry.c
++++ b/libgnomevfs/gnome-vfs-application-registry.c
+@@ -965,7 +965,7 @@ gnome_vfs_application_registry_init (void)
+ NULL);
+ gnome_registry_dir.system_dir = TRUE;
+
+- user_registry_dir.dirname = g_build_filename (g_get_home_dir(),
++ user_registry_dir.dirname = g_build_filename (gnome_vfs_get_home_dir(),
+ ".gnome",
+ "application-info",
+ NULL);
+diff --git a/libgnomevfs/gnome-vfs-init.c b/libgnomevfs/gnome-vfs-init.c
+index e3fd5d9..c07cf06 100644
+--- a/libgnomevfs/gnome-vfs-init.c
++++ b/libgnomevfs/gnome-vfs-init.c
+@@ -118,7 +118,8 @@ gnome_vfs_init (void)
+ char *bogus_argv[2] = { "dummy", NULL };
+ */
+
+- if (!ensure_dot_gnome_exists ()) {
++ /* The first call also checks that ~/.gnome2 is writable. */
++ if (!gnome_vfs_get_home_dir ()) {
+ return FALSE;
+ }
+
+diff --git a/libgnomevfs/gnome-vfs-private-utils.c b/libgnomevfs/gnome-vfs-private-utils.c
+index 7fafde3..7ad8fbc 100644
+--- a/libgnomevfs/gnome-vfs-private-utils.c
++++ b/libgnomevfs/gnome-vfs-private-utils.c
+@@ -34,6 +34,7 @@
+ #include "gnome-vfs-uri.h"
+ #include <errno.h>
+ #include <glib.h>
++#include <glib/gstdio.h>
+ #include <gconf/gconf-client.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -1085,3 +1086,54 @@ _gnome_vfs_winsock_strerror (int error)
+ }
+ #endif
+
++static gboolean
++ensure_dot_gnome_exists (gchar *home_dir)
++{
++ gboolean retval = TRUE;
++ gchar *dirname;
++
++ dirname = g_build_filename (home_dir, ".gnome2", NULL);
++
++ if (!g_file_test (dirname, G_FILE_TEST_EXISTS)) {
++ if (g_mkdir (dirname, S_IRWXU) != 0) {
++ g_warning ("Unable to create ~/.gnome2 directory: %s",
++ g_strerror (errno));
++ retval = FALSE;
++ }
++ } else if (!g_file_test (dirname, G_FILE_TEST_IS_DIR)) {
++ g_warning ("Error: ~/.gnome2 must be a directory.");
++ retval = FALSE;
++ }
++
++ g_free (dirname);
++ return retval;
++}
++
++/**
++ * gnome_vfs_get_home_dir:
++ *
++ * If ~/.gnome2 is writable, return the home directory
++ * Otherwise, return the contents of the HOME environment variable
++ *
++ * Return value: home directory if successful, NULL otherwise.
++ * Do not free the value returned.
++ */
++const gchar *
++gnome_vfs_get_home_dir (void)
++{
++ static gchar *home = NULL;
++
++ if (home == NULL) {
++ gchar *tmp = g_get_home_dir ();
++ if (ensure_dot_gnome_exists (tmp)) {
++ home = g_strdup (tmp);
++ } else {
++ gchar *tmp2 = g_getenv ("HOME");
++ if (!g_str_equal (tmp, tmp2) && ensure_dot_gnome_exists (tmp2)) {
++ home = g_strdup (tmp2);
++ }
++ }
++ }
++
++ return home;
++}
+diff --git a/libgnomevfs/gnome-vfs-private-utils.h b/libgnomevfs/gnome-vfs-private-utils.h
+index 981c6d9..fe282a2 100644
+--- a/libgnomevfs/gnome-vfs-private-utils.h
++++ b/libgnomevfs/gnome-vfs-private-utils.h
+@@ -124,6 +124,8 @@ const char *_gnome_vfs_winsock_strerror (int error);
+
+ #endif
+
++const gchar *gnome_vfs_get_home_dir (void);
++
+ G_END_DECLS
+
+ #endif /* _GNOME_VFS_PRIVATE_UTILS_H */
+diff --git a/modules/file-method.c b/modules/file-method.c
+index 37e4853..7265e58 100644
+--- a/modules/file-method.c
++++ b/modules/file-method.c
+@@ -1531,7 +1531,7 @@ save_trash_entry_cache (void)
+ GList *p;
+ char *buffer, *escaped_path, *escaped_mount_point;
+
+- cache_file_parent = append_to_path (g_get_home_dir (), TRASH_ENTRY_CACHE_PARENT);
++ cache_file_parent = append_to_path (gnome_vfs_get_home_dir (), TRASH_ENTRY_CACHE_PARENT);
+ cache_file_path = append_to_path (cache_file_parent, TRASH_ENTRY_CACHE_NAME);
+
+ if (mkdir_recursive (cache_file_parent, 0777) != 0) {
+@@ -1670,7 +1670,7 @@ read_saved_cached_trash_entries (void)
+ cached_trash_directories = NULL;
+
+ /* read in the entries from disk */
+- cache_file_path = g_build_filename (g_get_home_dir (),
++ cache_file_path = g_build_filename (gnome_vfs_get_home_dir (),
+ TRASH_ENTRY_CACHE_PARENT,
+ TRASH_ENTRY_CACHE_NAME,
+ NULL);
+@@ -1942,7 +1942,7 @@ do_find_directory (GnomeVFSMethod *method,
+ return GNOME_VFS_ERROR_INVALID_URI;
+
+ /* We will need the URI and the stat structure for the home directory. */
+- home_directory = g_get_home_dir ();
++ home_directory = gnome_vfs_get_home_dir ();
+
+ if (gnome_vfs_context_check_cancellation (context)) {
+ g_free (full_name_near);
+--
+1.7.3
+