summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-20 16:06:18 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-20 16:06:18 +0000
commit151ec41ae0585c8c9c4148b54c68294e2b4bd0db (patch)
tree8e24d4c66f150944d9faaed52fbb4b6b80bf49a5 /gnome-base/librsvg/librsvg-2.34.2.ebuild
parentVersion bump, remove old. (diff)
downloadgentoo-2-151ec41ae0585c8c9c4148b54c68294e2b4bd0db.tar.gz
gentoo-2-151ec41ae0585c8c9c4148b54c68294e2b4bd0db.tar.bz2
gentoo-2-151ec41ae0585c8c9c4148b54c68294e2b4bd0db.zip
Version bump, remove old.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/librsvg/librsvg-2.34.2.ebuild')
-rw-r--r--gnome-base/librsvg/librsvg-2.34.2.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/gnome-base/librsvg/librsvg-2.34.2.ebuild b/gnome-base/librsvg/librsvg-2.34.2.ebuild
new file mode 100644
index 000000000000..d7c844e0c61f
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.34.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.34.2.ebuild,v 1.1 2011/11/20 16:06:18 pacho Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="no"
+
+inherit gnome2 multilib eutils autotools
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="http://librsvg.sourceforge.net/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc +gtk gtk3 +introspection tools"
+
+RDEPEND=">=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=dev-libs/glib-2.24:2
+ >=x11-libs/cairo-1.2
+ >=x11-libs/pango-1.10
+ >=dev-libs/libxml2-2.4.7:2
+ >=dev-libs/libcroco-0.6.1
+ || ( x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2 )
+ gtk? ( >=x11-libs/gtk+-2.16:2 )
+ gtk3? ( >=x11-libs/gtk+-2.90.0:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12
+ doc? ( >=dev-util/gtk-doc-1.13 )
+ >=dev-util/gtk-doc-am-1.13"
+# >=dev-util/gtk-doc-am-1.13 needed by eautoreconf
+
+pkg_setup() {
+ # croco is forced on to respect SVG specification
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable tools)
+ $(use_enable gtk gtk-theme)
+ $(use_enable introspection)
+ --with-croco
+ --enable-pixbuf-loader"
+ use gtk && ! use gtk3 && G2CONF+=" --with-gtk=2.0"
+ use gtk && use gtk3 && G2CONF+=" --with-gtk=both"
+ ! use gtk && use gtk3 && G2CONF+=" --with-gtk=3.0 --enable-gtk-theme"
+
+ DOCS="AUTHORS ChangeLog README NEWS TODO"
+}
+
+src_prepare() {
+ # Fix automagic gtk+ dependency, bug #371290
+ epatch "${FILESDIR}/${PN}-2.34.0-automagic-gtk.patch"
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+
+ tmp_file=$(mktemp --suffix=gdk_pixbuf_ebuild)
+ # be atomic!
+ gdk-pixbuf-query-loaders > "${tmp_file}"
+ if [ "${?}" = "0" ]; then
+ cat "${tmp_file}" > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+ else
+ ewarn "Cannot update loaders.cache, gdk-pixbuf-query-loaders failed to run"
+ fi
+ rm "${tmp_file}"
+}
+
+pkg_postrm() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+
+ tmp_file=$(mktemp --suffix=gdk_pixbuf_ebuild)
+ # be atomic!
+ gdk-pixbuf-query-loaders > "${tmp_file}"
+ if [ "${?}" = "0" ]; then
+ cat "${tmp_file}" > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+ else
+ ewarn "Cannot update loaders.cache, gdk-pixbuf-query-loaders failed to run"
+ fi
+ rm "${tmp_file}"
+}