summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2006-08-18 19:14:57 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2006-08-18 19:14:57 +0000
commit4472cad8ba8701caa372b32e9abdb68a56e2aa92 (patch)
tree2229f3c988d44b480f47e164662851d659a62bfb /gnome-base/orbit/orbit-2.14.2.ebuild
parentFixed EOLs in make.defaults. (diff)
downloadgentoo-2-4472cad8ba8701caa372b32e9abdb68a56e2aa92.tar.gz
gentoo-2-4472cad8ba8701caa372b32e9abdb68a56e2aa92.tar.bz2
gentoo-2-4472cad8ba8701caa372b32e9abdb68a56e2aa92.zip
fix orbit-2* ebuilds to unset IDL_DIR before compiling (bug #58540)
(Portage version: 2.1.1_pre5-r2)
Diffstat (limited to 'gnome-base/orbit/orbit-2.14.2.ebuild')
-rw-r--r--gnome-base/orbit/orbit-2.14.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnome-base/orbit/orbit-2.14.2.ebuild b/gnome-base/orbit/orbit-2.14.2.ebuild
index d953369ca719..a05477dac164 100644
--- a/gnome-base/orbit/orbit-2.14.2.ebuild
+++ b/gnome-base/orbit/orbit-2.14.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.2.ebuild,v 1.2 2006/07/26 04:38:28 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.2.ebuild,v 1.3 2006/08/18 19:14:57 compnerd Exp $
inherit gnome2
@@ -33,3 +33,12 @@ DEPEND="${RDEPEND}
MAKEOPTS="${MAKEOPTS} -j1"
DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}