summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-24 17:55:10 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-24 17:55:10 +0000
commit1f13175696f19f8c516f64d567def56f1c5c92b2 (patch)
tree6257c815f02d6dbef589b047fdc25aaeefc18c30 /gnome-base
parentVersion bump for Gnome 3.10 (diff)
downloadgentoo-2-1f13175696f19f8c516f64d567def56f1c5c92b2.tar.gz
gentoo-2-1f13175696f19f8c516f64d567def56f1c5c92b2.tar.bz2
gentoo-2-1f13175696f19f8c516f64d567def56f1c5c92b2.zip
Version bump for Gnome 3.10
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-control-center/ChangeLog10
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-gentoo-paths.patch119
-rw-r--r--gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-optional.patch384
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-3.10.2.ebuild (renamed from gnome-base/gnome-control-center/gnome-control-center-3.8.5-r1.ebuild)52
4 files changed, 542 insertions, 23 deletions
diff --git a/gnome-base/gnome-control-center/ChangeLog b/gnome-base/gnome-control-center/ChangeLog
index 5b5d21983758..35c8e9d4afcd 100644
--- a/gnome-base/gnome-control-center/ChangeLog
+++ b/gnome-base/gnome-control-center/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-control-center
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/ChangeLog,v 1.140 2013/12/08 18:26:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/ChangeLog,v 1.141 2013/12/24 17:55:10 pacho Exp $
+
+*gnome-control-center-3.10.2 (24 Dec 2013)
+
+ 24 Dec 2013; Pacho Ramos <pacho@gentoo.org>
+ +files/gnome-control-center-3.10.2-gentoo-paths.patch,
+ +files/gnome-control-center-3.10.2-optional.patch,
+ +gnome-control-center-3.10.2.ebuild, -gnome-control-center-3.8.5-r1.ebuild:
+ Version bump for Gnome 3.10
08 Dec 2013; Pacho Ramos <pacho@gentoo.org> gnome-control-center-3.8.6.ebuild:
x86 stable, bug #478252
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-gentoo-paths.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-gentoo-paths.patch
new file mode 100644
index 000000000000..8ef4033492ae
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-gentoo-paths.patch
@@ -0,0 +1,119 @@
+From 6ce180eace2bb3b9954d0b9ca74c7108e772ad68 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 8 Dec 2013 23:44:56 +0100
+Subject: [PATCH 2/2] Fix some absolute paths to be appropriate for Gentoo
+
+---
+ panels/datetime/Makefile.am | 1 +
+ panels/datetime/test-endianess.c | 4 ++--
+ panels/datetime/test-timezone.c | 2 +-
+ panels/datetime/tz.h | 4 ++--
+ panels/printers/Makefile.am | 3 +++
+ panels/printers/cc-printers-panel.c | 4 ++--
+ panels/printers/pp-host.c | 2 +-
+ 7 files changed, 12 insertions(+), 8 deletions(-)
+
+diff --git a/panels/datetime/Makefile.am b/panels/datetime/Makefile.am
+index fc85592..133845f 100644
+--- a/panels/datetime/Makefile.am
++++ b/panels/datetime/Makefile.am
+@@ -24,6 +24,7 @@ AM_CPPFLAGS = \
+ $(DATETIME_PANEL_CFLAGS) \
+ -DGNOMELOCALEDIR="\"$(datadir)/locale\"" \
+ -DGNOMECC_DATA_DIR="\"$(pkgdatadir)\"" \
++ -DREALDATADIR="\"$(datadir)\"" \
+ $(NULL)
+
+ noinst_PROGRAMS = test-timezone-gfx test-endianess test-timezone
+diff --git a/panels/datetime/test-endianess.c b/panels/datetime/test-endianess.c
+index 490df17..b43fc87 100644
+--- a/panels/datetime/test-endianess.c
++++ b/panels/datetime/test-endianess.c
+@@ -38,11 +38,11 @@ int main (int argc, char **argv)
+ return 0;
+ }
+
+- dir = g_dir_open ("/usr/share/i18n/locales/", 0, NULL);
++ dir = g_dir_open (REALDATADIR "/i18n/locales/", 0, NULL);
+ if (dir == NULL) {
+ /* Try with /usr/share/locale/
+ * https://bugzilla.gnome.org/show_bug.cgi?id=646780 */
+- dir = g_dir_open ("/usr/share/locale/", 0, NULL);
++ dir = g_dir_open (REALDATADIR "/locale/", 0, NULL);
+ if (dir == NULL) {
+ return 1;
+ }
+diff --git a/panels/datetime/test-timezone.c b/panels/datetime/test-timezone.c
+index 5667657..8483b87 100644
+--- a/panels/datetime/test-timezone.c
++++ b/panels/datetime/test-timezone.c
+@@ -1,7 +1,7 @@
+ #include <gtk/gtk.h>
+ #include "cc-timezone-map.h"
+
+-#define TZ_DIR "/usr/share/zoneinfo/"
++#define TZ_DIR REALDATADIR "/zoneinfo/"
+
+ static GList *
+ get_timezone_list (GList *tzs,
+diff --git a/panels/datetime/tz.h b/panels/datetime/tz.h
+index 71c1c23..ca4b3c4 100644
+--- a/panels/datetime/tz.h
++++ b/panels/datetime/tz.h
+@@ -29,9 +29,9 @@
+ #include <glib.h>
+
+ #ifndef __sun
+-# define TZ_DATA_FILE "/usr/share/zoneinfo/zone.tab"
++# define TZ_DATA_FILE REALDATADIR "/zoneinfo/zone.tab"
+ #else
+-# define TZ_DATA_FILE "/usr/share/lib/zoneinfo/tab/zone_sun.tab"
++# define TZ_DATA_FILE REALDATADIR "/lib/zoneinfo/tab/zone_sun.tab"
+ #endif
+
+ typedef struct _TzDB TzDB;
+diff --git a/panels/printers/Makefile.am b/panels/printers/Makefile.am
+index 63a33b4..12e2e45 100644
+--- a/panels/printers/Makefile.am
++++ b/panels/printers/Makefile.am
+@@ -7,6 +7,9 @@ INCLUDES = \
+ $(SMBCLIENT_CFLAGS) \
+ -I$(top_srcdir)/shell/ \
+ -DGNOMELOCALEDIR="\"$(datadir)/locale\"" \
++ -DREALDATADIR="\"$(datadir)\"" \
++ -DPREFIX="\"$(prefix)\"" \
++ -DLIBEXECDIR="\"$(libexecdir)\"" \
+ $(NULL)
+
+ noinst_LTLIBRARIES = libprinters.la
+diff --git a/panels/printers/cc-printers-panel.c b/panels/printers/cc-printers-panel.c
+index 29b8173..24bcdf8 100644
+--- a/panels/printers/cc-printers-panel.c
++++ b/panels/printers/cc-printers-panel.c
+@@ -2428,8 +2428,8 @@ test_page_cb (GtkButton *button,
+
+ if (printer_name)
+ {
+- const gchar *const dirs[] = { "/usr/share/cups",
+- "/usr/local/share/cups",
++ const gchar *const dirs[] = { REALDATADIR "/cups",
++ PREFIX "/local/share/cups",
+ NULL };
+ const gchar *testprint[] = { "%s/data/testprint",
+ "%s/data/testprint.ps",
+diff --git a/panels/printers/pp-host.c b/panels/printers/pp-host.c
+index a994a61..51efe50 100644
+--- a/panels/printers/pp-host.c
++++ b/panels/printers/pp-host.c
+@@ -251,7 +251,7 @@ _pp_host_get_snmp_devices_thread (GSimpleAsyncResult *res,
+ data->devices->devices = NULL;
+
+ argv = g_new0 (gchar *, 3);
+- argv[0] = g_strdup ("/usr/lib/cups/backend/snmp");
++ argv[0] = g_strdup (LIBEXECDIR "/cups/backend/snmp");
+ argv[1] = g_strdup (priv->hostname);
+
+ /* Use SNMP to get printer's informations */
+--
+1.8.3.2
+
diff --git a/gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-optional.patch b/gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-optional.patch
new file mode 100644
index 000000000000..0c4d1117375c
--- /dev/null
+++ b/gnome-base/gnome-control-center/files/gnome-control-center-3.10.2-optional.patch
@@ -0,0 +1,384 @@
+From 079e6b87816d96d73adaa5eeb2f8a1b620a0ae70 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 9 Dec 2013 23:23:13 +0100
+Subject: [PATCH 1/2] Make bluetooth/colord/goa/kerberos/wacom optional
+
+Upstream is not interested in any part of this patch:
+
+https://bugzilla.gnome.org/show_bug.cgi?id=686840
+https://bugzilla.gnome.org/show_bug.cgi?id=697478
+https://bugzilla.gnome.org/show_bug.cgi?id=700145
+
+Dropped mm from this revision of the patch since it appears more
+complicated than ever to split it from the network panel.
+
+Signed-Off: Gilles Dartiguelongue <eva@gentoo.org>
+---
+ configure.ac | 140 ++++++++++++++++++++++++++------
+ panels/Makefile.am | 10 ++-
+ panels/user-accounts/um-realm-manager.c | 9 ++
+ shell/Makefile.am | 10 ++-
+ shell/cc-panel-loader.c | 8 ++
+ 5 files changed, 149 insertions(+), 28 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 19bebaf..8b4177a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -136,14 +136,58 @@ PKG_CHECK_MODULES(MOUSE_PANEL, $COMMON_MODULES xi >= 1.2
+ gnome-settings-daemon >= $GSD_REQUIRED_VERSION x11)
+ PKG_CHECK_MODULES(NETWORK_PANEL, $COMMON_MODULES gmodule-2.0)
+ PKG_CHECK_MODULES(NOTIFICATIONS_PANEL, $COMMON_MODULES libgnome-menu-3.0)
+-PKG_CHECK_MODULES(ONLINE_ACCOUNTS_PANEL, $COMMON_MODULES goa-1.0 goa-backend-1.0 >= $GOA_REQUIRED_VERSION)
++
++build_online_accounts=false
++AC_ARG_ENABLE(goa,
++ AC_HELP_STRING([--disable-goa],
++ [disable online accounts management panel]),
++ [case "${enableval}" in
++ yes) WANT_ONLINE_ACCOUNTS=yes ;;
++ no) WANT_ONLINE_ACCOUNTS=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-goa) ;;
++ esac],
++ [WANT_ONLINE_ACCOUNTS=yes]) dnl Default value
++
++if test x$WANT_ONLINE_ACCOUNTS = xyes; then
++ PKG_CHECK_MODULES(ONLINE_ACCOUNTS_PANEL, $COMMON_MODULES goa-1.0 goa-backend-1.0 >= $GOA_REQUIRED_VERSION)
++ build_online_accounts=true
++fi
++if test "x$build_online_accounts" = xtrue ; then
++ AC_DEFINE(BUILD_ONLINE_ACCOUNTS, 1, [Define to 1 to build the Online Accounts panel])
++fi
++AM_CONDITIONAL(BUILD_ONLINE_ACCOUNTS, test "x$build_online_accounts" = "xtrue")
++AC_SUBST(ONLINE_ACCOUNTS_PANEL_CFLAGS)
++AC_SUBST(ONLINE_ACCOUNTS_PANEL_LIBS)
++
+ PKG_CHECK_MODULES(POWER_PANEL, $COMMON_MODULES upower-glib >= 0.9.1
+ gnome-settings-daemon >= $GSD_REQUIRED_VERSION)
+-PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES
+- colord >= $COLORD_REQUIRED_VERSION
+- colord-gtk >= $COLORD_GTK_REQUIRED_VERSION
+- libsoup-2.4
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
++
++build_color=false
++AC_ARG_ENABLE(color,
++ AC_HELP_STRING([--disable-color],
++ [disable color management panel]),
++ [case "${enableval}" in
++ yes) WANT_COLOR=yes ;;
++ no) WANT_COLOR=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-color) ;;
++ esac],
++ [WANT_COLOR=yes]) dnl Default value
++
++if test x$WANT_COLOR = xyes; then
++ PKG_CHECK_MODULES(COLOR_PANEL, $COMMON_MODULES
++ colord >= $COLORD_REQUIRED_VERSION
++ colord-gtk >= $COLORD_GTK_REQUIRED_VERSION
++ libsoup-2.4
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION)
++ build_color=true
++fi
++if test "x$build_color" = xtrue ; then
++ AC_DEFINE(BUILD_COLOR, 1, [Define to 1 to build the Color panel])
++fi
++AM_CONDITIONAL(BUILD_COLOR, test "x$build_color" = "xtrue")
++AC_SUBST(COLOR_PANEL_CFLAGS)
++AC_SUBST(COLOR_PANEL_LIBS)
++
+ PKG_CHECK_MODULES(PRINTERS_PANEL, $COMMON_MODULES
+ polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION)
+ PKG_CHECK_MODULES(PRIVACY_PANEL, $COMMON_MODULES)
+@@ -196,8 +240,24 @@ if test x${have_networkmanager} = xyes; then
+ fi
+
+ # Check for gnome-bluetooth
+-PKG_CHECK_MODULES(BLUETOOTH, $COMMON_MODULES gnome-bluetooth-1.0 >= 3.9.3,
+- [have_bluetooth=yes], have_bluetooth=no)
++have_bluetooth=no
++AC_ARG_ENABLE(bluetooth,
++ AC_HELP_STRING([--disable-bluetooth],
++ [disable bluetooth management panel]),
++ [case "${enableval}" in
++ yes) WANT_BLUETOOTH=yes ;;
++ no) WANT_BLUETOOTH=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-bluetooth) ;;
++ esac],
++ [WANT_BLUETOOTH=yes]) dnl Default value
++
++if test x$WANT_BLUETOOTH = xyes; then
++ # Check for gnome-bluetooth
++ PKG_CHECK_MODULES(BLUETOOTH, $COMMON_MODULES gnome-bluetooth-1.0 >= 3.9.3,
++ [have_bluetooth=yes], have_bluetooth=no)
++ have_bluetooth=yes
++fi
++
+ if test "x$have_bluetooth" = xyes ; then
+ AC_DEFINE(BUILD_BLUETOOTH, 1, [Define to 1 to build the Bluetooth panel])
+ fi
+@@ -282,15 +342,26 @@ case $host_os in
+ if test "$host_cpu" = s390 -o "$host_cpu" = s390x; then
+ have_wacom=no
+ else
+- PKG_CHECK_MODULES(WACOM_PANEL, $COMMON_MODULES
+- gnome-settings-daemon >= $GSD_REQUIRED_VERSION
+- xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
+- gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
+- clutter-gtk-1.0
+- clutter-1.0 >= $CLUTTER_REQUIRED_VERSION, [have_wacom=yes], [have_wacom=no])
+- if test x${have_wacom} = xyes; then
++ AC_ARG_ENABLE(wacom,
++ AC_HELP_STRING([--disable-wacom],
++ [disable wacom management panel]),
++ [case "${enableval}" in
++ yes) WANT_WACOM=yes ;;
++ no) WANT_WACOM=no ;;
++ *) AC_MSG_ERROR(bad value ${enableval} for --disable-wacom) ;;
++ esac],
++ [WANT_WACOM=yes]) dnl Default value
++
++ if test x$WANT_WACOM = xyes; then
++ PKG_CHECK_MODULES(WACOM_PANEL, $COMMON_MODULES
++ gnome-settings-daemon >= $GSD_REQUIRED_VERSION
++ xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
++ gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
++ clutter-gtk-1.0
++ clutter-1.0 >= $CLUTTER_REQUIRED_VERSION)
+ AC_DEFINE(BUILD_WACOM, 1, [Define to 1 to build the Wacom panel])
+ AC_DEFINE(HAVE_WACOM, 1, [Define to 1 is Wacom is supportted])
++ have_wacom=yes
+ fi
+ fi
+ ;;
+@@ -301,16 +372,22 @@ esac
+ AM_CONDITIONAL(BUILD_WACOM, [test x${have_wacom} = xyes])
+
+ # Kerberos kerberos support
+-AC_PATH_PROG(KRB5_CONFIG, krb5-config, no)
+-if test "$KRB5_CONFIG" = "no"; then
+- AC_MSG_ERROR([krb5-config executable not found in your path - should be installed with the kerberos libraries])
+-fi
+-
+-AC_MSG_CHECKING(for krb5 libraries and flags)
+-KRB5_CFLAGS="`$KRB5_CONFIG --cflags`"
+-KRB5_LIBS="`$KRB5_CONFIG --libs`"
+-AC_MSG_RESULT($KRB5_CFLAGS $KRB5_LIBS)
++AC_ARG_ENABLE([kerberos],
++ AS_HELP_STRING([--disable-kerberos], [disable kerberos support (default: enabled)]),,
++ [enable_kerberos=yes])
++
++if test x"$enable_kerberos" != x"no" ; then
++ AC_PATH_PROG(KRB5_CONFIG, krb5-config, no)
++ if test "$KRB5_CONFIG" = "no"; then
++ AC_MSG_ERROR([krb5-config executable not found in your path - should be installed with the kerberos libraries])
++ fi
+
++ AC_MSG_CHECKING(for krb5 libraries and flags)
++ KRB5_CFLAGS="`$KRB5_CONFIG --cflags`"
++ KRB5_LIBS="`$KRB5_CONFIG --libs`"
++ AC_MSG_RESULT($KRB5_CFLAGS $KRB5_LIBS)
++ AC_DEFINE(HAVE_KERBEROS, 1, [defined if krb5 is available])
++fi
+ AC_SUBST(KRB5_CFLAGS)
+ AC_SUBST(KRB5_LIBS)
+
+@@ -547,6 +624,11 @@ if test "x$have_bluetooth" = "xyes"; then
+ else
+ AC_MSG_NOTICE([ Bluetooth panel disabled])
+ fi
++if test "x$build_color" = "xtrue"; then
++ AC_MSG_NOTICE([** colord (Color panel)])
++else
++ AC_MSG_NOTICE([ Color panel disabled])
++fi
+ if test "x$enable_cups" = "xyes"; then
+ AC_MSG_NOTICE([** CUPS (Printers panel)])
+ else
+@@ -557,11 +639,21 @@ if test "x$have_cheese" = "xyes"; then
+ else
+ AC_MSG_NOTICE([ Users panel webcam support disabled])
+ fi
++if test "x$build_online_accounts" = "xtrue"; then
++ AC_MSG_NOTICE([** gnome-online-accounts (Online Accounts panel)])
++else
++ AC_MSG_NOTICE([ Online Accounts panel disabled])
++fi
+ if test "x$with_libsocialweb" = "xyes"; then
+ AC_MSG_NOTICE([** libsocialweb (Background panel Flickr support)])
+ else
+ AC_MSG_NOTICE([ Background panel Flickr support disabled])
+ fi
++if test "x$build_wacom" = "xtrue"; then
++ AC_MSG_NOTICE([** libwacom (Wacom Graphics Tablet panel)])
++else
++ AC_MSG_NOTICE([ Wacom Graphics Tablet panel disabled])
++fi
+ if test "x$have_wacom" = "xyes"; then
+ AC_MSG_NOTICE([** wacom (Wacom tablet panel)])
+ else
+diff --git a/panels/Makefile.am b/panels/Makefile.am
+index 9961c25..0c54622 100644
+--- a/panels/Makefile.am
++++ b/panels/Makefile.am
+@@ -2,11 +2,9 @@ SUBDIRS= \
+ common \
+ background \
+ power \
+- color \
+ display \
+ mouse \
+ notifications \
+- online-accounts \
+ region \
+ info \
+ sound \
+@@ -18,6 +16,10 @@ SUBDIRS= \
+ privacy \
+ sharing
+
++if BUILD_COLOR
++SUBDIRS += color
++endif
++
+ if BUILD_WACOM
+ SUBDIRS += wacom
+ endif
+@@ -34,4 +36,8 @@ if BUILD_BLUETOOTH
+ SUBDIRS += bluetooth
+ endif
+
++if BUILD_ONLINE_ACCOUNTS
++SUBDIRS += online-accounts
++endif
++
+ -include $(top_srcdir)/git.mk
+diff --git a/panels/user-accounts/um-realm-manager.c b/panels/user-accounts/um-realm-manager.c
+index 1fd41ad..ce0988e 100644
+--- a/panels/user-accounts/um-realm-manager.c
++++ b/panels/user-accounts/um-realm-manager.c
+@@ -23,7 +23,9 @@
+
+ #include "um-realm-manager.h"
+
++#ifdef HAVE_KERBEROS
+ #include <krb5/krb5.h>
++#endif
+
+ #include <glib.h>
+ #include <glib/gi18n.h>
+@@ -697,6 +699,7 @@ login_closure_free (gpointer data)
+ g_slice_free (LoginClosure, login);
+ }
+
++#ifdef HAVE_KERBEROS
+ static krb5_error_code
+ login_perform_kinit (krb5_context k5,
+ const gchar *realm,
+@@ -760,12 +763,14 @@ login_perform_kinit (krb5_context k5,
+
+ return code;
+ }
++#endif /* HAVE_KERBEROS */
+
+ static void
+ kinit_thread_func (GSimpleAsyncResult *async,
+ GObject *object,
+ GCancellable *cancellable)
+ {
++#ifdef HAVE_KERBEROS
+ LoginClosure *login = g_simple_async_result_get_op_res_gpointer (async);
+ krb5_context k5 = NULL;
+ krb5_error_code code;
+@@ -843,6 +848,10 @@ kinit_thread_func (GSimpleAsyncResult *async,
+
+ if (k5)
+ krb5_free_context (k5);
++#else /* HAVE_KERBEROS */
++ g_simple_async_result_set_error (async, UM_REALM_ERROR, UM_REALM_ERROR_GENERIC,
++ _("gnome-control-center was built without kerberos support"));
++#endif
+ }
+
+ void
+diff --git a/shell/Makefile.am b/shell/Makefile.am
+index ad7a68f..cc968ac 100644
+--- a/shell/Makefile.am
++++ b/shell/Makefile.am
+@@ -52,14 +52,12 @@ gnome_control_center_LDADD = \
+ $(top_builddir)/libgd/libgd.la \
+ $(top_builddir)/panels/common/liblanguage.la \
+ $(top_builddir)/panels/background/libbackground.la \
+- $(top_builddir)/panels/color/libcolor.la \
+ $(top_builddir)/panels/datetime/libdate_time.la \
+ $(top_builddir)/panels/display/libdisplay.la \
+ $(top_builddir)/panels/info/libinfo.la \
+ $(top_builddir)/panels/keyboard/libkeyboard.la \
+ $(top_builddir)/panels/mouse/libmouse-properties.la \
+ $(top_builddir)/panels/notifications/libnotifications.la \
+- $(top_builddir)/panels/online-accounts/libonline-accounts.la \
+ $(top_builddir)/panels/power/libpower.la \
+ $(top_builddir)/panels/privacy/libprivacy.la \
+ $(top_builddir)/panels/region/libregion.la \
+@@ -85,6 +83,14 @@ if BUILD_BLUETOOTH
+ gnome_control_center_LDADD += $(top_builddir)/panels/bluetooth/libbluetooth.la
+ endif
+
++if BUILD_COLOR
++gnome_control_center_LDADD += $(top_builddir)/panels/color/libcolor.la
++endif
++
++if BUILD_ONLINE_ACCOUNTS
++gnome_control_center_LDADD += $(top_builddir)/panels/online-accounts/libonline-accounts.la
++endif
++
+ AM_CPPFLAGS = -DGNOMELOCALEDIR="\"$(datadir)/locale\""
+
+ # Dbus service file
+diff --git a/shell/cc-panel-loader.c b/shell/cc-panel-loader.c
+index 26576dc..8a92f95 100644
+--- a/shell/cc-panel-loader.c
++++ b/shell/cc-panel-loader.c
+@@ -33,7 +33,9 @@ extern GType cc_background_panel_get_type (void);
+ #ifdef BUILD_BLUETOOTH
+ extern GType cc_bluetooth_panel_get_type (void);
+ #endif /* BUILD_BLUETOOTH */
++#ifdef BUILD_COLOR
+ extern GType cc_color_panel_get_type (void);
++#endif /* BUILD_COLOR */
+ extern GType cc_date_time_panel_get_type (void);
+ extern GType cc_display_panel_get_type (void);
+ extern GType cc_info_panel_get_type (void);
+@@ -43,7 +45,9 @@ extern GType cc_mouse_panel_get_type (void);
+ extern GType cc_network_panel_get_type (void);
+ #endif /* BUILD_NETWORK */
+ extern GType cc_notifications_panel_get_type (void);
++#ifdef BUILD_ONLINE_ACCOUNTS
+ extern GType cc_goa_panel_get_type (void);
++#endif /* BUILD_ONLINE_ACCOUNTS */
+ extern GType cc_power_panel_get_type (void);
+ #ifdef BUILD_PRINTERS
+ extern GType cc_printers_panel_get_type (void);
+@@ -77,7 +81,9 @@ static struct {
+ #ifdef BUILD_BLUETOOTH
+ PANEL_TYPE("bluetooth", cc_bluetooth_panel_get_type ),
+ #endif
++#ifdef BUILD_COLOR
+ PANEL_TYPE("color", cc_color_panel_get_type ),
++#endif
+ PANEL_TYPE("datetime", cc_date_time_panel_get_type ),
+ PANEL_TYPE("display", cc_display_panel_get_type ),
+ PANEL_TYPE("info", cc_info_panel_get_type ),
+@@ -87,7 +93,9 @@ static struct {
+ PANEL_TYPE("network", cc_network_panel_get_type ),
+ #endif
+ PANEL_TYPE("notifications", cc_notifications_panel_get_type),
++#ifdef BUILD_ONLINE_ACCOUNTS
+ PANEL_TYPE("online-accounts", cc_goa_panel_get_type ),
++#endif
+ PANEL_TYPE("power", cc_power_panel_get_type ),
+ #ifdef BUILD_PRINTERS
+ PANEL_TYPE("printers", cc_printers_panel_get_type ),
+--
+1.8.3.2
+
diff --git a/gnome-base/gnome-control-center/gnome-control-center-3.8.5-r1.ebuild b/gnome-base/gnome-control-center/gnome-control-center-3.10.2.ebuild
index 815a37e1b598..a7a4e18a38de 100644
--- a/gnome-base/gnome-control-center/gnome-control-center-3.8.5-r1.ebuild
+++ b/gnome-base/gnome-control-center/gnome-control-center-3.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/gnome-control-center-3.8.5-r1.ebuild,v 1.1 2013/10/08 15:24:51 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-control-center/gnome-control-center-3.10.2.ebuild,v 1.1 2013/12/24 17:55:10 pacho Exp $
EAPI="5"
GCONF_DEBUG="yes"
@@ -13,8 +13,7 @@ HOMEPAGE="https://git.gnome.org/browse/gnome-control-center/"
LICENSE="GPL-2+"
SLOT="2"
-
-IUSE="+bluetooth +colord +cups +gnome-online-accounts +i18n input_devices_wacom kerberos modemmanager +socialweb v4l"
+IUSE="+bluetooth +colord +cups +gnome-online-accounts +i18n input_devices_wacom kerberos +socialweb v4l"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
# False positives caused by nested configure scripts
@@ -27,16 +26,20 @@ QA_CONFIGURE_OPTIONS=".*"
# https://mail.gnome.org/archives/gnome-announce-list/2013-June/msg00005.html
#
# kerberos unfortunately means mit-krb5; build fails with heimdal
+
+# FIXME: modemmanager is not optional
+# networkmanager is not optional
+
COMMON_DEPEND="
- >=dev-libs/glib-2.35.1:2
+ >=dev-libs/glib-2.37.2:2
>=x11-libs/gdk-pixbuf-2.23.0:2
- >=x11-libs/gtk+-3.7.10:3
- >=gnome-base/gsettings-desktop-schemas-3.7.2.2
- >=gnome-base/gnome-desktop-3.7.5:3=
+ >=x11-libs/gtk+-3.9.12:3
+ >=gnome-base/gsettings-desktop-schemas-3.9.91
+ >=gnome-base/gnome-desktop-3.9.90:3=
>=gnome-base/gnome-settings-daemon-3.8.3[colord?,policykit]
>=gnome-base/libgnomekbd-2.91.91
- dev-libs/libpwquality
+ >=dev-libs/libpwquality-1.2.2
dev-libs/libxml2:2
gnome-base/gnome-menus:3
gnome-base/libgtop:2
@@ -49,7 +52,8 @@ COMMON_DEPEND="
>=x11-libs/libnotify-0.7.3:0=
>=gnome-extra/nm-applet-0.9.7.995
- >=net-misc/networkmanager-0.9.8[modemmanager?]
+ >=net-misc/networkmanager-0.9.8[modemmanager]
+ >=net-misc/modemmanager-0.7.990
virtual/opengl
x11-apps/xmodmap
@@ -57,15 +61,16 @@ COMMON_DEPEND="
x11-libs/libXxf86misc
>=x11-libs/libXi-1.2
- bluetooth? ( >=net-wireless/gnome-bluetooth-3.5.5:= )
- colord? ( >=x11-misc/colord-0.1.29 )
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.9.3:= )
+ colord? (
+ net-libs/libsoup:2.4
+ >=x11-misc/colord-0.1.34 )
cups? (
>=net-print/cups-1.4[dbus]
>=net-fs/samba-3.6.14-r1[smbclient] )
- gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8.1 )
- i18n? ( >=app-i18n/ibus-1.4.99 )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.9.90 )
+ i18n? ( >=app-i18n/ibus-1.5.2 )
kerberos? ( app-crypt/mit-krb5 )
- modemmanager? ( >=net-misc/modemmanager-0.7.990 )
socialweb? ( net-libs/libsocialweb )
v4l? (
media-libs/gstreamer:1.0
@@ -73,6 +78,8 @@ COMMON_DEPEND="
>=media-video/cheese-3.5.91 )
input_devices_wacom? (
>=dev-libs/libwacom-0.7
+ >=media-libs/clutter-1.11.3:1.0
+ media-libs/clutter-gtk:1.0
>=x11-libs/libXi-1.2 )
"
# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
@@ -82,7 +89,7 @@ RDEPEND="${COMMON_DEPEND}
x11-themes/gnome-icon-theme-symbolic
colord? (
>=gnome-extra/gnome-color-manager-3
- >=x11-misc/colord-0.1.29
+ >=x11-misc/colord-0.1.34
>=x11-libs/colord-gtk-0.1.24 )
cups? (
>=app-admin/system-config-printer-gnome-1.3.5
@@ -123,11 +130,12 @@ src_prepare() {
# Make some panels and dependencies optional; requires eautoreconf
# https://bugzilla.gnome.org/686840, 697478, 700145
- epatch "${FILESDIR}/${PN}-3.8.5-optional.patch"
+ epatch "${FILESDIR}"/${PN}-3.10.2-optional.patch
# Fix some absolute paths to be appropriate for Gentoo
- epatch "${FILESDIR}/${PN}-3.8.0-paths-makefiles.patch"
- epatch "${FILESDIR}/${PN}-3.8.0-paths.patch"
+ epatch "${FILESDIR}"/${PN}-3.10.2-gentoo-paths.patch
+
+ epatch_user
# top-level configure.ac does not use AC_CONFIG_SUBDIRS, so we need this to
# avoid libtoolize "We've already been run in this tree" warning, bug #484988
@@ -138,15 +146,16 @@ src_prepare() {
popd > /dev/null
done
elibtoolize --force
- epatch_user
- # panels/datetime/Makefile.am gets touched as a result of something in our
- # src_prepare(). We need to touch timedated{c,h} to prevent them from being
+ # panels/datetime/Makefile.am gets touched by "gentoo-paths" patch.
+ # We need to touch timedated{c,h} to prevent them from being
# regenerated (bug #415901)
# Upstream think they should be removed, preventing compilation errors too
# (https://bugzilla.gnome.org/704822)
[[ -f panels/datetime/timedated.h ]] && rm -f panels/datetime/timedated.h
[[ -f panels/datetime/timedated.c ]] && rm -f panels/datetime/timedated.c
+
+ gnome2_src_prepare
}
src_configure() {
@@ -160,7 +169,6 @@ src_configure() {
$(use_enable gnome-online-accounts goa) \
$(use_enable i18n ibus) \
$(use_enable kerberos) \
- $(use_enable modemmanager) \
$(use_with socialweb libsocialweb) \
$(use_with v4l cheese) \
$(use_enable input_devices_wacom wacom)