summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-25 06:23:32 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-25 06:23:32 +0000
commit82d9b2867394cede02196bd32bffbea45b4f46e4 (patch)
treea529820d7b2002b79e2de0426acf4f23f47a27fa /gnome-base
parentMask cups USE for g-c-c 3.8 due missing keywords #444688 (diff)
downloadgentoo-2-82d9b2867394cede02196bd32bffbea45b4f46e4.tar.gz
gentoo-2-82d9b2867394cede02196bd32bffbea45b4f46e4.tar.bz2
gentoo-2-82d9b2867394cede02196bd32bffbea45b4f46e4.zip
Drop keywords due #478076 and readd partially working version for them
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/ChangeLog9
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3-r1.ebuild4
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3.ebuild115
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.4.ebuild4
4 files changed, 127 insertions, 5 deletions
diff --git a/gnome-base/gnome-settings-daemon/ChangeLog b/gnome-base/gnome-settings-daemon/ChangeLog
index 57d0f4d70267..e5f202033c54 100644
--- a/gnome-base/gnome-settings-daemon/ChangeLog
+++ b/gnome-base/gnome-settings-daemon/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/gnome-settings-daemon
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.121 2013/07/20 08:33:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.122 2013/07/25 06:23:32 pacho Exp $
+
+*gnome-settings-daemon-3.8.3 (25 Jul 2013)
+
+ 25 Jul 2013; Pacho Ramos <pacho@gentoo.org>
+ +gnome-settings-daemon-3.8.3.ebuild, gnome-settings-daemon-3.8.3-r1.ebuild,
+ gnome-settings-daemon-3.8.4.ebuild:
+ Drop keywords due #478076 and readd partially working version for them
*gnome-settings-daemon-3.8.4 (20 Jul 2013)
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3-r1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3-r1.ebuild
index 73331393d9d5..417595964815 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3-r1.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3-r1.ebuild,v 1.1 2013/07/14 18:45:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3-r1.ebuild,v 1.2 2013/07/25 06:23:32 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -16,7 +16,7 @@ SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/${P}-patches.tar.xz"
LICENSE="GPL-2+"
SLOT="0"
IUSE="+colord +cups debug +i18n input_devices_wacom packagekit policykit +short-touchpad-timeout smartcard +udev"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
REQUIRED_USE="
packagekit? ( udev )
smartcard? ( udev )
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3.ebuild
new file mode 100644
index 000000000000..59e1593d3c8a
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.3.ebuild,v 1.3 2013/07/25 06:23:32 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 virtualx
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="https://git.gnome.org/browse/gnome-settings-daemon"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+colord +cups debug +i18n input_devices_wacom packagekit policykit +short-touchpad-timeout smartcard +udev"
+KEYWORDS=" ~alpha ~ia64 ~sparc"
+REQUIRED_USE="
+ packagekit? ( udev )
+ smartcard? ( udev )
+"
+
+# require colord-0.1.27 dependency for connection type support
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.3:2
+ >=x11-libs/gtk+-3.7.8:3
+ >=gnome-base/gnome-desktop-3.7.90:3=
+ >=gnome-base/gsettings-desktop-schemas-3.7.2.1
+ >=gnome-base/librsvg-2.36.2
+ media-fonts/cantarell
+ media-libs/fontconfig
+ >=media-libs/lcms-2.2:2
+ media-libs/libcanberra[gtk3]
+ >=media-sound/pulseaudio-2
+ >=sys-power/upower-0.9.11
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/libnotify-0.7.3:=
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-libs/libXi
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXtst
+ x11-libs/libXxf86misc
+
+ colord? ( >=x11-misc/colord-0.1.27:= )
+ cups? ( >=net-print/cups-1.4[dbus] )
+ i18n? ( >=app-i18n/ibus-1.4.99 )
+ input_devices_wacom? (
+ >=dev-libs/libwacom-0.7
+ x11-drivers/xf86-input-wacom )
+ packagekit? ( >=app-admin/packagekit-base-0.7.4 )
+ smartcard? ( >=dev-libs/nss-3.11.2 )
+ udev? ( virtual/udev[gudev] )
+"
+# Themes needed by g-s-d, gnome-shell, gtk+:3 apps to work properly
+# <gnome-color-manager-3.1.1 has file collisions with g-s-d-3.1.x
+# <gnome-power-manager-3.1.3 has file collisions with g-s-d-3.1.x
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/dconf
+ >=x11-themes/gnome-themes-standard-2.91
+ >=x11-themes/gnome-icon-theme-2.91
+ >=x11-themes/gnome-icon-theme-symbolic-2.91
+ !<gnome-base/gnome-control-center-2.22
+ !<gnome-extra/gnome-color-manager-3.1.1
+ !<gnome-extra/gnome-power-manager-3.1.3
+
+"
+# xproto-7.0.15 needed for power plugin
+DEPEND="${COMMON_DEPEND}
+ cups? ( sys-apps/sed )
+ dev-libs/libxml2:2
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ x11-proto/inputproto
+ x11-proto/xf86miscproto
+ >=x11-proto/xproto-7.0.15
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=621836
+ # Apparently this change severely affects touchpad usability for some
+ # people, so revert it if USE=short-touchpad-timeout.
+ # Revisit if/when upstream adds a setting for customizing the timeout.
+ use short-touchpad-timeout &&
+ epatch "${FILESDIR}/${PN}-3.7.90-short-touchpad-timeout.patch"
+
+ # Make colord and wacom optional; requires eautoreconf
+ epatch "${FILESDIR}/${PN}-3.7.90-optional-color-wacom.patch"
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-man \
+ $(use_enable colord color) \
+ $(use_enable cups) \
+ $(use_enable debug) \
+ $(use_enable debug more-warnings) \
+ $(use_enable i18n ibus) \
+ $(use_enable packagekit) \
+ $(use_enable smartcard smartcard-support) \
+ $(use_enable udev gudev) \
+ $(use_enable input_devices_wacom wacom)
+}
+
+src_test() {
+ Xemake check
+}
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.4.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.4.ebuild
index 40b7e64f94da..88fa4388c47a 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.4.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.4.ebuild,v 1.1 2013/07/20 08:33:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-3.8.4.ebuild,v 1.2 2013/07/25 06:23:32 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -13,7 +13,7 @@ HOMEPAGE="https://git.gnome.org/browse/gnome-settings-daemon"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="+colord +cups debug +i18n input_devices_wacom packagekit policykit +short-touchpad-timeout smartcard +udev"
REQUIRED_USE="