summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-11 16:31:59 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-11 16:31:59 +0000
commita0a3ea5c6dbd13e69c8ea378f601f15e8a5edec3 (patch)
tree5a705b8b8b8807910956a5d59735f9eaafd8dd07 /gnome-base
parentEnable multilib support. (diff)
downloadgentoo-2-a0a3ea5c6dbd13e69c8ea378f601f15e8a5edec3.tar.gz
gentoo-2-a0a3ea5c6dbd13e69c8ea378f601f15e8a5edec3.tar.bz2
gentoo-2-a0a3ea5c6dbd13e69c8ea378f601f15e8a5edec3.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-vfs/ChangeLog9
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-2.24.4-r2.ebuild156
2 files changed, 163 insertions, 2 deletions
diff --git a/gnome-base/gnome-vfs/ChangeLog b/gnome-base/gnome-vfs/ChangeLog
index e2a911077c79..c2e95ceab830 100644
--- a/gnome-base/gnome-vfs/ChangeLog
+++ b/gnome-base/gnome-vfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gnome-vfs
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.347 2013/05/06 03:50:08 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.348 2014/06/11 16:31:59 mgorny Exp $
+
+*gnome-vfs-2.24.4-r2 (11 Jun 2014)
+
+ 11 Jun 2014; Michał Górny <mgorny@gentoo.org> +gnome-vfs-2.24.4-r2.ebuild:
+ Enable multilib support.
06 May 2013; Patrick Lauer <patrick@gentoo.org> gnome-vfs-2.24.4-r1.ebuild:
Automake 1.13 fix
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r2.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r2.ebuild
new file mode 100644
index 000000000000..43cd7e0207ed
--- /dev/null
+++ b/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r2.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.24.4-r2.ebuild,v 1.1 2014/06/11 16:31:59 mgorny Exp $
+
+EAPI=5
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2 multilib-minimal virtualx
+
+DESCRIPTION="Gnome Virtual Filesystem"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl avahi doc fam gnutls ipv6 kerberos samba ssl"
+
+RDEPEND=">=gnome-base/gconf-2[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.9.3[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.6[${MULTILIB_USEDEP}]
+ app-arch/bzip2[${MULTILIB_USEDEP}]
+ gnome-base/gnome-mime-data
+ >=x11-misc/shared-mime-info-0.14
+ >=dev-libs/dbus-glib-0.71[${MULTILIB_USEDEP}]
+ acl? (
+ sys-apps/acl[${MULTILIB_USEDEP}]
+ sys-apps/attr[${MULTILIB_USEDEP}] )
+ avahi? ( >=net-dns/avahi-0.6[${MULTILIB_USEDEP}] )
+ kerberos? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ fam? ( virtual/fam[${MULTILIB_USEDEP}] )
+ samba? ( >=net-fs/samba-3[${MULTILIB_USEDEP}] )
+ ssl? (
+ gnutls? (
+ net-libs/gnutls[${MULTILIB_USEDEP}]
+ !gnome-extra/gnome-vfs-sftp )
+ !gnutls? (
+ >=dev-libs/openssl-0.9.5[${MULTILIB_USEDEP}]
+ !gnome-extra/gnome-vfs-sftp ) )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ >=dev-util/gtk-doc-am-1.13
+ doc? ( >=dev-util/gtk-doc-1 )"
+RDEPEND="${RDEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r1
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+
+src_prepare() {
+ # Allow the Trash on afs filesystems (#106118)
+ epatch "${FILESDIR}"/${PN}-2.12.0-afs.patch
+
+ # Fix compiling with headers missing
+ epatch "${FILESDIR}"/${PN}-2.15.2-headers-define.patch
+
+ # Fix for crashes running programs via sudo
+ epatch "${FILESDIR}"/${PN}-2.16.0-no-dbus-crash.patch
+
+ # Fix automagic dependencies, upstream bug #493475
+ epatch "${FILESDIR}"/${PN}-2.20.0-automagic-deps.patch
+ epatch "${FILESDIR}"/${PN}-2.20.1-automagic-deps.patch
+
+ # Fix to identify ${HOME} (#200897)
+ # thanks to debian folks
+ epatch "${FILESDIR}"/${PN}-2.24.4-home_dir_fakeroot.patch
+
+ # Configure with gnutls-2.7, bug #253729
+ # Fix building with gnutls-2.12, bug #388895
+ epatch "${FILESDIR}"/${PN}-2.24.4-gnutls27.patch
+
+ # Prevent duplicated volumes, bug #193083
+ epatch "${FILESDIR}"/${PN}-2.24.0-uuid-mount.patch
+
+ # Do not build tests with FEATURES="-test", bug #226221
+ epatch "${FILESDIR}"/${PN}-2.24.4-build-tests-asneeded.patch
+
+ # Disable broken test, bug #285706
+ epatch "${FILESDIR}"/${PN}-2.24.4-disable-test-async-cancel.patch
+
+ # Fix for automake-1.13 compatibility, #466944
+ epatch "${FILESDIR}"/${P}-automake-1.13.patch
+
+ # Fix deprecated API disabling in used libraries - this is not future-proof, bug 212163
+ # upstream bug #519632
+ sed -i -e '/DISABLE_DEPRECATED/d' \
+ daemon/Makefile.am daemon/Makefile.in \
+ libgnomevfs/Makefile.am libgnomevfs/Makefile.in \
+ modules/Makefile.am modules/Makefile.in \
+ test/Makefile.am test/Makefile.in || die
+ sed -i -e 's:-DG_DISABLE_DEPRECATED:$(NULL):g' \
+ programs/Makefile.am programs/Makefile.in || die
+
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-schemas-install
+ --disable-static
+ --disable-cdda
+ --disable-howl
+ $(use_enable acl)
+ $(use_enable avahi)
+ $(use_enable fam)
+ $(use_enable gnutls)
+ --disable-hal
+ $(use_enable ipv6)
+ $(use_enable kerberos krb5)
+ $(use_enable samba)
+ $(use_enable ssl openssl)
+ # Useless ? --enable-http-neon
+
+ # fix path to krb5-config
+ KRB5_CONFIG=/usr/bin/${CHOST}-krb5-config
+ )
+
+ # this works because of the order of configure parsing
+ # so should always be behind the use_enable options
+ # foser <foser@gentoo.org 19 Apr 2004
+ use gnutls && use ssl && myconf+=( --disable-openssl )
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure "${myconf[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+ fi
+}
+
+multilib_src_test() {
+ unset DISPLAY
+ # Fix bug #285706
+ unset XAUTHORITY
+ Xemake check || die "tests failed"
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+ einstalldocs
+}
+
+