summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-04-27 21:47:31 +0000
committerMarinus Schraal <foser@gentoo.org>2004-04-27 21:47:31 +0000
commitcd02e55431f8586ad9f8ba079b1020cc082f7f68 (patch)
tree25a482ab9ea5b863b07de690e7e639e3320579b8 /gnome-extra/gconf-editor
parentAdd inherit eutils (diff)
downloadgentoo-2-cd02e55431f8586ad9f8ba079b1020cc082f7f68.tar.gz
gentoo-2-cd02e55431f8586ad9f8ba079b1020cc082f7f68.tar.bz2
gentoo-2-cd02e55431f8586ad9f8ba079b1020cc082f7f68.zip
fix gtk2.4 build
Diffstat (limited to 'gnome-extra/gconf-editor')
-rw-r--r--gnome-extra/gconf-editor/ChangeLog5
-rw-r--r--gnome-extra/gconf-editor/files/gconf-editor-2.4.0-gtk+-2.4.patch25
-rw-r--r--gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild14
3 files changed, 41 insertions, 3 deletions
diff --git a/gnome-extra/gconf-editor/ChangeLog b/gnome-extra/gconf-editor/ChangeLog
index 9b0c2f7ebc38..bd3b73156d8f 100644
--- a/gnome-extra/gconf-editor/ChangeLog
+++ b/gnome-extra/gconf-editor/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-extra/gconf-editor
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gconf-editor/ChangeLog,v 1.27 2004/04/27 21:15:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gconf-editor/ChangeLog,v 1.28 2004/04/27 21:47:31 foser Exp $
+
+ 27 Apr 2004; foser <foser@gentoo.org> gconf-editor-2.4.0.ebuild :
+ Add gtk+-2.4 build patch provided by gmsoft in #46640
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> gconf-editor-2.6.0.ebuild:
Add inherit eutils
diff --git a/gnome-extra/gconf-editor/files/gconf-editor-2.4.0-gtk+-2.4.patch b/gnome-extra/gconf-editor/files/gconf-editor-2.4.0-gtk+-2.4.patch
new file mode 100644
index 000000000000..f4f60db39fb7
--- /dev/null
+++ b/gnome-extra/gconf-editor/files/gconf-editor-2.4.0-gtk+-2.4.patch
@@ -0,0 +1,25 @@
+diff -uNr gconf-editor-2.4.0.orig/src/Makefile.am gconf-editor-2.4.0/src/Makefile.am
+--- gconf-editor-2.4.0.orig/src/Makefile.am 2004-04-26 17:33:04.000000000 +0000
++++ gconf-editor-2.4.0/src/Makefile.am 2004-04-26 17:33:52.000000000 +0000
+@@ -2,9 +2,6 @@
+ -DLOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" \
+ -DGCONF_EDITOR_IMAGEDIR=\""$(datadir)/pixmaps/gconf-editor"\" \
+ -DIMAGEDIR=\""$(datadir)/pixmaps"\" \
+- -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED \
+- -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED \
+- -DGNOME_DISABLE_DEPRECATED -DGNOME_VFS_DISABLE_DEPRECATED \
+ $(GCONF_EDITOR_CFLAGS)
+
+ bin_PROGRAMS = gconf-editor
+diff -uNr gconf-editor-2.4.0.orig/src/Makefile.in gconf-editor-2.4.0/src/Makefile.in
+--- gconf-editor-2.4.0.orig/src/Makefile.in 2004-04-26 17:33:04.000000000 +0000
++++ gconf-editor-2.4.0/src/Makefile.in 2004-04-26 17:33:45.000000000 +0000
+@@ -123,7 +123,7 @@
+ USE_NLS = @USE_NLS@
+ VERSION = @VERSION@
+
+-INCLUDES = -DLOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" -DGCONF_EDITOR_IMAGEDIR=\""$(datadir)/pixmaps/gconf-editor"\" -DIMAGEDIR=\""$(datadir)/pixmaps"\" -DG_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGNOME_DISABLE_DEPRECATED -DGNOME_VFS_DISABLE_DEPRECATED $(GCONF_EDITOR_CFLAGS)
++INCLUDES = -DLOCALEDIR=\""$(prefix)/$(DATADIRNAME)/locale"\" -DGCONF_EDITOR_IMAGEDIR=\""$(datadir)/pixmaps/gconf-editor"\" -DIMAGEDIR=\""$(datadir)/pixmaps"\" $(GCONF_EDITOR_CFLAGS)
+
+
+ bin_PROGRAMS = gconf-editor
diff --git a/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild b/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild
index 94eb0824df22..180b5f403848 100644
--- a/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild
+++ b/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild,v 1.9 2004/03/17 01:02:52 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild,v 1.10 2004/04/27 21:47:31 foser Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="An editor to the GNOME 2 config system"
HOMEPAGE="http://www.gnome.org/"
@@ -18,3 +18,13 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fix gtk+-2.4 build
+ epatch ${FILESDIR}/${P}-gtk+-2.4.patch
+
+}