summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-22 18:05:50 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-22 18:05:50 +0000
commit16515cdd4e1ae8d30347ea3d2a91bc40160dd256 (patch)
treeefff9683138646ee9aba16eb849237b75f8312a9 /gnome-extra/gnome-do-plugins
parentFix broken png file, fix desktop file, add missing dependencies. (diff)
downloadgentoo-2-16515cdd4e1ae8d30347ea3d2a91bc40160dd256.tar.gz
gentoo-2-16515cdd4e1ae8d30347ea3d2a91bc40160dd256.tar.bz2
gentoo-2-16515cdd4e1ae8d30347ea3d2a91bc40160dd256.zip
Version bump, drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/gnome-do-plugins')
-rw-r--r--gnome-extra/gnome-do-plugins/ChangeLog12
-rw-r--r--gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch17
-rw-r--r--gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono28.patch42
-rw-r--r--gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.4.ebuild40
-rw-r--r--gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild53
5 files changed, 62 insertions, 102 deletions
diff --git a/gnome-extra/gnome-do-plugins/ChangeLog b/gnome-extra/gnome-do-plugins/ChangeLog
index 5ad1e45073d3..ebb27971c4d7 100644
--- a/gnome-extra/gnome-do-plugins/ChangeLog
+++ b/gnome-extra/gnome-do-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/gnome-do-plugins
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.24 2012/05/13 12:39:35 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.25 2014/11/22 18:05:49 pacho Exp $
+
+*gnome-do-plugins-0.8.5 (22 Nov 2014)
+
+ 22 Nov 2014; Pacho Ramos <pacho@gentoo.org> +gnome-do-plugins-0.8.5.ebuild,
+ -files/gnome-do-plugins-0.8.2-mono26.patch,
+ -files/gnome-do-plugins-0.8.2-mono28.patch, -gnome-do-plugins-0.8.4.ebuild:
+ Version bump, drop old
13 May 2012; Agostino Sarubbo <ago@gentoo.org>
-gnome-do-plugins-0.8.2-r1.ebuild, -gnome-do-plugins-0.8.3.ebuild:
@@ -137,4 +144,3 @@
+files/do-plugins-optional-ext-dep.patch, +metadata.xml,
+gnome-do-plugins-0.3.0.ebuild:
Initial import, thanks to Arun Raghavan in #207396.
-
diff --git a/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch b/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch
deleted file mode 100644
index e4aa8f2e695f..000000000000
--- a/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream revision 678 fixes compilation with mono 2.6.
-
-=== modified file 'Evolution/src/ContactItemSource.cs'
---- Evolution/src/ContactItemSource.cs 2009-06-22 04:05:16 +0000
-+++ Evolution/src/ContactItemSource.cs 2010-02-12 01:08:47 +0000
-@@ -32,8 +32,8 @@
- {
- public struct ContactAttribute
- {
-- public string Detail { get; protected set; }
-- public string Key { get; protected set; }
-+ public string Detail { get; private set; }
-+ public string Key { get; private set; }
-
- public ContactAttribute (string key, string detail)
- {
-
diff --git a/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono28.patch b/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono28.patch
deleted file mode 100644
index 1dc125b39da5..000000000000
--- a/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono28.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-https://bugs.launchpad.net/do-plugins/+bug/634564
-
---- Evolution/src/ContactItemSource.cs 2010-11-04 16:32:32.000000000 -0600
-+++ Evolution/src/ContactItemSource.cs 2010-11-04 16:34:25.000000000 -0600
-@@ -35,7 +35,7 @@
- public string Detail { get; set; }
- public string Key { get; set; }
-
-- public ContactAttribute (string key, string detail)
-+ public ContactAttribute (string key, string detail) : this ()
- {
- Key = key;
- Detail = detail;
---- File/src/Do/Do.FilesAndFolders/IndexedFolder.cs 2009-10-12 14:30:04.000000000 -0600
-+++ File/src/Do/Do.FilesAndFolders/IndexedFolder.cs 2010-11-04 16:34:45.000000000 -0600
-@@ -33,7 +33,7 @@
- public uint Level { get; private set; }
- public FolderStatus Status { get; private set; }
-
-- public IndexedFolder (string path, uint level, FolderStatus status)
-+ public IndexedFolder (string path, uint level, FolderStatus status) : this ()
- {
- if (path == null) throw new ArgumentNullException ("path");
-
---- Pidgin/src/PidginContactItemSource.cs 2009-10-12 14:30:04.000000000 -0600
-+++ Pidgin/src/PidginContactItemSource.cs 2010-09-01 16:41:10.000000000 -0600
-@@ -241,7 +241,7 @@
- }
- //if the alias is still null, let's try to get the server alias
- if (string.IsNullOrEmpty (alias))
-- alias = Pidgin.GetBuddyServerAlias (protos[proto]) ?? null;
-+ alias = (string) Pidgin.GetBuddyServerAlias (protos[proto]) ?? null;
- break;
- //let's pick up the custom icon as the metacontact's icon
- case "setting":
-@@ -278,4 +278,4 @@
- return buddy;
- }
- }
--}
-\ No newline at end of file
-+}
diff --git a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.4.ebuild b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.4.ebuild
deleted file mode 100644
index 323b92129a39..000000000000
--- a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.4.ebuild,v 1.2 2012/05/05 06:25:18 jdhore Exp $
-
-EAPI=2
-
-inherit eutils gnome2 mono versionator
-
-MY_PN="do-plugins"
-PVC=$(get_version_component_range 1-3)
-
-DESCRIPTION="Plugins to put the Do in Gnome Do"
-HOMEPAGE="http://do.davebsd.com/"
-SRC_URI="https://launchpad.net/${MY_PN}/trunk/${PVC}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="banshee"
-
-RDEPEND=">=gnome-extra/gnome-do-${PV}
- dev-dotnet/wnck-sharp
- banshee? ( >=media-sound/banshee-1.4.2 )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_configure() {
- econf --enable-debug=no --enable-release=yes \
- $(use banshee) \
- --disable-empathy \
- --disable-flickr || die "configure failed"
-}
-
-src_compile()
-{
- # The make system is unfortunately broken for parallel builds and
- # upstream indicated on IRC that they have no intention to fix
- # that.
- emake -j1 || die "make failed"
-}
diff --git a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild
new file mode 100644
index 000000000000..2a8408035110
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.5.ebuild,v 1.1 2014/11/22 18:05:49 pacho Exp $
+
+EAPI=5
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2 mono-env versionator
+
+MY_PN="do-plugins"
+PVC=$(get_version_component_range 1-3)
+
+DESCRIPTION="Plugins to put the Do in Gnome Do"
+HOMEPAGE="https://launchpad.net/do-plugins"
+SRC_URI="https://launchpad.net/${MY_PN}/trunk/${PVC}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="banshee"
+
+RDEPEND="
+ >=gnome-extra/gnome-do-0.9
+ dev-dotnet/wnck-sharp
+ banshee? ( >=media-sound/banshee-1.4.2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Skip failing plugins (from ArchLinux)
+ sed -i -e '/DiskMounter/d
+ /Transmission/d' Makefile.am || die
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use banshee) \
+ --disable-empathy \
+ --disable-flickr \
+ --disable-transmission
+}
+
+src_compile() {
+ # The make system is unfortunately broken for parallel builds and
+ # upstream indicated on IRC that they have no intention to fix
+ # that.
+ MAKEOPTS="${MAKEOPTS} -j1" gnome2_src_compile
+}