summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-11-12 22:37:21 +0000
committerMarinus Schraal <foser@gentoo.org>2002-11-12 22:37:21 +0000
commit88bb2d6541a80aad9797c47e20c35d7b83addc5f (patch)
tree1ff9cfcd0030ca15d4a77da5aec6bac81ffa0a91 /gnome-extra/gnome-games
parentset -ppc in keywords, no ppc devs seem willing to support this (diff)
downloadgentoo-2-88bb2d6541a80aad9797c47e20c35d7b83addc5f.tar.gz
gentoo-2-88bb2d6541a80aad9797c47e20c35d7b83addc5f.tar.bz2
gentoo-2-88bb2d6541a80aad9797c47e20c35d7b83addc5f.zip
GNOME 2.1.2 commit
Diffstat (limited to 'gnome-extra/gnome-games')
-rw-r--r--gnome-extra/gnome-games/ChangeLog7
-rw-r--r--gnome-extra/gnome-games/files/digest-gnome-games-2.1.21
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.1.2.ebuild107
3 files changed, 114 insertions, 1 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index dd879c9b2905..075a0144835a 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-games
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.17 2002/10/28 14:29:17 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.18 2002/11/12 22:37:21 foser Exp $
+
+*gnome-games-2.1.2 (12 Nov 2002)
+
+ 12 Nov 2002; foser <foser@gentoo.org> gnome-games-2.1.2.ebuild :
+ GNOME 2.1.2 release
*gnome-games-2.1.1 (28 Oct 2002)
diff --git a/gnome-extra/gnome-games/files/digest-gnome-games-2.1.2 b/gnome-extra/gnome-games/files/digest-gnome-games-2.1.2
new file mode 100644
index 000000000000..16650b6b6eeb
--- /dev/null
+++ b/gnome-extra/gnome-games/files/digest-gnome-games-2.1.2
@@ -0,0 +1 @@
+MD5 d78f79ac99ccb309e26632c02ef37aed gnome-games-2.1.2.tar.bz2 9512177
diff --git a/gnome-extra/gnome-games/gnome-games-2.1.2.ebuild b/gnome-extra/gnome-games/gnome-games-2.1.2.ebuild
new file mode 100644
index 000000000000..036fa0ba2c2f
--- /dev/null
+++ b/gnome-extra/gnome-games/gnome-games-2.1.2.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.1.2.ebuild,v 1.1 2002/11/12 22:37:21 foser Exp $
+
+inherit gnome2 debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Games for the Gnome2 desktop"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64 ppc alpha"
+LICENSE="GPL-2"
+
+RDEPEND=">=app-text/scrollkeeper-0.3.11
+ >=sys-libs/ncurses-5.2
+ >=sys-devel/gettext-0.10.40
+ >=gnome-base/gconf-1.2.1
+ =gnome-base/gnome-vfs-2.1*
+ =gnome-base/libgnome-2.1*
+ =gnome-base/libgnomeui-2.1*"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.22
+ ${RDEPEND}"
+
+
+G2CONF="${G2CONF} --with-ncurses --enable-debug=yes"
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ einstall || die "install failure"
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ dodoc AUTHORS COPYING COPYING-DOCS ChangeLog HACKING INSTALL MAINTAINERS NEWS README TODO
+
+ docinto aisleriot
+ cd aisleriot
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../freecell
+ docinto freecell
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ cd ../gataxx
+ docinto gataxx
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../glines
+ docinto glines
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ cd ../gnect
+ docinto gnect
+ dodoc AUTHORS ChangeLog TODO
+
+ cd ../gnibbles
+ docinto gnibbles
+ dodoc AUTHORS ChangeLog
+
+ cd ../gnobots2
+ docinto gnobots2
+ dodoc AUTHORS README
+
+ cd ../gnome-stones
+ docinto gnome-stones
+ dodoc ChangeLog README TODO
+
+ cd ../gnometris
+ docinto gnometris
+ dodoc AUTHORS COPYING ChangeLog TODO
+
+ cd ../gnomine
+ docinto gnomine
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gnotravex
+ docinto gnotravex
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gnotski
+ docinto gnotski
+ dodoc AUTHORS ChangeLog README
+
+ cd ../gtali
+ docinto gtali
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+
+ cd ../iagno
+ docinto iagno
+ dodoc AUTHORS ChangeLog
+
+ cd ../mahjongg
+ docinto mahjongg
+ dodoc ChangeLog NEWS README TODO
+
+ cd ../same-gnome
+ docinto same-gnome
+ dodoc ChangeLog README TODO
+
+ cd ../xbill
+ docinto xbill
+ dodoc AUTHORS COPYING ChangeLog NEWS README README.Ports
+
+ cd ..
+ export SCROLLKEEPER_UPDATE="1"
+}
+