summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-12-25 21:23:16 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-12-25 21:23:16 +0000
commit95b4673443ec95065eb763cf97e28b8501ee05be (patch)
treed3331145ad9597fcb7320d89821e5b5dbee0f9fb /gnome-extra/gnome-games
parent[bump] perl-core/IO-Compress-2.59.0 (diff)
downloadgentoo-2-95b4673443ec95065eb763cf97e28b8501ee05be.tar.gz
gentoo-2-95b4673443ec95065eb763cf97e28b8501ee05be.tar.bz2
gentoo-2-95b4673443ec95065eb763cf97e28b8501ee05be.zip
Version bump for Gnome 3.6. Switch to EAPI=5 and python-r1.eclass.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-extra/gnome-games')
-rw-r--r--gnome-extra/gnome-games/ChangeLog8
-rw-r--r--gnome-extra/gnome-games/gnome-games-3.6.1-r1.ebuild185
-rw-r--r--gnome-extra/gnome-games/metadata.xml2
3 files changed, 192 insertions, 3 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index 02e77c1e0330..a86b0cdd637e 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gnome-games
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.325 2012/12/10 02:06:28 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.326 2012/12/25 21:23:16 eva Exp $
+
+*gnome-games-3.6.1-r1 (25 Dec 2012)
+
+ 25 Dec 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-games-3.6.1-r1.ebuild, metadata.xml:
+ Version bump for Gnome 3.6. Switch to EAPI=5 and python-r1.eclass.
10 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
-gnome-games-3.2.1-r1.ebuild, -files/gnome-games-3.2.1-pygobject-3.0.3.patch,
diff --git a/gnome-extra/gnome-games/gnome-games-3.6.1-r1.ebuild b/gnome-extra/gnome-games/gnome-games-3.6.1-r1.ebuild
new file mode 100644
index 000000000000..dfd575a0fe11
--- /dev/null
+++ b/gnome-extra/gnome-games/gnome-games-3.6.1-r1.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-3.6.1-r1.ebuild,v 1.1 2012/12/25 21:23:16 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="xml"
+
+# Make sure games is inherited first so that the gnome2
+# functions will be called if they are not overridden
+inherit games gnome2 python-r1 virtualx
+
+DESCRIPTION="Collection of games for the GNOME desktop"
+HOMEPAGE="http://live.gnome.org/GnomeGames/"
+
+LICENSE="GPL-2 GPL-3 FDL-1.1"
+SLOT="0"
+# TODO: file KEYWORDREQ bug once it's determined that seed is usable
+KEYWORDS="~amd64 ~mips ~x86"
+
+# FIXME: we should decide whether to have USE flag for games or features
+# IUSE="artworkextra clutter opengl python test"
+# vs
+# IUSE="artworkextra aisleriot glchess quadrapassel swell-foop lightsoff gnibbles sudoku"
+IUSE="artworkextra +aisleriot +clutter +glchess +sudoku test"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.25.7
+ >=gnome-base/librsvg-2.32
+ >=x11-libs/cairo-1.10
+ >=x11-libs/gtk+-3.3.11:3[introspection]
+
+ >=media-libs/libcanberra-0.26[gtk3]
+
+ artworkextra? ( >=gnome-extra/gnome-games-extra-data-3 )
+ clutter? (
+ media-libs/clutter:1.0[introspection]
+ >=media-libs/clutter-gtk-0.91.6:1.0 )
+ glchess? (
+ dev-db/sqlite:3
+ virtual/glu
+ virtual/opengl
+ x11-libs/libX11 )
+ sudoku? ( dev-libs/gobject-introspection )
+"
+RDEPEND="${COMMON_DEPEND}
+ sudoku? (
+ ${PYTHON_DEPS}
+ dev-python/pycairo
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/pango[introspection]
+ >=x11-libs/gtk+-3:3[introspection] )
+
+ !<gnome-extra/gnome-games-extra-data-3
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.4
+ dev-util/itstool
+ >=sys-devel/gettext-0.10.40
+ virtual/pkgconfig
+"
+
+# For compatibility with older versions of the gnome-games package
+PDEPEND="aisleriot? ( games-board/aisleriot )"
+
+# Others are installed below; multiples in this package.
+DOCS="AUTHORS HACKING MAINTAINERS TODO"
+
+_omitgame() {
+ G2CONF="${G2CONF},${1}"
+}
+
+pkg_setup() {
+ # create the games user / group
+ games_pkg_setup
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ if use sudoku ; then
+ python_copy_sources
+ fi
+}
+
+src_configure() {
+ G2CONF="${G2CONF}
+ --disable-static
+ ITSTOOL=$(type -P true)
+ VALAC=$(type -P true)
+ --with-platform=gnome
+ --with-scores-group=${GAMES_GROUP}
+ --enable-omitgames=none" # This line should be last for _omitgame
+
+ # FIXME: Use REQUIRED_USE once games.eclass is ported to EAPI 4
+ if ! use clutter; then
+ ewarn "USE='-clutter' => quadrapassel, swell-foop, lightsoff, gnibbles won't be installed"
+ _omitgame quadrapassel
+ _omitgame gnibbles
+ _omitgame swell-foop
+ _omitgame lightsoff
+ fi
+
+ if ! use glchess; then
+ _omitgame glchess
+ fi
+
+ if ! use sudoku; then
+ _omitgame gnome-sudoku
+ fi
+
+ if use sudoku ; then
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+ else
+ gnome2_src_configure
+ fi
+}
+
+src_compile() {
+ if use sudoku ; then
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+ else
+ gnome2_src_compile
+ fi
+}
+
+src_test() {
+ if use sudoku ; then
+ python_foreach_impl run_in_build_dir Xemake check
+ else
+ Xemake check || die "tests failed"
+ fi
+}
+
+src_install() {
+ if use sudoku ; then
+ install_python() {
+ gnome2_src_install
+ python_doscript gnome-sudoku/src/gnome-sudoku
+ }
+ python_foreach_impl run_in_build_dir install_python
+ else
+ gnome2_src_install
+ fi
+
+ # Documentation install for each of the games
+ for game in \
+ $(find . -maxdepth 1 -type d ! -name po ! -name libgames-support); do
+ docinto ${game}
+ for doc in AUTHORS ChangeLog NEWS README TODO; do
+ [ -s ${game}/${doc} ] && dodoc ${game}/${doc}
+ done
+ done
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ # Avoid overwriting previous .scores files
+ local basefile
+ for scorefile in "${ED}"/var/lib/games/*.scores; do
+ basefile=$(basename $scorefile)
+ if [ -s "${EROOT}/var/lib/games/${basefile}" ]; then
+ cp "${EROOT}/var/lib/games/${basefile}" \
+ "${ED}/var/lib/games/${basefile}"
+ fi
+ done
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}
+
+run_in_build_dir() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+ "$@"
+ popd > /dev/null
+}
diff --git a/gnome-extra/gnome-games/metadata.xml b/gnome-extra/gnome-games/metadata.xml
index 91a26b1bb134..2b1240e9bb87 100644
--- a/gnome-extra/gnome-games/metadata.xml
+++ b/gnome-extra/gnome-games/metadata.xml
@@ -8,8 +8,6 @@
<flag name="clutter">Install games that use <pkg>media-libs/clutter</pkg></flag>
<flag name="glchess">Install Chess written in <pkg>dev-lang/vala</pkg> and
OpenGL</flag>
- <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
- for introspection</flag>
<flag name="sudoku">Install the game Sudoku which uses
<pkg>dev-python/pygobject</pkg> and introspection</flag>
</use>