summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-12-23 22:50:09 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-12-23 22:50:09 +0000
commit8fbf27794fba8c917ed8d14cbe4acbf91a31b771 (patch)
treefda495cadfef1e4f598ba4f18378c4afe5931deb /gnome-extra/gtkhtml
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-8fbf27794fba8c917ed8d14cbe4acbf91a31b771.tar.gz
gentoo-2-8fbf27794fba8c917ed8d14cbe4acbf91a31b771.tar.bz2
gentoo-2-8fbf27794fba8c917ed8d14cbe4acbf91a31b771.zip
Version bump. Bug fixes and translation updates.
(Portage version: 2.2_rc60/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog8
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.28.2.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index 23d97f040e24..2fced809ef58 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.201 2009/12/03 17:01:43 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.202 2009/12/23 22:50:09 eva Exp $
+
+*gtkhtml-3.28.2 (23 Dec 2009)
+
+ 23 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtkhtml-3.28.2.ebuild:
+ Version bump. Bug fixes and translation updates.
03 Dec 2009; Brent Baude <ranger@gentoo.org> gtkhtml-3.26.3.ebuild:
Marking gtkhtml-3.26.3 ppc64 stable for bug 281427
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.28.2.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.28.2.ebuild
new file mode 100644
index 000000000000..392a28a29797
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.28.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.28.2.ebuild,v 1.1 2009/12/23 22:50:09 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.14"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="glade"
+
+# We keep bonobo until we can make sure no apps in tree uses
+# the old composer code.
+RDEPEND=">=x11-libs/gtk+-2.16
+ >=gnome-base/gail-1.1
+ >=x11-themes/gnome-icon-theme-2.22.0
+ >=gnome-base/orbit-2
+ >=app-text/enchant-1.1.7
+ gnome-base/gconf:2
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4
+ glade? ( dev-util/glade:3 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_with glade glade-catalog)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Add missing file, upstream bug #597361
+ cp "${FILESDIR}/gtkhtml-editor.xml" \
+ "${S}/components/editor/gtkhtml-editor.xml" || die "cp failed"
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1::g' \
+ a11y/Makefile.am a11y/Makefile.in || die "sed 2 failed"
+
+ # ./../doltcompile: line 31: --silent : command not found
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}