summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2001-07-26 17:43:04 +0000
committerBruce A. Locke <blocke@gentoo.org>2001-07-26 17:43:04 +0000
commitebc36beeccba865c86a7b14e454afbce2a06d90f (patch)
tree27ec78f93e60a183375c28bc2db60da89a780e71 /gnome-extra/gtkhtml
parentchanged binary name to nbaudit since nat is rather confusing (packages real n... (diff)
downloadgentoo-2-ebc36beeccba865c86a7b14e454afbce2a06d90f.tar.gz
gentoo-2-ebc36beeccba865c86a7b14e454afbce2a06d90f.tar.bz2
gentoo-2-ebc36beeccba865c86a7b14e454afbce2a06d90f.zip
gtkhtml 0.10.1... simple copy of the 0.9.2 ebuild for new version... seems to work fine here
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/files/digest-gtkhtml-0.10.11
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-0.10.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/gnome-extra/gtkhtml/files/digest-gtkhtml-0.10.1 b/gnome-extra/gtkhtml/files/digest-gtkhtml-0.10.1
new file mode 100644
index 000000000000..18ddf019e4eb
--- /dev/null
+++ b/gnome-extra/gtkhtml/files/digest-gtkhtml-0.10.1
@@ -0,0 +1 @@
+MD5 54cbf3d46a8626b2deb6f57cc7fa94d8 gtkhtml-0.10.1.tar.gz
diff --git a/gnome-extra/gtkhtml/gtkhtml-0.10.1.ebuild b/gnome-extra/gtkhtml/gtkhtml-0.10.1.ebuild
new file mode 100644
index 000000000000..34ac51db54a1
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-0.10.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gtkhtml"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/gtkhtml/${A}
+ ftp://gnome.eazel.com/pub/gnome/unstable/sources/${PN}/${A}"
+HOMEPAGE="http://www.gnome.org/"
+
+DEPEND=">=gnome-base/gal-0.6
+ >=gnome-base/control-center-1.2.4
+ >=gnome-base/glibwww-0.2-r1
+ >=gnome-base/libghttp-1.0.9
+ >=gnome-base/libunicode-0.4
+ >=dev-util/xml-i18n-tools-0.8.4
+ bonobo? ( >=gnome-base/bonobo-1.0.4 )"
+
+RDEPEND=">=gnome-base/gal-0.5
+ >=gnome-base/control-center-1.2.4
+ >=gnome-base/libghttp-1.0.9
+ >=gnome-base/libunicode-0.4
+ bonobo? ( >=gnome-base/bonobo-1.0.4 )"
+
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ if [ "`use bonobo`" ]
+ then
+ myconf="${myconf} --with-bonobo"
+ else
+ myconf="${myconf} --without-bonobo"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ --sysconfdir=/etc/opt/gnome ${myconf} --with-gconf
+
+ try pmake
+}
+
+src_install() {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+
+}
+
+
+
+
+
+
+
+
+
+
+
+
+