summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-23 01:14:37 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-23 01:14:37 +0000
commita8181cac7cdc64f6119c1d8103cdd25de4ddce56 (patch)
treed1032fa8bddabca3d729f5b9cb3cbd062e411275 /gnome-extra/libgail-gnome
parentand a few final touches (diff)
downloadgentoo-2-a8181cac7cdc64f6119c1d8103cdd25de4ddce56.tar.gz
gentoo-2-a8181cac7cdc64f6119c1d8103cdd25de4ddce56.tar.bz2
gentoo-2-a8181cac7cdc64f6119c1d8103cdd25de4ddce56.zip
libgail for gnome in gnome2
Diffstat (limited to 'gnome-extra/libgail-gnome')
-rw-r--r--gnome-extra/libgail-gnome/ChangeLog7
-rw-r--r--gnome-extra/libgail-gnome/files/digest-libgail-gnome-0.5.01
-rw-r--r--gnome-extra/libgail-gnome/libgail-gnome-0.5.0.ebuild54
3 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/libgail-gnome/ChangeLog b/gnome-extra/libgail-gnome/ChangeLog
new file mode 100644
index 000000000000..9a1972579417
--- /dev/null
+++ b/gnome-extra/libgail-gnome/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for gnome-extra/libgail-gnome
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgail-gnome/ChangeLog,v 1.1 2002/05/23 01:14:37 spider Exp $
+
+*libgail-gnome-0.5 (22 May 2002)
+ 22 May 2002; Spider <spider@gentoo.org> libgail-gnome-0.5.ebuild :
+ initial release from gnome2
diff --git a/gnome-extra/libgail-gnome/files/digest-libgail-gnome-0.5.0 b/gnome-extra/libgail-gnome/files/digest-libgail-gnome-0.5.0
new file mode 100644
index 000000000000..b91e0dd30a0d
--- /dev/null
+++ b/gnome-extra/libgail-gnome/files/digest-libgail-gnome-0.5.0
@@ -0,0 +1 @@
+MD5 55ae884514698d4c57c66381f434aa46 libgail-gnome-0.5.0.tar.bz2 131592
diff --git a/gnome-extra/libgail-gnome/libgail-gnome-0.5.0.ebuild b/gnome-extra/libgail-gnome/libgail-gnome-0.5.0.ebuild
new file mode 100644
index 000000000000..5e02b8848071
--- /dev/null
+++ b/gnome-extra/libgail-gnome/libgail-gnome-0.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgail-gnome/libgail-gnome-0.5.0.ebuild,v 1.1 2002/05/23 01:14:37 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="THIS MUST BE BUILT IN X launched as root!!! "
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/libgail-gnome/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+
+RDEPEND=">=gnome-base/libgnomeui-1.112.1
+ >=gnome-base/libbonoboui-1.112.1
+ >=gnome-extra/at-spi-0.0.8
+ >=dev-libs/atk-1.0.0
+ >=gnome-base/gnome-common-1.2.4-r1"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+
+src_compile() {
+ local myconf
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+# dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3 TODO.xml
+}
+
+
+
+
+