summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-02 20:35:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-02 20:35:34 +0000
commit54e41a32fe94c3b525946e3b4e06e2e2de8413c2 (patch)
tree4a2b365836dda82047365091b3f7839050fbea93 /gnome-extra/libgsf
parentMarked ~hppa for dev-util/darcs-2.1.*. (diff)
downloadgentoo-2-54e41a32fe94c3b525946e3b4e06e2e2de8413c2.tar.gz
gentoo-2-54e41a32fe94c3b525946e3b4e06e2e2de8413c2.tar.bz2
gentoo-2-54e41a32fe94c3b525946e3b4e06e2e2de8413c2.zip
Version bump to 1.14.9.
(Portage version: 2.2_rc11/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra/libgsf')
-rw-r--r--gnome-extra/libgsf/ChangeLog7
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.9.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index d86ec09af593..6c3c63256d89 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.118 2008/08/23 12:03:10 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.119 2008/10/02 20:35:34 eva Exp $
+
+*libgsf-1.14.9 (02 Oct 2008)
+
+ 02 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org> +libgsf-1.14.9.ebuild:
+ Version bump to 1.14.9.
*libgsf-1.14.8 (23 Aug 2008)
diff --git a/gnome-extra/libgsf/libgsf-1.14.9.ebuild b/gnome-extra/libgsf/libgsf-1.14.9.ebuild
new file mode 100644
index 000000000000..5d552d4a583b
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.9.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.9.ebuild,v 1.1 2008/10/02 20:35:34 eva Exp $
+
+inherit eutils gnome2 python multilib
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 doc gnome python"
+
+RDEPEND="
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2.4.16
+ gnome? ( >=gnome-base/gconf-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/gnome-vfs-2.2 )
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ python? ( dev-lang/python
+ >=dev-python/pygobject-2.10
+ >=dev-python/pygtk-2.10 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.29
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+PDEPEND="gnome? ( media-gfx/imagemagick )"
+
+DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+
+# FIXME: requires gio-standalone, what is it ?
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-gio
+ $(use_with bzip2 bz2)
+ $(use_with gnome gnome-vfs)
+ $(use_with gnome bonobo)
+ $(use_with python)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.1
+ preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.113
+ preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.113
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gsf
+ fi
+
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.1
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.113
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.113
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ if use python; then
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gsf
+ fi
+}