summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-13 08:05:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-13 08:05:54 +0000
commit8405c8a6e4c599df0be218d58e45eed72f9d6869 (patch)
tree1e739a8f8522ac0148b7528892832fa0f9932e79 /gnome-extra/panflute
parentold (diff)
downloadgentoo-2-8405c8a6e4c599df0be218d58e45eed72f9d6869.tar.gz
gentoo-2-8405c8a6e4c599df0be218d58e45eed72f9d6869.tar.bz2
gentoo-2-8405c8a6e4c599df0be218d58e45eed72f9d6869.zip
Fix compability with x11-libs/libnotify >= 0.7 wrt #357877 by Justin Lecher.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/panflute')
-rw-r--r--gnome-extra/panflute/ChangeLog8
-rw-r--r--gnome-extra/panflute/files/panflute-0.6.2-libnotify-0.7.patch13
-rw-r--r--gnome-extra/panflute/panflute-0.6.2.ebuild7
3 files changed, 24 insertions, 4 deletions
diff --git a/gnome-extra/panflute/ChangeLog b/gnome-extra/panflute/ChangeLog
index 248468414a2b..0c578dcf45fc 100644
--- a/gnome-extra/panflute/ChangeLog
+++ b/gnome-extra/panflute/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/panflute
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/ChangeLog,v 1.3 2010/12/08 22:44:57 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/ChangeLog,v 1.4 2011/03/13 08:05:54 ssuominen Exp $
+
+ 13 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> panflute-0.6.2.ebuild,
+ +files/panflute-0.6.2-libnotify-0.7.patch:
+ Fix compability with x11-libs/libnotify >= 0.7 wrt #357877 by Justin Lecher.
08 Dec 2010; Gilles Dartiguelongue <eva@gentoo.org> panflute-0.6.2.ebuild:
Handle multiple ABI python, bug #324173.
diff --git a/gnome-extra/panflute/files/panflute-0.6.2-libnotify-0.7.patch b/gnome-extra/panflute/files/panflute-0.6.2-libnotify-0.7.patch
new file mode 100644
index 000000000000..327025e8b2a3
--- /dev/null
+++ b/gnome-extra/panflute/files/panflute-0.6.2-libnotify-0.7.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/show_bug.cgi?id=357877#c9
+
+--- src/panflute/applet/applet.py
++++ src/panflute/applet/applet.py
+@@ -352,7 +352,7 @@
+
+ try:
+ import pynotify
+- notification = pynotify.Notification (" ", "", None, None)
++ notification = pynotify.Notification (" ", "", None)
+ notification.set_urgency (pynotify.URGENCY_LOW)
+ return notification
+ except ImportError, e:
diff --git a/gnome-extra/panflute/panflute-0.6.2.ebuild b/gnome-extra/panflute/panflute-0.6.2.ebuild
index 802bc4f608d1..4dab18b08b55 100644
--- a/gnome-extra/panflute/panflute-0.6.2.ebuild
+++ b/gnome-extra/panflute/panflute-0.6.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/panflute-0.6.2.ebuild,v 1.3 2010/12/08 22:44:57 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/panflute/panflute-0.6.2.ebuild,v 1.4 2011/03/13 08:05:54 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -51,6 +51,9 @@ pkg_setup() {
src_prepare() {
gnome2_src_prepare
+ has_version ">=x11-libs/libnotify-0.7" && epatch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
+
# disable pyc compiling
mv py-compile py-compile.orig
ln -s $(type -P true) py-compile