summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-09 03:57:44 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-09 03:57:44 +0000
commit5d687b6292b0b563709960629c4a65158cd70be4 (patch)
treee27568986a56df90051463164696589730c2d49a /gnome-extra
parentVersion bump. (diff)
downloadgentoo-2-5d687b6292b0b563709960629c4a65158cd70be4.tar.gz
gentoo-2-5d687b6292b0b563709960629c4a65158cd70be4.tar.bz2
gentoo-2-5d687b6292b0b563709960629c4a65158cd70be4.zip
Version bump for Cinnamon 2.2.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nemo/ChangeLog7
-rw-r--r--gnome-extra/nemo/nemo-2.2.1.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/gnome-extra/nemo/ChangeLog b/gnome-extra/nemo/ChangeLog
index 58e45a795b03..919d43d04dbc 100644
--- a/gnome-extra/nemo/ChangeLog
+++ b/gnome-extra/nemo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/nemo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nemo/ChangeLog,v 1.10 2014/04/26 20:10:58 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nemo/ChangeLog,v 1.11 2014/05/09 03:57:44 tetromino Exp $
+
+*nemo-2.2.1 (09 May 2014)
+
+ 09 May 2014; Alexandre Rostovtsev <tetromino@gentoo.org> +nemo-2.2.1.ebuild:
+ Version bump for Cinnamon 2.2.
26 Apr 2014; Pacho Ramos <pacho@gentoo.org>
-files/nemo-1.1.2-view-toolbar.patch, -nemo-1.1.2.ebuild, -nemo-1.8.3.ebuild:
diff --git a/gnome-extra/nemo/nemo-2.2.1.ebuild b/gnome-extra/nemo/nemo-2.2.1.ebuild
new file mode 100644
index 000000000000..875667c160a0
--- /dev/null
+++ b/gnome-extra/nemo/nemo-2.2.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nemo/nemo-2.2.1.ebuild,v 1.1 2014/05/09 03:57:44 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools eutils gnome2 python-any-r1 virtualx
+
+DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/nemo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="exif +introspection packagekit tracker xmp"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34:2
+ >=gnome-extra/cinnamon-desktop-1.0:0=
+ >=x11-libs/pango-1.28.3
+ >=x11-libs/gtk+-3.3.17:3[introspection?]
+ >=dev-libs/libxml2-2.7.8:2
+
+ gnome-base/dconf:0=
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/libnotify-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ exif? ( >=media-libs/libexif-0.6.20:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ tracker? ( >=app-misc/tracker-0.12:= )
+ xmp? ( >=media-libs/exempi-2.1.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/gnome-icon-theme-symbolic
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/polib[${PYTHON_USEDEP}]')
+ >=dev-lang/perl-5
+ >=dev-util/gdbus-codegen-2.31.0
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto
+
+ dev-util/gtk-doc
+ gnome-base/gnome-common
+"
+# For eautoreconf
+# gnome-base/gnome-common, dev-util/gtk-doc (not only -am!)
+PDEPEND=">=gnome-base/gvfs-0.1.2"
+
+src_prepare() {
+ epatch_user
+ eautoreconf # no configure in tarball
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-update-mimedb \
+ --disable-more-warnings \
+ $(use_enable exif libexif) \
+ $(use_enable introspection) \
+ $(use_enable tracker) \
+ $(use_enable xmp)
+}
+
+src_test() {
+ if ! [[ -f "${EROOT}usr/share/glib-2.0/schemas/org.nemo.gschema.xml" ]]; then
+ ewarn "Skipping tests because Nemo gsettings schema are not installed."
+ ewarn "To run the tests, a version of ${CATEGORY}/${PN} needs to be"
+ ewarn "already installed."
+ return
+ fi
+ gnome2_environment_reset
+ unset DBUS_SESSION_BUS_ADDRESS
+ export GSETTINGS_BACKEND="memory"
+ cd src # we don't care about translation tests
+ Xemake check
+ unset GSETTINGS_BACKEND
+}