summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-04-09 09:44:38 +0000
committerPacho Ramos <pacho@gentoo.org>2010-04-09 09:44:38 +0000
commit7f6ecfecdd88069ffcee4bae2eec65fd50092feb (patch)
tree7713ef4116c983d6bb28d28bc1f45a268df896bc /gnome-extra
parentamd64 stable, bug 295947 (diff)
downloadgentoo-2-7f6ecfecdd88069ffcee4bae2eec65fd50092feb.tar.gz
gentoo-2-7f6ecfecdd88069ffcee4bae2eec65fd50092feb.tar.bz2
gentoo-2-7f6ecfecdd88069ffcee4bae2eec65fd50092feb.zip
Version bump
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/ChangeLog7
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.18.ebuild98
2 files changed, 104 insertions, 1 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index 7f6afda3ec78..8ef153930242 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.155 2010/03/31 21:01:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.156 2010/04/09 09:44:38 pacho Exp $
+
+*libgsf-1.14.18 (09 Apr 2010)
+
+ 09 Apr 2010; Pacho Ramos <pacho@gentoo.org> +libgsf-1.14.18.ebuild:
+ Version bump fixing zip directory record problem.
31 Mar 2010; Gilles Dartiguelongue <eva@gentoo.org>
-libgsf-1.14.16.ebuild, libgsf-1.14.17.ebuild:
diff --git a/gnome-extra/libgsf/libgsf-1.14.18.ebuild b/gnome-extra/libgsf/libgsf-1.14.18.ebuild
new file mode 100644
index 000000000000..8c4435d18c91
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.18.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.18.ebuild,v 1.1 2010/04/09 09:44:38 pacho Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 python multilib
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gnome-mplayer-0.9.6-gconf-2.m4.tgz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 doc gnome gtk python thumbnail"
+
+RDEPEND="
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2.4.16
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gnome? (
+ >=gnome-base/libbonobo-2
+ >=gnome-base/gnome-vfs-2.2 )
+ gtk? ( >=x11-libs/gtk+-2 )
+ python? (
+ >=dev-python/pygobject-2.10
+ >=dev-python/pygtk-2.10 )
+ thumbnail? ( >=gnome-base/gconf-2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+PDEPEND="gnome? ( || (
+ media-gfx/imagemagick
+ media-gfx/graphicsmagick[imagemagick] ) )"
+
+DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-gio
+ --disable-static
+ $(use_with bzip2 bz2)
+ $(use_with gnome gnome-vfs)
+ $(use_with gnome bonobo)
+ $(use_with python)
+ $(use_with gtk gdk-pixbuf)
+ $(use_with thumbnail gconf)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ cp "${WORKDIR}/gnome-mplayer-0.9.6-gconf-2.m4" m4/ \
+ || die "failed to copy gconf macro"
+
+ # Fix gconf automagic, bug #289856
+ epatch "${FILESDIR}/${PN}-1.14.16-gconf-automagic.patch"
+
+ # Fix useless variable in toplevel Makefile.am, bug #298813
+ epatch "${FILESDIR}/${PN}-1.14.16-automake-fixes.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.1
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if use python; then
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/gsf
+ fi
+
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.1
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/gsf
+}