summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-19 20:21:38 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-19 20:21:38 +0000
commitd479ba315e0577eb5128bcc92081c57e2674a6ee (patch)
treef811fd80f3222006ca510c5a48377b7a107a2ecc /gnome-extra
parentVersion bump to 0.6.4 which fixes all compilation errors and most test errors... (diff)
downloadgentoo-2-d479ba315e0577eb5128bcc92081c57e2674a6ee.tar.gz
gentoo-2-d479ba315e0577eb5128bcc92081c57e2674a6ee.tar.bz2
gentoo-2-d479ba315e0577eb5128bcc92081c57e2674a6ee.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-contacts/ChangeLog7
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.8.1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/gnome-extra/gnome-contacts/ChangeLog b/gnome-extra/gnome-contacts/ChangeLog
index 4b651b9161c1..785095b11042 100644
--- a/gnome-extra/gnome-contacts/ChangeLog
+++ b/gnome-extra/gnome-contacts/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/gnome-contacts
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/ChangeLog,v 1.15 2013/03/30 15:01:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/ChangeLog,v 1.16 2013/04/19 20:21:38 pacho Exp $
+
+*gnome-contacts-3.8.1 (19 Apr 2013)
+
+ 19 Apr 2013; Pacho Ramos <pacho@gentoo.org> +gnome-contacts-3.8.1.ebuild:
+ Version bump
30 Mar 2013; Pacho Ramos <pacho@gentoo.org> gnome-contacts-3.8.0.ebuild:
Don't run vala_src_prepare two times (#463776 by Harris Landgarten).
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.8.1.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.8.1.ebuild
new file mode 100644
index 000000000000..b7493220ef3c
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.8.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-contacts/gnome-contacts-3.8.1.ebuild,v 1.1 2013/04/19 20:21:38 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://live.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="v4l"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+VALA_DEPEND="$(vala_depend)
+ dev-libs/folks[vala]
+ gnome-base/gnome-desktop[introspection]
+ gnome-extra/evolution-data-server[vala]
+ net-libs/telepathy-glib[vala]
+ x11-libs/libnotify[introspection]"
+
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=dev-libs/folks-0.7.3:=[eds,telepathy]
+ >=dev-libs/glib-2.31.10:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-extra/evolution-data-server-3.5.3:=[gnome-online-accounts]
+ >=gnome-base/gnome-desktop-3.0:3=
+ net-libs/gnome-online-accounts
+ >=net-libs/telepathy-glib-0.17.5
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libnotify:=
+ >=x11-libs/gtk+-3.4:3
+ x11-libs/pango
+ v4l? ( >=media-video/cheese-3.5.91:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ !v4l? ( ${VALA_DEPEND} )"
+# When !v4l, we regenerate the .c sources
+
+src_prepare() {
+ # Regenerate the pre-generated C sources
+ if ! use v4l; then
+ touch src/*.vala
+ fi
+
+ gnome2_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure $(use_with v4l cheese)
+}