summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-17 22:45:15 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-17 22:45:15 +0000
commite890764131accf6774b37ec3763727ec531989a7 (patch)
tree892c57f190e1a128798e28a7c7445f4426e7bd52 /gnome-extra
parentinitial commit. (diff)
downloadgentoo-2-e890764131accf6774b37ec3763727ec531989a7.tar.gz
gentoo-2-e890764131accf6774b37ec3763727ec531989a7.tar.bz2
gentoo-2-e890764131accf6774b37ec3763727ec531989a7.zip
fix python eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/ChangeLog5
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.7.ebuild32
2 files changed, 28 insertions, 9 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index 3915177d154c..934a8f07091a 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.114 2008/01/30 16:02:59 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.115 2008/02/17 22:45:15 eva Exp $
+
+ 17 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org> libgsf-1.14.7.ebuild:
+ fix python eclass use, bug #207667
30 Jan 2008; Daniel Gryniewicz <dang@gentoo.org> libgsf-1.14.7.ebuild:
Fix imagemagick circular dep; bug #206491
diff --git a/gnome-extra/libgsf/libgsf-1.14.7.ebuild b/gnome-extra/libgsf/libgsf-1.14.7.ebuild
index e5b5bc57c5a5..1ecf9615b9e3 100644
--- a/gnome-extra/libgsf/libgsf-1.14.7.ebuild
+++ b/gnome-extra/libgsf/libgsf-1.14.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.7.ebuild,v 1.8 2008/01/30 16:02:59 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.7.ebuild,v 1.9 2008/02/17 22:45:15 eva Exp $
inherit eutils gnome2 python multilib
@@ -30,13 +30,23 @@ DEPEND="${RDEPEND}
PDEPEND="gnome? ( media-gfx/imagemagick )"
-G2CONF="${G2CONF} \
- $(use_with bzip2 bz2) \
- $(use_with gnome) \
- $(use_with python)"
-
DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with bzip2 bz2)
+ $(use_with gnome)
+ $(use_with python)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
pkg_preinst() {
preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.1
preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.1
@@ -46,7 +56,10 @@ pkg_preinst() {
pkg_postinst() {
gnome2_pkg_postinst
- use python && python_mod_optimize "${ROOT}"usr/$(get_libdir)/python*/site-packages/gsf
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/gsf
+ fi
preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.1
preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.1
@@ -56,5 +69,8 @@ pkg_postinst() {
pkg_postrm() {
gnome2_pkg_postrm
- use python && python_mod_cleanup "${ROOT}"usr/$(get_libdir)/python*/site-packages/gsf
+ if use python; then
+ python_version
+ python_mod_cleanup "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/gsf
+ fi
}