summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-02-09 17:28:32 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-02-09 17:28:32 +0000
commit1004a5cab68c6301f79db99ccd7d4a88e7035c19 (patch)
tree62d5f311b88179d651b728d78e681c6af84217a4 /gnustep-apps
parentAdded initial ebuild for PHP libevent wrapper (diff)
downloadgentoo-2-1004a5cab68c6301f79db99ccd7d4a88e7035c19.tar.gz
gentoo-2-1004a5cab68c6301f79db99ccd7d4a88e7035c19.tar.bz2
gentoo-2-1004a5cab68c6301f79db99ccd7d4a88e7035c19.zip
Fix compilation with clang, drop old version
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-apps')
-rw-r--r--gnustep-apps/price/ChangeLog8
-rw-r--r--gnustep-apps/price/files/price-1.0.0-PRCustTraceEdges_include.patch20
-rw-r--r--gnustep-apps/price/price-0.9.1.ebuild25
-rw-r--r--gnustep-apps/price/price-1.0.0.ebuild8
4 files changed, 32 insertions, 29 deletions
diff --git a/gnustep-apps/price/ChangeLog b/gnustep-apps/price/ChangeLog
index 836d750c5f66..fb8c2936f79c 100644
--- a/gnustep-apps/price/ChangeLog
+++ b/gnustep-apps/price/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnustep-apps/price
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/ChangeLog,v 1.24 2011/12/21 08:47:43 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/ChangeLog,v 1.25 2012/02/09 17:28:32 voyageur Exp $
+
+ 09 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> -price-0.9.1.ebuild,
+ price-1.0.0.ebuild, +files/price-1.0.0-PRCustTraceEdges_include.patch:
+ Fix compilation with clang, drop old version
21 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> price-1.0.0.ebuild:
x86 stable wrt bug #393935
diff --git a/gnustep-apps/price/files/price-1.0.0-PRCustTraceEdges_include.patch b/gnustep-apps/price/files/price-1.0.0-PRCustTraceEdges_include.patch
new file mode 100644
index 000000000000..d071192ac892
--- /dev/null
+++ b/gnustep-apps/price/files/price-1.0.0-PRCustTraceEdges_include.patch
@@ -0,0 +1,20 @@
+--- PRCustTraceEdges.h 2008/08/21 21:31:07 1.9
++++ PRCustTraceEdges.h 2011/04/06 12:59:03 1.10
+@@ -3,7 +3,7 @@
+ // PRICE
+ //
+ // Created by Riccardo Mottola on Fri Mar 19 2004.
+-// Copyright (c) 2004 Carduus. All rights reserved.
++// Copyright (c) 2004-2011 Carduus. All rights reserved.
+ //
+ // This application is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.
+ // This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+@@ -11,7 +11,7 @@
+ #import <AppKit/AppKit.h>
+ #import "PRProgressAction.h"
+ #import "PRImage.h"
+-
++#import "PRMedian.h"
+
+ @interface PRCustTraceEdges : PRProgressAction
+ {
diff --git a/gnustep-apps/price/price-0.9.1.ebuild b/gnustep-apps/price/price-0.9.1.ebuild
deleted file mode 100644
index e0acfd3d40a8..000000000000
--- a/gnustep-apps/price/price-0.9.1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/price-0.9.1.ebuild,v 1.1 2010/01/05 10:52:52 voyageur Exp $
-
-EAPI=2
-inherit gnustep-2
-
-MY_P=PRICE-${PV}
-DESCRIPTION="Precision Raster Image Convolution Engine"
-HOMEPAGE="http://price.sourceforge.net/"
-SRC_URI="mirror://sourceforge/price/${MY_P}.tar.gz"
-KEYWORDS="~amd64 ~ppc ~x86"
-SLOT="0"
-LICENSE="GPL-2"
-IUSE=""
-
-DEPEND=">=gnustep-base/gnustep-gui-0.13.0"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Mixmatching #include and #import on limits.h leads to bug #278160
- sed -i -e 's/#import <limits.h>/#include <limits.h>/' *.m || die "sed failed"
-}
diff --git a/gnustep-apps/price/price-1.0.0.ebuild b/gnustep-apps/price/price-1.0.0.ebuild
index b3c0d39ba42c..a4498ecbe0d8 100644
--- a/gnustep-apps/price/price-1.0.0.ebuild
+++ b/gnustep-apps/price/price-1.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/price-1.0.0.ebuild,v 1.4 2011/12/21 08:47:43 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/price/price-1.0.0.ebuild,v 1.5 2012/02/09 17:28:32 voyageur Exp $
EAPI=2
inherit gnustep-2
@@ -18,3 +18,7 @@ DEPEND=">=gnustep-base/gnustep-gui-0.13.0"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-PRCustTraceEdges_include.patch
+}