summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo Arrifano <miknix@gentoo.org>2009-07-15 02:04:23 +0000
committerAngelo Arrifano <miknix@gentoo.org>2009-07-15 02:04:23 +0000
commit25c0dd08bfbfb489c49eb2ddbd4911e37d7f81ec (patch)
tree41e7c3cced3fced1829564ecd53951c5ad4639cf /gpe-base
parentFixed some tests that failed. Closes Bug #223055. (diff)
downloadgentoo-2-25c0dd08bfbfb489c49eb2ddbd4911e37d7f81ec.tar.gz
gentoo-2-25c0dd08bfbfb489c49eb2ddbd4911e37d7f81ec.tar.bz2
gentoo-2-25c0dd08bfbfb489c49eb2ddbd4911e37d7f81ec.zip
Prevent gtk-doc being always installed, add doc use flag.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'gpe-base')
-rw-r--r--gpe-base/libgpevtype/ChangeLog5
-rw-r--r--gpe-base/libgpevtype/libgpevtype-0.50.ebuild22
2 files changed, 22 insertions, 5 deletions
diff --git a/gpe-base/libgpevtype/ChangeLog b/gpe-base/libgpevtype/ChangeLog
index 5e5c0e41c232..f7694fb38a00 100644
--- a/gpe-base/libgpevtype/ChangeLog
+++ b/gpe-base/libgpevtype/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gpe-base/libgpevtype
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gpe-base/libgpevtype/ChangeLog,v 1.1 2009/03/01 00:31:48 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/gpe-base/libgpevtype/ChangeLog,v 1.2 2009/07/15 02:04:23 miknix Exp $
+
+ 15 Jul 2009; Angelo Arrifano <miknix@gentoo.org> libgpevtype-0.50.ebuild:
+ Prevent gtk-doc being always installed, add doc use flag.
*libgpevtype-0.50 (01 Mar 2009)
diff --git a/gpe-base/libgpevtype/libgpevtype-0.50.ebuild b/gpe-base/libgpevtype/libgpevtype-0.50.ebuild
index 7582d8918d6c..c51f7aa59991 100644
--- a/gpe-base/libgpevtype/libgpevtype-0.50.ebuild
+++ b/gpe-base/libgpevtype/libgpevtype-0.50.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gpe-base/libgpevtype/libgpevtype-0.50.ebuild,v 1.2 2009/03/01 06:00:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/gpe-base/libgpevtype/libgpevtype-0.50.ebuild,v 1.3 2009/07/15 02:04:23 miknix Exp $
GPE_TARBALL_SUFFIX="bz2"
-inherit gpe
+inherit gpe autotools
DESCRIPTION="Data interchange library for the GPE Palmtop Environment"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~arm ~amd64 ~x86"
-IUSE="${IUSE}"
+IUSE="${IUSE} doc"
GPE_DOCS="ChangeLog"
+GPECONF="${GPECONF} $(use_enable doc gtk-doc)"
RDEPEND="${RDEPEND}
gpe-base/libtododb
@@ -20,4 +21,17 @@ RDEPEND="${RDEPEND}
>=gpe-base/libeventdb-0.29"
DEPEND="${DEPEND}
- ${RDEPEND}"
+ ${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.2 )"
+
+src_unpack() {
+ gpe_src_unpack "$@"
+
+ if ! use doc; then
+ sed -i -e 's;SUBDIRS = doc;SUBDIRS = ;' Makefile.am \
+ || die "sed failed"
+ fi
+
+ eautoreconf
+}
+