summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-09 04:40:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-09 04:40:21 +0000
commitea1e35540fdafa6539b0f1cb73e9434ae902efed (patch)
tree7f598392e07ac9b8908e150260b32cf8c3f64c0b /kde-base/arts
parenthppa stable (diff)
downloadgentoo-2-ea1e35540fdafa6539b0f1cb73e9434ae902efed.tar.gz
gentoo-2-ea1e35540fdafa6539b0f1cb73e9434ae902efed.tar.bz2
gentoo-2-ea1e35540fdafa6539b0f1cb73e9434ae902efed.zip
touchups
Diffstat (limited to 'kde-base/arts')
-rw-r--r--kde-base/arts/ChangeLog5
-rw-r--r--kde-base/arts/arts-1.2.0.ebuild32
2 files changed, 22 insertions, 15 deletions
diff --git a/kde-base/arts/ChangeLog b/kde-base/arts/ChangeLog
index be26f39b5833..424cb1c86abe 100644
--- a/kde-base/arts/ChangeLog
+++ b/kde-base/arts/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/arts
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.75 2004/02/05 16:32:14 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/ChangeLog,v 1.76 2004/02/09 04:40:21 vapier Exp $
+
+ 08 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
+ Move a lot of code out of global scope since it shouldnt be there ;).
05 Feb 2004; Luca Barbato <lu_zero@gentoo.org> arts-1.2.0.ebuild:
Marked ~ppc
diff --git a/kde-base/arts/arts-1.2.0.ebuild b/kde-base/arts/arts-1.2.0.ebuild
index afebd7398f3d..fe8a119a2a33 100644
--- a/kde-base/arts/arts-1.2.0.ebuild
+++ b/kde-base/arts/arts-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.0.ebuild,v 1.5 2004/02/09 04:36:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.0.ebuild,v 1.6 2004/02/09 04:40:21 vapier Exp $
inherit kde flag-o-matic
set-kdedir 3.2
@@ -23,19 +23,6 @@ DEPEND="alsa? ( media-libs/alsa-lib virtual/alsa )
>=x11-libs/qt-3.2
>=sys-apps/portage-2.0.49-r8"
-if [ "${COMPILER}" == "gcc3" ]; then
- # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
- # these.. Even starting a compile shuts down the arts server
- filter-flags -fomit-frame-pointer -fstrength-reduce
-fi
-
-#fix bug 13453
-filter-flags "-foptimize-sibling-calls"
-
-myconf="$myconf `use_enable alsa`"
-myconf="$myconf `use_enable oggvorbis vorbis`"
-myconf="$myconf `use_enable mad libmad`"
-
# patch to configure.in.in that makes the vorbis, libmad deps optional
# has no version number in its filename because it's the same for all
# arts versions - the patched file hasn't changed in a year's time
@@ -48,6 +35,23 @@ src_unpack() {
# rm -f $S/configure
}
+src_compile() {
+ if [ "${COMPILER}" == "gcc3" ]; then
+ # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+ # these.. Even starting a compile shuts down the arts server
+ filter-flags -fomit-frame-pointer -fstrength-reduce
+ fi
+
+ #fix bug 13453
+ filter-flags -foptimize-sibling-calls
+
+ myconf="$myconf `use_enable alsa`"
+ myconf="$myconf `use_enable oggvorbis vorbis`"
+ myconf="$myconf `use_enable mad libmad`"
+
+ kde_src_compile
+}
+
src_install() {
kde_src_install
dodoc ${S}/doc/{NEWS,README,TODO}