summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-02 23:55:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-02 23:55:27 +0000
commit53ed26851f04feee27f28807cd20c5624511a3f8 (patch)
tree2fde07263aab7c2bdd2b2b2b23e013ca5a190e15 /kde-base/artsplugin-akode/artsplugin-akode-3.5.2-r1.ebuild
parentMasking app-misc/colortail pending removal (diff)
downloadgentoo-2-53ed26851f04feee27f28807cd20c5624511a3f8.tar.gz
gentoo-2-53ed26851f04feee27f28807cd20c5624511a3f8.tar.bz2
gentoo-2-53ed26851f04feee27f28807cd20c5624511a3f8.zip
Add patch to avoid memory leak in arts when using akode plugin. Thanks to Matthew Stapleton for the patch in bug #128574.
(Portage version: 2.1_pre7-r3)
Diffstat (limited to 'kde-base/artsplugin-akode/artsplugin-akode-3.5.2-r1.ebuild')
-rw-r--r--kde-base/artsplugin-akode/artsplugin-akode-3.5.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-base/artsplugin-akode/artsplugin-akode-3.5.2-r1.ebuild b/kde-base/artsplugin-akode/artsplugin-akode-3.5.2-r1.ebuild
new file mode 100644
index 000000000000..df66049f28a8
--- /dev/null
+++ b/kde-base/artsplugin-akode/artsplugin-akode-3.5.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-akode/artsplugin-akode-3.5.2-r1.ebuild,v 1.1 2006/04/02 23:55:27 flameeyes Exp $
+
+KMNAME=kdemultimedia
+KMMODULE=akode_artsplugin
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="akode arts plugin"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="media-libs/akode
+ $(deprange $PV $MAXKDEVER kde-base/kdemultimedia-arts)"
+
+KMCOPYLIB="libartsbuilder arts/runtime"
+
+PATCHES="${FILESDIR}/${P}-memleak.patch"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+}
+
+src_compile() {
+ local myconf="--with-akode"
+
+ kde-meta_src_compile
+}