summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-02-06 07:49:01 +0000
committerDan Armak <danarmak@gentoo.org>2005-02-06 07:49:01 +0000
commit47fdbfd302c9372c1db8320fcb8cb739d6950066 (patch)
tree528d2c85d3a92acd4f80df78138446f9d9955717 /kde-base/artsplugin-mpeglib
parentClean up ebuild and move manpages/patches to our mirrors. (diff)
downloadgentoo-2-47fdbfd302c9372c1db8320fcb8cb739d6950066.tar.gz
gentoo-2-47fdbfd302c9372c1db8320fcb8cb739d6950066.tar.bz2
gentoo-2-47fdbfd302c9372c1db8320fcb8cb739d6950066.zip
add patch fixing typo in Makefile.am. I'm not sure the typo actually breaks anything, but it could... sumitted upstream as bugs.kde.org 98675.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'kde-base/artsplugin-mpeglib')
-rw-r--r--kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild6
-rw-r--r--kde-base/artsplugin-mpeglib/files/artsc-typo.diff11
2 files changed, 15 insertions, 2 deletions
diff --git a/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild
index 3cc9d37de8fe..f564c34b035c 100644
--- a/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild
+++ b/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild,v 1.1 2005/02/05 11:39:10 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/artsplugin-mpeglib/artsplugin-mpeglib-3.4.0_beta2.ebuild,v 1.2 2005/02/06 07:49:01 danarmak Exp $
KMNAME=kdemultimedia
KMMODULE=mpeglib_artsplug
@@ -16,9 +16,11 @@ OLDDEPEND="~kde-base/mpeglib-$PV"
KMCOPYLIB="libmpeg mpeglib/lib/"
KMEXTRACTONLY="mpeglib/"
+PATCHES="$FILESDIR/artsc-typo.diff" # bugs.kde.org 98675
+
pkg_setup() {
if ! useq arts; then
eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
die
fi
-} \ No newline at end of file
+}
diff --git a/kde-base/artsplugin-mpeglib/files/artsc-typo.diff b/kde-base/artsplugin-mpeglib/files/artsc-typo.diff
new file mode 100644
index 000000000000..f5bd037aeaaa
--- /dev/null
+++ b/kde-base/artsplugin-mpeglib/files/artsc-typo.diff
@@ -0,0 +1,11 @@
+--- mpeglib_artsplug/Makefile.am.orig 2005-02-04 00:48:27.000000000 +0200
++++ mpeglib_artsplug/Makefile.am 2005-02-06 09:27:29.095013192 +0200
+@@ -89,7 +89,7 @@
+
+ bin_PROGRAMS = mpeglibartsplay
+
+-mpeglibartsplay_LDFLAGS = $(ARTCS_LIBS) $(all_libraries)
++mpeglibartsplay_LDFLAGS = $(ARTSC_LIBS) $(all_libraries)
+ mpeglibartsplay_SOURCES = mpeglibartsplay.cpp
+
+ mpeglibartsplay_LDADD = -lsoundserver_idl \