summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit0650db9ab87aa55db42a5157e24d12132d2832ae (patch)
treefb6d626c063029446861ab8305a09ef01b29fd36 /kde-base/dolphin-plugins
parentVersion bump. Remove intermediate version. (diff)
downloadgentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.gz
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.bz2
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.zip
Version bump to KDE SC 4.6.3.
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog8
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.6.3.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 2879a1aaddce..1a42d640c004 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.12 2011/04/07 16:03:40 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.13 2011/05/07 10:47:46 scarabeus Exp $
+
+*dolphin-plugins-4.6.3 (07 May 2011)
+
+ 07 May 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +dolphin-plugins-4.6.3.ebuild:
+ Version bump KDE SC 4.6.3
07 Apr 2011; Kacper Kowalik <xarthisius@gentoo.org>
dolphin-plugins-4.6.2.ebuild:
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.6.3.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.6.3.ebuild
new file mode 100644
index 000000000000..27ad22b191da
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.6.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.6.3.ebuild,v 1.1 2011/05/07 10:47:46 scarabeus Exp $
+
+EAPI=4
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +git +subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ git? ( dev-vcs/git )
+ subversion? ( dev-vcs/subversion )
+"
+
+# SCM plugins moved from dolphin somewhere before 4.4.75
+add_blocker dolphin '<4.4.75'
+
+KMLOADLIBS="libkonq"
+
+#
+# See bug 351147 for why this is necessary
+#
+src_prepare() {
+ echo 'macro_optional_add_subdirectory ( dolphin-plugins )' >> CMakeLists.txt || die
+ echo > dolphin-plugins/CMakeLists.txt || die
+ use git && echo 'add_subdirectory ( git )' >> dolphin-plugins/CMakeLists.txt
+ use subversion && echo 'add_subdirectory ( svn )' >> dolphin-plugins/CMakeLists.txt
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ { use git || use subversion; } && kde4-meta_src_install
+}