summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-03 16:31:05 +0000
commitaed7569556697316dc345ae4ca172377916e8ab2 (patch)
tree6e2289aa47f31b041e7299a47dc94defaa7729a3 /kde-base/kalgebra
parentKeyword ~ppc64 wrt #337385 (diff)
downloadgentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.tar.gz
gentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.tar.bz2
gentoo-2-aed7569556697316dc345ae4ca172377916e8ab2.zip
KDE SC 4.5.3 Version bump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog7
-rw-r--r--kde-base/kalgebra/kalgebra-4.5.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index 1c5fe6aa5271..f8979a1517fd 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.74 2010/10/06 09:17:20 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.75 2010/11/03 16:31:02 scarabeus Exp $
+
+*kalgebra-4.5.3 (03 Nov 2010)
+
+ 03 Nov 2010; Tomáš Chvátal <scarabeus@gentoo.org> +kalgebra-4.5.3.ebuild:
+ Version bump
*kalgebra-4.5.2 (05 Oct 2010)
diff --git a/kde-base/kalgebra/kalgebra-4.5.3.ebuild b/kde-base/kalgebra/kalgebra-4.5.3.ebuild
new file mode 100644
index 000000000000..4aeb845cd945
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.5.3.ebuild,v 1.1 2010/11/03 16:31:02 scarabeus Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris-graph2d.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-meta_src_test
+}