summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-07-27 14:04:54 +0000
commitdcee7201ef2606358a4f2abc45af713ef2555e5a (patch)
treedac1ea20988f395333c20c4985b60f84f2e71a82 /kde-base/kalgebra
parentbump to the TeX Live 2011 version (diff)
downloadgentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.gz
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.tar.bz2
gentoo-2-dcee7201ef2606358a4f2abc45af713ef2555e5a.zip
[kde-base] Version bump KDE SC 4.7.0
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog7
-rw-r--r--kde-base/kalgebra/kalgebra-4.7.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index a27fec2b834a..446cbc9ee995 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.93 2011/07/10 20:39:47 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.94 2011/07/27 14:04:31 alexxy Exp $
+
+*kalgebra-4.7.0 (27 Jul 2011)
+
+ 27 Jul 2011; Alexey Shvetsov <alexxy@gentoo.org> +kalgebra-4.7.0.ebuild:
+ Version bump KDE SC 4.7.0
10 Jul 2011; Theo Chatzimichos <tampakrap@gentoo.org> kalgebra-4.6.5.ebuild:
Add missing patch
diff --git a/kde-base/kalgebra/kalgebra-4.7.0.ebuild b/kde-base/kalgebra/kalgebra-4.7.0.ebuild
new file mode 100644
index 000000000000..f3baafb9b4da
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.7.0.ebuild,v 1.1 2011/07/27 14:04:31 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+OPENGL_REQUIRED="optional"
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+"
+KMEXTRA="
+ libkdeedu/qtmmlwidget/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.5.73-solaris-graph2d.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-base_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-base_src_test
+}