summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-11-02 20:35:59 +0000
committerAlex Alexander <wired@gentoo.org>2009-11-02 20:35:59 +0000
commita57401678100615cdbb3348d332bcd0574af7da5 (patch)
treeedefe0c62e922639353d8351e8b7f897e5b1f2ff /kde-base/kalzium
parentVersion bump KDE 4.3.3 (diff)
downloadgentoo-2-a57401678100615cdbb3348d332bcd0574af7da5.tar.gz
gentoo-2-a57401678100615cdbb3348d332bcd0574af7da5.tar.bz2
gentoo-2-a57401678100615cdbb3348d332bcd0574af7da5.zip
Version bump KDE 4.3.3
(Portage version: 2.2_rc48/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.3.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 64acda187f74..097983fc0ebd 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.141 2009/10/18 16:04:46 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.142 2009/11/02 20:35:59 wired Exp $
+
+*kalzium-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +kalzium-4.3.3.ebuild:
+ Version bump
18 Oct 2009; Markus Meier <maekke@gentoo.org> kalzium-4.3.1.ebuild:
x86 stable, bug #287697
diff --git a/kde-base/kalzium/kalzium-4.3.3.ebuild b/kde-base/kalzium/kalzium-4.3.3.ebuild
new file mode 100644
index 000000000000..d0ac23ab2872
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.3.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.3.3.ebuild,v 1.1 2009/11/02 20:35:59 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="editor debug +handbook +plasma solver"
+
+COMMON_DEPEND="
+ $(add_kdebase_dep libkdeedu)
+ editor? ( >=sci-chemistry/openbabel-2.2 )
+"
+DEPEND="${COMMON_DEPEND}
+ editor? ( >=dev-cpp/eigen-2.0.3 )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+KMEXTRACTONLY="
+ libkdeedu/kdeeduui/
+ libkdeedu/libscience/
+"
+
+src_configure(){
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen2)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ kde4-meta_src_configure
+}