summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2009-12-22 23:02:35 +0000
committerJonathan Callen <abcd@gentoo.org>2009-12-22 23:02:35 +0000
commitd2be7f4c34f4450b87a6094bba11e4e35bf037a6 (patch)
treecbee59c00b8feb96a364943864318f9655779c04 /kde-base/kcalc
parentPull in changes from overlay (diff)
downloadgentoo-2-d2be7f4c34f4450b87a6094bba11e4e35bf037a6.tar.gz
gentoo-2-d2be7f4c34f4450b87a6094bba11e4e35bf037a6.tar.bz2
gentoo-2-d2be7f4c34f4450b87a6094bba11e4e35bf037a6.zip
Add patch for prefix support (Solaris)
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'kde-base/kcalc')
-rw-r--r--kde-base/kcalc/ChangeLog6
-rw-r--r--kde-base/kcalc/files/kcalc-4.3.2-solaris-knumber_priv.patch13
-rw-r--r--kde-base/kcalc/kcalc-4.3.4.ebuild6
3 files changed, 23 insertions, 2 deletions
diff --git a/kde-base/kcalc/ChangeLog b/kde-base/kcalc/ChangeLog
index b9177352a3a4..f9b88496c261 100644
--- a/kde-base/kcalc/ChangeLog
+++ b/kde-base/kcalc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kcalc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/ChangeLog,v 1.138 2009/12/10 19:31:23 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/ChangeLog,v 1.139 2009/12/22 23:02:35 abcd Exp $
+
+ 22 Dec 2009; Jonathan Callen <abcd@gentoo.org>
+ +files/kcalc-4.3.2-solaris-knumber_priv.patch, kcalc-4.3.4.ebuild:
+ Add patch for prefix support (Solaris)
10 Dec 2009; Tomáš Chvátal <scarabeus@gentoo.org> -kcalc-4.3.1.ebuild:
Drop KDE SC-4.3.1.
diff --git a/kde-base/kcalc/files/kcalc-4.3.2-solaris-knumber_priv.patch b/kde-base/kcalc/files/kcalc-4.3.2-solaris-knumber_priv.patch
new file mode 100644
index 000000000000..24417d0ed6a6
--- /dev/null
+++ b/kde-base/kcalc/files/kcalc-4.3.2-solaris-knumber_priv.patch
@@ -0,0 +1,13 @@
+Desc: Fix missing isinf() for Solaris.
+Author: Heiko Przybyl <zuxez@cs.tu-berlin.de>
+--- kcalc-4.3.2/kcalc/knumber/knumber_priv.cpp.orig 2009-10-16 13:14:46.107208004 +0200
++++ kcalc-4.3.2/kcalc/knumber/knumber_priv.cpp 2009-10-16 13:14:56.639773377 +0200
+@@ -25,7 +25,7 @@
+
+ #include <QRegExp>
+
+-#if defined(Q_OS_SOLARIS) && defined(__SUNPRO_CC)
++#if defined(Q_OS_SOLARIS)
+ // Strictly by the standard, ininf() is a c99-ism which
+ // is unavailable in C++. The IEEE FP headers provide
+ // a function with similar functionality, so use that instead.
diff --git a/kde-base/kcalc/kcalc-4.3.4.ebuild b/kde-base/kcalc/kcalc-4.3.4.ebuild
index f5c1965c3de8..a5ad5f5c320e 100644
--- a/kde-base/kcalc/kcalc-4.3.4.ebuild
+++ b/kde-base/kcalc/kcalc-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/kcalc-4.3.4.ebuild,v 1.1 2009/12/01 10:07:10 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/kcalc-4.3.4.ebuild,v 1.2 2009/12/22 23:02:35 abcd Exp $
EAPI="2"
@@ -16,3 +16,7 @@ DEPEND="
dev-libs/gmp
"
RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris-knumber_priv.patch
+)