summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
committerChris Reffett <creffett@gentoo.org>2013-10-09 23:04:46 +0000
commitb5c71598bd396d68feb09813aad0c75a45f81a3a (patch)
treeb738e19f08caad8c28f1ee6bee7051613495e2de /kde-base/kde-l10n
parentFix docs installation, bug 487448 by Juergen Rose. Add -fno-strict-aliasing t... (diff)
downloadgentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.gz
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.tar.bz2
gentoo-2-b5c71598bd396d68feb09813aad0c75a45f81a3a.zip
Version bump KDE SC 4.11.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog7
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.11.2.ebuild91
2 files changed, 97 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 10721e68674c..54f683329c5e 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.204 2013/09/03 19:49:54 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.205 2013/10/09 23:03:51 creffett Exp $
+
+*kde-l10n-4.11.2 (08 Oct 2013)
+
+ 08 Oct 2013; Chris Reffett <creffett@gentoo.org> +kde-l10n-4.11.2.ebuild:
+ Version bump KDE SC 4.11.2
03 Sep 2013; Chris Reffett <creffett@gentoo.org> -kde-l10n-4.11.0.ebuild:
Drop KDE 4.11.0
diff --git a/kde-base/kde-l10n/kde-l10n-4.11.2.ebuild b/kde-base/kde-l10n/kde-l10n-4.11.2.ebuild
new file mode 100644
index 000000000000..ae1a2ed7498c
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.11.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.11.2.ebuild,v 1.1 2013/10/09 23:03:51 creffett Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://l10n.kde.org"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND="!<kde-base/konq-plugins-4.6"
+
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+# /usr/portage/distfiles $ ls -1 kde-l10n-*-${PV}.* |sed -e 's:-${PV}.tar.xz::' -e 's:kde-l10n-::' |tr '\n' ' '
+MY_LANGS="ar bg bs ca ca@valencia cs da de el en_GB es et eu fa fi fr ga gl he
+hi hr hu ia is it ja kk km ko lt lv mr nb nds nl nn pa pl pt pt_BR ro ru sk sl
+sr sv tg tr ug uk vi wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.xz )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_prepare() {
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:^ *add_subdirectory( *kdepim-runtime *):# no kdepim-runtime:g' {} +
+ find "${S}" -name CMakeLists.txt -type f \
+ -exec sed -i -e 's:^ *add_subdirectory( *kdepim *):# no kdepim:g' {} +
+
+ # bug 481106, please remove in 4.11.1 and later
+ use linguas_pl && rm "${S}"/${PN}-pl-${PV}/messages/kde-runtime/{accountwizard*,akonadi_*}.po
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_build handbook docs)
+ )
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}