summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-02-05 21:29:56 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-02-05 21:29:56 +0000
commit838ecd95df8bbd88a97f11a8954f3dcda20797b0 (patch)
tree36d49a04cbc2755799ef53d8edd0ad9a132b6fda /kde-base/kdebase
parentUpdated dependencies for X. This closes bug #14651. Put winex-20021123 into x86. (diff)
downloadgentoo-2-838ecd95df8bbd88a97f11a8954f3dcda20797b0.tar.gz
gentoo-2-838ecd95df8bbd88a97f11a8954f3dcda20797b0.tar.bz2
gentoo-2-838ecd95df8bbd88a97f11a8954f3dcda20797b0.zip
fix bug #15182
changed dependency to virtual/motif instead of openmotif (lesstif also works) fixed indention
Diffstat (limited to 'kde-base/kdebase')
-rw-r--r--kde-base/kdebase/ChangeLog6
-rw-r--r--kde-base/kdebase/kdebase-3.1-r1.ebuild93
2 files changed, 51 insertions, 48 deletions
diff --git a/kde-base/kdebase/ChangeLog b/kde-base/kdebase/ChangeLog
index 44e09c580b91..eaca2b0b49bd 100644
--- a/kde-base/kdebase/ChangeLog
+++ b/kde-base/kdebase/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kdebase
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.56 2003/02/01 20:30:58 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/ChangeLog,v 1.57 2003/02/05 21:29:56 hannes Exp $
+
+ 05 Feb 2003; Hannes Mehnert <hannes@gentoo.org> kdebase-3.1-r1.ebuild:
+ changed dep on motif to virtual/motif (lesstif also works), changed dep
+ to kdelibs-3.1-r2 (closes bug #15182, thanks to throstur@bylur.net)
01 Feb 2003; Jack Morgan <jmorgan@gentoo.org> kdebase-3.1.ebuild:
added ~sparc to keywords
diff --git a/kde-base/kdebase/kdebase-3.1-r1.ebuild b/kde-base/kdebase/kdebase-3.1-r1.ebuild
index ae911ffe3525..3aa0a3d9c773 100644
--- a/kde-base/kdebase/kdebase-3.1-r1.ebuild
+++ b/kde-base/kdebase/kdebase-3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.1-r1.ebuild,v 1.2 2003/01/31 20:00:21 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase/kdebase-3.1-r1.ebuild,v 1.3 2003/02/05 21:29:56 hannes Exp $
NEED_KDE_DONT_ADD_KDELIBS_DEP=1 # we're a special case, see below
inherit kde-dist
@@ -12,7 +12,7 @@ KEYWORDS="~x86 ~ppc"
newdepend ">=media-sound/cdparanoia-3.9.8
ldap? ( >=net-nds/openldap-1.2 )
pam? ( >=sys-libs/pam-0.73 )
- motif? ( >=x11-libs/openmotif-2.1.30 )
+ motif? ( virtual/motif )
encode? ( >=media-sound/lame-3.89b )
oggvorbis? ( >=media-libs/libvorbis-1.0_beta1 )
cups? ( net-print/cups )
@@ -26,7 +26,7 @@ newdepend ">=media-sound/cdparanoia-3.9.8
# special case, contd.: we need kdelibs >=3.1-r1, but not so that we get a version !=3.1
# so we told kde-functions:need-kde not to add a dep on kdelibs, and now we'll do it manually
# newdepend "( >=kde-base/kdelibs-3.1-r1 <kde-base/kdelibs-3.1.1 )" # bug in portage?
-newdepend "=kde-base/kdelibs-3.1-r1"
+newdepend "=kde-base/kdelibs-3.1-r2"
myconf="$myconf --with-dpms --with-cdparanoia"
@@ -40,64 +40,63 @@ use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
use ssl && myconf="$myconf --with-ssl" || myconf="$myconf --without-ssl"
use pam && myconf="$myconf --with-pam=yes" || myconf="$myconf --with-pam=no --with-shadow"
use java && myconf="$myconf --with-java=$(java-config --jdk-home)" || myconf="$myconf --without-java"
-src_compile() {
-
- kde_src_compile myconf configure
- kde_remove_flag kdm/kfrontend -fomit-frame-pointer
- kde_src_compile make
+src_compile() {
+ kde_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde_src_compile make
}
src_install() {
- kde_src_install
+ kde_src_install
- # cf bug #5953
- insinto /etc/pam.d
- #newins ${FILESDIR}/kscreensaver.pam kscreensaver
- newins ${FILESDIR}/kde.pam kde
+ # cf bug #5953
+ insinto /etc/pam.d
+ #newins ${FILESDIR}/kscreensaver.pam kscreensaver
+ newins ${FILESDIR}/kde.pam kde
- # startkde script
- cd ${D}/${KDEDIR}/bin
- patch -p0 < ${FILESDIR}/${PVR}/startkde-${PVR}-gentoo.diff || die
- mv startkde startkde.orig
- sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
- rm startkde.orig
- chmod a+x startkde
+ # startkde script
+ cd ${D}/${KDEDIR}/bin
+ patch -p0 < ${FILESDIR}/${PVR}/startkde-${PVR}-gentoo.diff || die
+ mv startkde startkde.orig
+ sed -e "s:_KDEDIR_:${KDEDIR}:" startkde.orig > startkde
+ rm startkde.orig
+ chmod a+x startkde
- # x11 session script
- cd ${T}
- echo "#!/bin/sh
+ # x11 session script
+ cd ${T}
+ echo "#!/bin/sh
${KDEDIR}/bin/startkde" > kde-${PV}
- chmod a+x kde-${PV}
- exeinto /etc/X11/Sessions
- doexe kde-${PV}
+ chmod a+x kde-${PV}
+ exeinto /etc/X11/Sessions
+ doexe kde-${PV}
- cd ${D}/${KDEDIR}/share/config/kdm || die
- sed -e "s:SessionTypes=:SessionTypes=kde-${PV},:" \
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ sed -e "s:SessionTypes=:SessionTypes=kde-${PV},:" \
-e "s:Session=${PREFIX}/share/config/kdm/Xsession:Session=/etc/X11/xdm/Xsession:" \
${FILESDIR}/${PVR}/kdmrc > kdmrc
- cp ${FILESDIR}/${PVR}/backgroundrc .
-
- #backup splashscreen images, so they can be put back when unmerging
- #mosfet or so.
- if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
- then
- cd ${D}/${KDEDIR}/share/apps
- cp -rf ksplash/ ksplash.default
- fi
-
- # Show gnome icons when choosing new icon for desktop shortcut
- dodir /usr/share/pixmaps
- mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
- rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
- cd ${D}/${KDEDIR}/share/apps/kdesktop/
- ln -sf /usr/share/pixmaps/ pics
-
- rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
+ cp ${FILESDIR}/${PVR}/backgroundrc .
+
+ #backup splashscreen images, so they can be put back when unmerging
+ #mosfet or so.
+ if [ ! -d ${KDEDIR}/share/apps/ksplash.default ]
+ then
+ cd ${D}/${KDEDIR}/share/apps
+ cp -rf ksplash/ ksplash.default
+ fi
+
+ # Show gnome icons when choosing new icon for desktop shortcut
+ dodir /usr/share/pixmaps
+ mv ${D}/${KDEDIR}/share/apps/kdesktop/pics/* ${D}/usr/share/pixmaps/
+ rm -rf ${D}/${KDEDIR}/share/apps/kdesktop/pics/
+ cd ${D}/${KDEDIR}/share/apps/kdesktop/
+ ln -sf /usr/share/pixmaps/ pics
+
+ rmdir ${D}/${KDEDIR}/share/templates/.source/emptydir
}
pkg_postinst() {
- mkdir -p ${KDEDIR}/share/templates/.source/emptydir
+ mkdir -p ${KDEDIR}/share/templates/.source/emptydir
}