summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commit588eb8e56926b65029e4de63aa398e51ed8cc9b8 (patch)
tree356a5e95843b62ad54fc9c77facba6ff67c4db94 /kde-base/kdebindings-ruby
parentx86 stable, bug 323729 (diff)
downloadgentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.gz
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.tar.bz2
gentoo-2-588eb8e56926b65029e4de63aa398e51ed8cc9b8.zip
[kde-base] Bump KDE SC 4.4.5 =)
(Portage version: 2.2_rc67_p182/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdebindings-ruby')
-rw-r--r--kde-base/kdebindings-ruby/ChangeLog8
-rw-r--r--kde-base/kdebindings-ruby/kdebindings-ruby-4.4.5.ebuild93
2 files changed, 100 insertions, 1 deletions
diff --git a/kde-base/kdebindings-ruby/ChangeLog b/kde-base/kdebindings-ruby/ChangeLog
index 34c83067223b..ec2462bbccb1 100644
--- a/kde-base/kdebindings-ruby/ChangeLog
+++ b/kde-base/kdebindings-ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.14 2010/06/27 17:45:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.15 2010/06/30 15:36:39 alexxy Exp $
+
+*kdebindings-ruby-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-ruby-4.4.5.ebuild:
+ Version bump
27 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
kdebindings-ruby-4.4.4.ebuild:
diff --git a/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.5.ebuild b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.5.ebuild
new file mode 100644
index 000000000000..fe1fe25cc9b2
--- /dev/null
+++ b/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.5.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.4.5.ebuild,v 1.1 2010/06/30 15:36:39 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebindings"
+KMMODULE="ruby"
+WEBKIT_REQUIRED="optional"
+
+USE_RUBY="ruby18"
+
+inherit kde4-meta ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS="~amd64 ~x86"
+IUSE="akonadi debug okular phonon plasma qscintilla qwt semantic-desktop"
+
+DEPEND="
+ $(add_kdebase_dep smoke 'akonadi?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?')
+"
+
+RDEPEND="${DEPEND}
+ !dev-ruby/qt4-qtruby
+"
+
+KMEXTRACTONLY="
+ ruby/krossruby
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-linkage.patch
+)
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ kde4-meta_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-meta_src_prepare
+
+ sed -i -e "s#smoke/smoke.h#smoke.h#" \
+ ruby/qtruby/src/handlers.cpp \
+ ruby/qtruby/src/marshall.h \
+ ruby/qtruby/src/marshall_types.h \
+ ruby/qtruby/src/Qt.cpp \
+ ruby/qtruby/src/qtruby.cpp \
+ ruby/qtruby/src/qtruby.h \
+ ruby/qtruby/src/smokeruby.h || die
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_enable plasma PLASMA_RUBY)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_enable phonon PHONON_RUBY)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_enable qscintilla QSCINTILLA_RUBY)
+ $(cmake-utils_use_enable qwt QWT_RUBY)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_enable semantic-desktop SOPRANO_RUBY)
+ $(cmake-utils_use_enable webkit QTWEBKIT_RUBY)
+ -DENABLE_KROSSRUBY=OFF
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ )
+ kde4-meta_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_install
+}